Closed Bug 1613519 Opened 5 years ago Closed 5 years ago

Add an option not to restore pinned tabs at startup

Categories

(Firefox :: Session Restore, enhancement)

74 Branch
enhancement
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: chris.cushman, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/74.0

Steps to reproduce:

If I have pinned tabs and close the browser without closing the tab then they will pop back up when opening a new instance of Firefox.

Steps to repro:

  1. Pin a tab.
  2. Close the browser.
  3. Open a new instance of Firefox Nightly by clicking the shortcut (if you right click on the shortcut and choose to Open new window or Open new tab then it will work and wont reproduce the bug)

Actual results:

Firefox Nightly will open but the pinned tabs you had in a previous session will pop up along with your homepage.

Expected results:

All closed tabs, even if pinned, should not open back up after the browser closes.

(In reply to chris.cushman from comment #0)

If I have pinned tabs and close the browser without closing the tab then they will pop back up when opening a new instance of Firefox.

"Pinned Tabs are small, can't be closed accidentally and open automatically when you start Firefox."
Pinned Tabs: keep favorite websites open and just a click away

This is Invalid as filed and would likely get closed as Wontfix as a request to change the behavior that's been in place since 2010. I'm changing it to a request for an "Always load pinned tabs" option like the one in Vivaldi.

Blocks: pinnedtabs
Type: defect → enhancement
Component: Untriaged → Session Restore
See Also: → 575560
Summary: Pinned tabs open back up after closing window → Add an option not to restore pinned tabs at startup

Yeah, the whole point of pinning tabs is to make them persistent. I don't see us adding this option.

Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: