Closed Bug 1613784 Opened 3 years ago Closed 3 years ago

Add Root Cause Field as Program Flag

Categories

(bugzilla.mozilla.org :: Administration, task)

task
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: emceeaich, Assigned: emceeaich)

Details

(Keywords: bmo-goal)

Attachments

(2 files, 1 obsolete file)

We'll need some new fields in Bugzilla for recording root causes. They could be added in the upcoming change window at the end of Feburary 2020.

Looks good to me. Could you please add "Poor Architecture" to this list as well? I have added short description for some of these that could be a bit confusing. https://docs.google.com/document/d/1FFEGsmoU8T0N8R9kk-MXWptOPtXXXRRIe4vQo3_HgMw/edit

Flags: needinfo?(tmaity)

I can, I also saw corner case in the document and will add it.

Now, next question is how soon do you want the field?

  • I can add it as a standard field during the change window on April 18
  • I can add it now, but it'll appear as a program flag in the section with tracking, status, and program flags
Flags: needinfo?(tmaity)

(In reply to Emma Humphries, Bugmaster β˜•οΈπŸŽΈπŸ§žβ€β™€οΈβœ¨ (she/her) [:emceeaich] (UTC-8) needinfo? me from comment #0)

We'll need some new fields in Bugzilla for recording root causes. They could be added in the upcoming change window at the end of Feburary 2020.

If you are talking about a tracking flag of type 'project' then you would not need to wait til a change window to occur. If you are talking about adding a custom field to the bugs table then yes we would need to wait. Could this field be a tracking project flag?

Flags: needinfo?(ehumphries)

Yes, I think this will end up as a project flag.

Flags: needinfo?(ehumphries)

Could you please share a snapshot of how this would look? Or example of an existing flag that I can relate to would be helpful

Flags: needinfo?(tmaity)

I can't create program flags on dev, but this is what existing program flags look like when you edit a bug.

Attached image root-cause-flag.png β€”

Slightly better version now that we enabled editing program flags on dev, I couldn't get the dropdown to show.

Attachment #9136911 - Attachment is obsolete: true

Thanks. Looks good.
Here is the updated list of RCAs:

Requirement Error

Poor Architecture

Design Error

Coding Error

  • Syntax Error
  • Logical Error
  • Semantic Error
  • Runtime Error
  • Unhandled exceptions
  • Internal API issue
  • Network Issue
  • Compatibility Issue
  • Concurrency Issue
  • Other: Anything not mentioned above

Testing Error

External Software Affecting Firefox

Standards

Localization Error

Performance Error

System Configuration

Infrastructure/build Error

Communication Issues

Product Decision

Corner Case

yes please. Thanks Emma

Flags: needinfo?(tmaity)

Here's the new flag as edited. I'm going to set Root Cause to ? for the phase II bugs you listed so there's an easy query for pending bugs.

Attachment #9137882 - Flags: feedback?(tmaity)
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Comment on attachment 9137882 [details]
Screenshot_2020-04-02 Release Tracking Flags.png

looks good. Thank you Emma
Comment on attachment 9137882 [details]
Screenshot_2020-04-02 Release Tracking Flags.png

The changes requested were implemented. Thanks a ton to Emma, appreciate your help!
Attachment #9137882 - Flags: feedback?(tmaity) → feedback?
You need to log in before you can comment on or make changes to this bug.