Closed Bug 1613976 Opened 8 months ago Closed 8 months ago

TEST-UNEXPECTED-OK | /mediacapture-record/MediaRecorder-peerconnection.https.html | expected TIMEOUT when Gecko 74 merges to Beta on 2020-02-10

Categories

(Core :: WebRTC: Signaling, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla74
Tracking Status
thunderbird_esr60 --- unaffected
thunderbird_esr68 --- unaffected
firefox-esr68 --- unaffected
firefox72 --- unaffected
firefox73 --- unaffected
firefox74 + fixed

People

(Reporter: dluca, Assigned: aryx)

References

(Blocks 1 open bug, Regression)

Details

Attachments

(1 file)

[Tracking Requested - why for this release]:

Central as beta simulation:
https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Cretry%2Cusercancel%2Crunnable&revision=179426220158fdf53c91451d1d4f37fed4033c64&selectedJob=287917194

Log:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=287917194&repo=try&lineNumber=1634

INFO - TEST-OK | /cors/access-control-expose-headers-parsing.window.html | took 731ms
[task 2020-02-07T11:35:47.261Z] 11:35:47     INFO - TEST-START | /cors/basic.htm
[task 2020-02-07T11:35:47.265Z] 11:35:47     INFO - Closing window 14
[task 2020-02-07T11:35:47.509Z] 11:35:47  WARNING - Traceback (most recent call last):
[task 2020-02-07T11:35:47.509Z] 11:35:47  WARNING -   File "/builds/worker/workspace/build/venv/lib/python2.7/site-packages/wptserve/handlers.py", line 332, in __call__
[task 2020-02-07T11:35:47.510Z] 11:35:47  WARNING -     rv = self.func(request, response)
[task 2020-02-07T11:35:47.510Z] 11:35:47  WARNING -   File "/builds/worker/workspace/build/tests/web-platform/tests/cors/resources/cors-makeheader.py", line 19, in main
[task 2020-02-07T11:35:47.510Z] 11:35:47  WARNING -     response.headers.set("Access-Control-Allow-Origin", origin)
[task 2020-02-07T11:35:47.510Z] 11:35:47  WARNING -   File "/builds/worker/workspace/build/venv/lib/python2.7/site-packages/wptserve/response.py", line 333, in set
[task 2020-02-07T11:35:47.510Z] 11:35:47  WARNING -     value = _maybe_encode(value)
[task 2020-02-07T11:35:47.510Z] 11:35:47  WARNING -   File "/builds/worker/workspace/build/venv/lib/python2.7/site-packages/wptserve/response.py", line 317, in _maybe_encode
[task 2020-02-07T11:35:47.510Z] 11:35:47  WARNING -     raise TypeError("Unexpected value in ResponseHeaders: %r" % s)
[task 2020-02-07T11:35:47.510Z] 11:35:47  WARNING - TypeError: Unexpected value in ResponseHeaders: None
[task 2020-02-07T11:35:47.510Z] 11:35:47  WARNING - 
[task 2020-02-07T11:35:47.953Z] 11:35:47     INFO - ......
[task 2020-02-07T11:35:47.953Z] 11:35:47     INFO - TEST-OK | /cors/basic.htm | took 692ms
[task 2020-02-07T11:35:47.954Z] 11:35:47     INFO - TEST-START | /cors/client-hint-request-headers-2.tentative.htm
[task 2020-02-07T11:35:47.958Z] 11:35:47     INFO - Closing window 18
[task 2020-02-07T11:35:48.513Z] 11:35:48     INFO - .
[task 2020-02-07T11:35:48.513Z] 11:35:48     INFO - TEST-OK | /cors/client-hint-request-headers-2.tentative.htm | took 552ms
[task 2020-02-07T11:35:48.513Z] 11:35:48     INFO - TEST-START | /cors/client-hint-request-headers.htm
[task 2020-02-07T11:35:48.513Z] 11:35:48     INFO - Closing window 22
[task 2020-02-07T11:35:49.253Z] 11:35:49     INFO - .....
[task 2020-02-07T11:35:49.253Z] 11:35:49     INFO - TEST-OK | /cors/client-hint-request-headers.htm | took 744ms
[task 2020-02-07T11:35:49.253Z] 11:35:49     INFO - TEST-START | /cors/cors-safelisted-request-header.any.html
[task 2020-02-07T11:35:49.255Z] 11:35:49     INFO - Closing window 26
[task 2020-02-07T11:35:50.647Z] 11:35:50     INFO - ...............
[task 2020-02-07T11:35:50.647Z] 11:35:50     INFO - TEST-OK | /cors/cors-safelisted-request-header.any.html | took 1396ms
[task 2020-02-07T11:35:50.648Z] 11:35:50     INFO - TEST-START | /cors/cors-safelisted-request-header.any.worker.html
[task 2020-02-07T11:35:50.651Z] 11:35:50     INFO - Closing window 30
Flags: needinfo?(docfaraday)

Looks like patches in bug 1591199 somehow cause fewer timeouts on Android here, a good thing generally.

The meta file is full of if release_or_beta and (os == "android") and if os == "android": TIMEOUT.

What's the rationale behind using release_or_beta as a differentiator in wpt exception files? Isn't that going to lead to surprises?

Assignee: nobody → aryx.bugmail
Status: NEW → ASSIGNED

(In reply to Jan-Ivar Bruaroey [:jib] (needinfo? me) from comment #1)

What's the rationale behind using release_or_beta as a differentiator in wpt exception files? Isn't that going to lead to surprises?

Testing the shipping configuration is preferred to actively enabling a feature in the test which is disabled by default in the product.

Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/a16dc4e5cc1e
Adjust expectations for MediaRecorder-peerconnection.https.html on Android with Beta and Release.

Landed it without review as it's not part of the build to prevent test failures after the merge of central to beta tomorrow. Order of error messages got reordered to keep them in sync with the output of the failing task run (also reordered in the test?).

Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla74
Flags: needinfo?(docfaraday)
You need to log in before you can comment on or make changes to this bug.