Can't look at mail, refuses to browse the internet.

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Dave Froehlich, Assigned: Matti)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Sometimes I will try to browse to a website and it will crash Mozilla 1.0 
and when I try to restart it refuses to open the browser window.  I cannot 
look at old mail.  Yes, this is serious.  The only thing it does is give the 
splash window (starting up).  That goes away and the mouse cursor is 
replaced by a spinning OS X color wheel forever until it is force quit.

HELP!

I can get it to open to look at a local graphic file but anything related to the 
internet makes it lock.

Last time this happened it took a few days before it would work again.

Please help.

Thanks.

Dave...

IE Works perfectly, so it is NOT my internet connection.
Apple Mail works perfectly too.
(Reporter)

Comment 1

16 years ago
OK, I created a new profile and I am browsing again.  But that doesn't solve the
problem.  I cannot look at any of my old mail.  How can I FIX the old profile so
that I can read it again?  Please help, this is EXTREMELY IMPORTANT.  This is
the second time this has happened.  Last time it took almost a week before I
could look at my mail again.

Please Help.

I'm NOT the only one with this problem, as I check through the BUGS.
What did other people do to fix the problem?  Until it's fixed I am going to
have to use OUTLOOK EXPRESS to read my mail and HOPE that my customers e-mail me
again.  I have their stuff and Mozilla **** out so I can no longer contact
them. Nice!
So please help.

Thanks,


Dave...

Comment 2

16 years ago
you should be able to copy your emails to the new profile fairly easily:
1) Create new profile (this you already done)
2) Create the mail accounts
3) Quit Mozilla
4) Find where the files for your old profile is. I'm not sure where it's stored
in OSX. In linux, it's in ~/.mozilla/. You should be able to find that out by
searching for the file "prefs.js".
5) In the profile directory, (eg, ~/.mozilla/default/qnyecokq.slt/), you should
see a "Mail" subdirectory, which is where mailboxes are stored.
6) Just copy the mailbox files to the corresponding directory in your new
profile. (eg, you might see Inbox and Inbox.msf, Inbox is the mailbox, Inbox.msf
is some index file)

Comment 3

16 years ago
Dave, it sounds like your profile may be getting corrupted by these crashes.
Obviously, that's a bad thing. Knowing more about the crash may help us diagnose
the problem.

You can enable Crash Reporting in the Mac OS X Console application. Then, each
time Mozilla crashes, it will append a "crash report" to
~/Library/Logs/Mozilla.crash.log. The next time you crash, file a bug about it
using the Bugzilla Helper at
[http://www.mozilla.org/quality/help/bug-form.html], and attach the crash report
to it.

It sounds like you use a POP e-mail account. You might find it worthwhile
configuring your account to leave messages on the server until you explicitly
delete them. That way, they won't be deleted just by downloading them, and you
won't "lose your e-mail" just because of a software problem.
Severity: critical → normal
(Reporter)

Comment 4

16 years ago
Hello All,
  I threw the cache in the trash and that solved the problem.  So I guess the
bug,  if there is one, is that there is no auto clear feature of the cache like
Netscape had.  I have a broadband connection so the cache fills up fast.
   I now believe that it is not the website that I browse to that crashes
Mozilla, it is the fact that Mozilla is looking at a new page and has no place
to cache it when the cache folder is full.  Maybe the bug fix could be to clear
the cache when full.  I am quite sure that I have solved the problem.

Thanks for everybody's help.

Dave...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

16 years ago
Hello Again,
One last comment from Dave.
Mozilla did not seem to crash when the problem took place.  All the pull down
menus were at the top of the screen as usual, only I couldn't pull any of them
down.  If I tried to start another copy of Mozilla, I got the message that I
cannot run more than one Mozilla at a time.  So I don't think it crashed or even
locked.  It was just busy trying to cache a file.

Maybe a new feature can be: If cache is full then don't cache.

Dave...
(Assignee)

Comment 6

16 years ago
no patch = not fixed
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
(Assignee)

Comment 7

16 years ago
-> wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

16 years ago
The problem occured again so I trashed the cache again and I will have to say:
WFM!  It works in one second. WFM

It is certain websites that seem to crash the browser and not that the cache is
full.  I am not an expert on this but definately, browsing to certain websites
crash Mozilla.  The crash doesn't always affect the cache.

Dave...
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.