External files must have same encoding (8-bit vs. Unicode)

NEW
Assigned to

Status

()

16 years ago
9 years ago

People

(Reporter: grasso, Assigned: jshin1987)

Tracking

({intl})

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1a) Gecko/20020611
BuildID:    2002061104

If an HTML file includes a javascript file, both must have the same encoding,
i.e. 8bit and unicode must not become mixed. Else, the javascript is not executed.

http://grassomusic.de/testcases/standard.htm
http://grassomusic.de/testcases/unicode.htm
http://grassomusic.de/testcases/unicode-be.htm



Reproducible: Always
Steps to Reproduce:
.

Actual Results:  .

.

Comment 1

16 years ago
---> Internationalization

There are other bugs where this has come up, but I don't know
the numbers offhand. I think this is a duplicate of one of them;
nhotta or jst will know -

Compare bug 106360, "charset parameter for external JS ignored"
(marked Verified Fixed)
Assignee: rogerl → yokoyama
Component: JavaScript Engine → Internationalization
QA Contact: pschwartau → ruixu
Summary: Files must have same encoding (8-bit versus unicode) → External files must have same encoding (8-bit vs. Unicode)

Updated

16 years ago
Keywords: intl
QA Contact: ruixu → ylong

Comment 2

16 years ago
Confirm the problem.

This is same problem as bug 152814 for me.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
estimation of work 3-5 days

Comment 4

14 years ago
I think both roy and me are off mozilla for more than 2 years. If these bugs are
still here now, I think the real stauts is 'won't fix'. If you want to reopen
it, please find a new owner for it first. 
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX

Comment 5

14 years ago
Mass Reassign Please excuse the spam
Assignee: tetsuroy → nobody

Comment 6

14 years ago
Mass Re-opening Bugs Frank Tang Closed on Wensday March 02 for no reason, all
the spam is his fault feel free to tar and feather him
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 7

14 years ago
Reassigning Franks old bugs to Jungshik Shin for triage - Sorry for spam
Assignee: nobody → jshin1987
Status: REOPENED → NEW
QA Contact: amyy → i18n
You need to log in before you can comment on or make changes to this bug.