2gstratus.org - tag insert doesn't work in phpbb

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
--
enhancement
RESOLVED WORKSFORME
16 years ago
3 years ago

People

(Reporter: ytseMatt, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020722
BuildID:    2002072204

On sites such as phpBB sites, MoveableType sites, etc...  When selecting the
text edit features (such as adding a hyperlink), Mozilla doesn't properly insert
the tags.

Reproducible: Always
Steps to Reproduce:
1.create a message
2.highlight text to add a hyperlink
3.click the URL button

Actual Results:  the tag gets added to the end of the text box and not around
the highlighted text

Expected Results:  the tags should be added around the highlighted text

Comment 1

16 years ago
reporter: can you reproduce this bug with a recent build of mozilla (for
example, 1.2beta)? if so, please comment again with details. if not, please
resolve this bug as WORKSFORME. thanks.
(Reporter)

Comment 2

16 years ago
This is still a bug in 1.2 Beta.  I have tried it both on a Windows XP Pro
system and on a Mac OS 10.2 (Jaguar) System.  Both systems still exhibit this
bug.  In most cases, you can no longer even get the "text format buttons" to
appear in the web page.  And when they are there, they still do not work properly.

I suggest trying it on one of the pages using Internet Explorer, just to see
what the buttons were designed to do.  From there you may be able to make the
proper adjustments to Mozilla.
Target Milestone: --- → mozilla1.2beta

Comment 3

16 years ago
having examined it, I now see what you are talking about.

this is not a mozilla bug as such - if you look at the phpbb forum code, you
find this:

// Insert at Claret position. Code from
// http://www.faqts.com/knowledge_base/view.phtml/aid/1052/fid/130

and looking at that page, the methods given are non-standard things which only
work in Internet Explorer and Netscape 4. The solution here is to work out how
to do it in mozilla (if it's possible), and then get the phpbb folks to include
it, and the sites which use phpbb (which now includes mozillazine!) to update.

so... first question is whether it's possible in mozilla... will have to consult
 on that...
Summary: text format feature → insert text (tag) at caret position doesn't work in phpbb

Comment 4

16 years ago
having just asked around on IRC, I'm still not sure.

reassigning, in the hopes that the DOM folks can sort it out. if this is already
possible in mozilla, then please say how and throw it over to the evang folks.
if it isn't, then this is a request to implement something!

(also, resetting target milestone - that field is for the person working on the
bug to say when they think it's going to be fixed by... please don't change it
if you're not that person)
Assignee: sgehani → anthonyd
Status: UNCONFIRMED → NEW
Component: XP Apps → DOM Traversal-Range
Ever confirmed: true
QA Contact: paw → lchiang
Target Milestone: mozilla1.2beta → ---

Comment 5

16 years ago
ok... after discussion on IRC, mozilla can't do this yet.

I have filed an RFE - bug 178683, which may get fixed or duped to stuff that's
already happening... when there is an implementation, then we will need to get
phpbb (http://www.phpbb.com/) and others to use it, and then we'll need to get
sites like the one in this bug to adopt it.

reassigning this to tech evang for the last bits...
Severity: normal → enhancement
Component: DOM Traversal-Range → US General
Depends on: 178683
OS: Windows XP → All
Product: Browser → Tech Evangelism
Hardware: PC → All
Summary: insert text (tag) at caret position doesn't work in phpbb → tag insert doesn't work in phpbb
Version: other → unspecified

Comment 6

16 years ago
oops... reassigning to default owner as well.
Assignee: anthonyd → susiew
QA Contact: lchiang → zach

Updated

16 years ago
Summary: tag insert doesn't work in phpbb → 2gstratus.org - tag insert doesn't work in phpbb
It seems this bug is not relevant anymore now as the PhpBB has changed their
Javascript code to respect DOM standards :)

Comment 8

15 years ago
tech evang june 2003 reorg
Assignee: susiew → english-us
QA Contact: zach → english-us

Comment 9

15 years ago
Isn't this a dupe of Bug 88049?

Prog.

Comment 10

15 years ago
More like, isn't this *related* to the solution in Bug 88049?

Sorry for the spam,

Prog.

Comment 11

15 years ago
yes - that's why it's marked to depend on another bug. (Although it's not the
right bug - that bug was marked WFM because it was fixed elsewhere)

But this is a tech evang bug - and actually the site this bug is about seems to
have changed their board system from phpBB to "Invision Power Board" anyway.

Comment 12

13 years ago
worksforme now.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.