Closed Bug 1614560 Opened 2 years ago Closed 2 years ago

26.21% build times (windows2012-32) regression on push 2d6fc4d1275b96db707e197697a5a6f551a2d271 (Mon February 10 2020)

Categories

(Firefox Build System :: Source Code Analysis, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: alexandrui, Unassigned)

References

(Regression)

Details

(Keywords: perf-alert, regression)

We have detected a build metrics regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=2d6fc4d1275b96db707e197697a5a6f551a2d271

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

26% build times windows2012-32 opt taskcluster-c5.4xlarge 2,101.01 -> 2,651.73

You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=24906

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Automated_Performance_Testing_and_Sheriffing/Build_Metrics

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Flags: needinfo?(bpostelnicu)
Component: Performance → Source Code Analysis
Product: Testing → Firefox Build System
Version: Version 3 → unspecified
Blocks: 1614561
No longer blocks: 1607747

This looks like a typical change that forces everything to be rebuilt, so this is also accompanied with a drop in sccache hit rate, which goes back up on following pushes, and it looks like the build times are back to more or less normal times now...

The build times jobs are running on different machines from commit to commit. I was lucky that I even found the bug causing the regression. So I have to believe you :)

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX

:glandium, like always is right, is right, clearing the needinfo.

Flags: needinfo?(bpostelnicu)
You need to log in before you can comment on or make changes to this bug.