hover over image does not show alt text

VERIFIED DUPLICATE of bug 25537

Status

defect
VERIFIED DUPLICATE of bug 25537
17 years ago
15 years ago

People

(Reporter: euston, Assigned: samir_bugzilla)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

()

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1b) Gecko/20020721
BuildID:    20020721

Normally, netscape and ie6 will show the alt text when you hover the mouse over
an image. Mozilla does not do this.

Reproducible: Always
Steps to Reproduce:
1. Load a page with images with alt text imbedded (either yahoo.co.uk, or
news.bbc.co.uk
2. Hover the mouse over an image and leave for a second
3. 

Actual Results:  Alt text does not display. Do the same with ie6 to show this
working.

Expected Results:  Alt text should display in a box, and disappear when the
mouse moves
Mozilla is correct. ALT is for alternate text (when the image can't be loaded
you see the ALT text instead). Use TITLE for a tooltip.
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → INVALID
This may technically be CORRECT behaviour (ie, not a programming bug), but it is
not desirable. Both Netscape and IE6 show the alt text on hover, but Mozilla
doesn't. Why? Web sites (in particular news.bbc.co.uk) use the alt text to show
more information that would otherwise be shown - in particular for
news.bbc.co.uk, they often use an image only to illustrate a news item - the
hover text gives you a summary of the article. This is very useful, and I use it
all the time. This is at very least (IMHO) a desired feature for a future release. 

P.s. What does "Use TITLE for a tooltip." mean?
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
There is a page that was used for the original discussion, 
http://ppewww.ph.gla.ac.uk/~flavell/alt/alt-text.html. It seems that the site is
currently down, so please use the following link
http://www.google.com/search?q=cache%3Ahttp%3A%2F%2Fppewww.ph.gla.ac.uk%2F%7Eflavell%2Falt%2Falt-text.html
Another document at the same site:
http://www.google.com/search?q=cache%3Ahttp%3A%2F%2Fppewww.ph.gla.ac.uk%2F~flavell%2Falt%2Falt-more.html%23popups

Also see bug 1995 comment 50 and bug 22839.

A tooltip is the yellow box with text in it. So you can use something like:
  <img src="blah.jpg" alt="blah" title="blahblah is nice">
"blahblah is nice" will be displayed in a yellow box when you move your mouse
over the image. Because TITLE="..." can be used for a tooltip and ALT="..." was
meant for other things (see links above), Mozilla will only display TITLE="..."
as tooltip.
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago17 years ago
Resolution: --- → INVALID
-> REOPEN
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 25537 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago17 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.