Closed Bug 161470 Opened 20 years ago Closed 20 years ago

Ability to edit (bug number in) comments or get a preview before post.

Categories

(Bugzilla :: Creating/Changing Bugs, enhancement)

2.17
enhancement
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 540

People

(Reporter: jasonb, Assigned: myk)

Details

I have an unfortunately habit of (too often for my liking) getting mental
dyslexia and entering the wrong bug number in comment text.  So, rather than
saying b*g 12345, I'll enter b*g 12344 - or something similar.  (Using "b*g" so
that no hyperlink will be needlessly created here.)

In order to "correct" this I need to post another comment with the correction,
or just leave it alone.

It would be immensely helpful in terms of cutting down correction "spam" if one
of the following two were possible:

1. Edit an existing comment in the database - so long as it is your own.  This
could perhaps be limited only to changing the bug number if people think that
history / accountablity should remain.

2. Cancel a comment so that it can be entered again.  (So long as people *don't*
think that history / accountability should remain.)  This would have the added
benefit of users being able to remove their own spam / inappropriate messages
from the database.

3. After entering a comment, Bugzilla could display it with an Edit / Confirm /
Cancel dialogue so that the poster has a last chance to check what they've
entered as it will actually appear.  (Frequently when I make the mistake of
entering the wrong bug number, I only "catch" it later when looking at its final
hypertext form and seeing that there's a line through it - meaning that I'd
referenced a closed bug rather than the open one that I'd intended.)
Dupe of bug 540 for the editing part, see bug 40896 for the preview mode thing

*** This bug has been marked as a duplicate of 540 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Verifying resolution of all bugs I've reported.
Status: RESOLVED → VERIFIED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.