Closed Bug 1614771 Opened 1 year ago Closed 1 year ago

Run `./mach addtest` with Python 3

Categories

(Testing :: General, task)

Version 3
task
Not set
normal

Tracking

(firefox75 fixed)

RESOLVED FIXED
mozilla75
Tracking Status
firefox75 --- fixed

People

(Reporter: ahal, Assigned: hamzah18051, Mentored)

References

Details

Attachments

(1 file)

To get this command running in Python 3, remove it from the blacklist in the root topsrcdir/mach driver. Then try running it with ./mach addtest. Expect errors, and fix them as you run into them. Be sure to try out all arguments / options on the command line. See the --help for a reference.

The main implementation is in testing/mach_commands.py (look for the AddTest class). Please note that file still contains Python 2 commands, so anything that runs at import time will need to be compatible with both 2 and 3 until everything is switched over. The addtest implementation itself can be Python 3 only.

Hey Hamzah, this might be a good one to help get you started. Let me know if you need a hand with the contribution process or anything else.

p.s I think I accidentally closed a chat window with you on Riot.. but feel free to reach out to me there again too.

Flags: needinfo?(hamzah18051)

I'll start working on it and put a PR as soon as I am done.

Flags: needinfo?(hamzah18051)
Assignee: nobody → hamzah18051
Status: NEW → ASSIGNED
Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/752a464c8ec8
Run `./mach addtest` with Python 3 r=ahal
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla75
Regressions: 1615656
Blocks: 1615656
No longer regressions: 1615656
Duplicate of this bug: 1615656
You need to log in before you can comment on or make changes to this bug.