Closed Bug 1614827 Opened 10 months ago Closed 9 months ago

Fission - PiP from youtube subframe doesn't work

Categories

(Toolkit :: Video/Audio Controls, defect, P3)

75 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1575868
Fission Milestone M6

People

(Reporter: wtds.trabalho, Unassigned)

References

(Blocks 1 open bug, )

Details

Attachments

(5 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

If I try to force PiP, the modal try to appears but close after.

Actual results:

  • I can't use PiP from that site youtube video iframe.
  • I can't run PiP from incorporated video

Expected results:

Run PiP from incorporated Youtube videos.

Thanks!

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:75.0) Gecko/20100101 Firefox/75.0
20200211094607

Works for me.

Has STR: --- → yes
Component: Untriaged → Video/Audio Controls
Product: Firefox → Toolkit
Summary: PiP, I can't open modal for incorporated video (Youtube) → PiP, I can't open modal for embedded video (Youtube)
Version: 68 Branch → 75 Branch
Blocks: videopip

(In reply to Gingerbread Man from comment #1)

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:75.0) Gecko/20100101 Firefox/75.0
20200211094607

Works for me.

Same here on both beta and nightly.

Reporter, can you reproduce on a clean profile?

Flags: needinfo?(wtds.trabalho)

Hi,

I can try. I will try as soon as possible.

Thanks!

Hi,

now I can see, but when I click, nothing happens.

Thanks!

Any errors in the browser console (ctrl-shift-j) when you click the item and nothing happens?

Thanks Gijs...

Browser console:

00:24:27.856 pictureinpicture.opened_method - Unknown scalar. 3
00:24:28.993 Request for fullscreen was denied because of FeaturePolicy directives. base.js:1164:37
00:24:29.005 TypeError: Fullscreen request denied base.js:1164:38
00:24:29.124 pictureinpicture.opened_method - Unknown scalar.

view-source:https://www.youtube.com/yts/jsbin/player_ias-vflp5fPn0/en_US/base.js:

hr=function(a){a.requestFullscreen?a.requestFullscreen(void 0):a.webkitRequestFullscreen?a.webkitRequestFullscreen():a.mozRequestFullScreen?a.mozRequestFullScreen():a.msRequestFullscreen?a.msRequestFullscreen():a.webkitEnterFullscreen&&a.webkitEnterFullscreen()};
Flags: needinfo?(wtds.trabalho) → needinfo?(gijskruitbosch+bugs)

00:24:27.856 pictureinpicture.opened_method - Unknown scalar. 3

This scalar is definitely defined ( https://searchfox.org/mozilla-central/source/toolkit/components/telemetry/Scalars.yaml#1022 , though only for Windows... I filed bug 1616045 for this.

The fullscreen requests should be unrelated.

However, I'm confused because in comment #3 you suggested you'd try a clean profile, but the screenshots you posted later have loads of add-on icons in the toolbar. Did you actually try a clean profile?

Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(wtds.trabalho)

Hi<

Yes, I will post a print in a clean profile.

Thanks!

Sorry. Now I can open PiP in a clean windows...

But I've got that error in console:

23:04:57.503 can't access property "removeAttribute", controlsOverlay is null 2 PictureInPictureChild.jsm:725
    onMouseOverVideo resource://gre/actors/PictureInPictureChild.jsm:725
    checkLastMouseMove resource://gre/actors/PictureInPictureChild.jsm:659
    mousemoveDeferredTask resource://gre/actors/PictureInPictureChild.jsm:390
    _runTask resource://gre/modules/DeferredTask.jsm:333
    _timerCallback resource://gre/modules/DeferredTask.jsm:305
    _timerCallback resource://gre/modules/DeferredTask.jsm:324
    callback resource://gre/modules/DeferredTask.jsm:179
    (Async: ChromeUtils::IdleDispatch handler)
    _startIdleDispatch resource://gre/modules/DeferredTask.jsm:192
    callback resource://gre/modules/DeferredTask.jsm:173

Thanks!

Flags: needinfo?(wtds.trabalho) → needinfo?(gijskruitbosch+bugs)
Attached image error-pip-clean.png

But not working in my current profile with all addons disabled...
Can you help me to find the problem. Not is the addons.

Thanks!

I'm testing HTTP/3 and other browsers flags, WebGL, Webrender.
Maybe that things have influence:

https://gist.github.com/wellington1993/f529adcb88789dd6989c54565626becc

Thanks!

Attached image erros-no-addons.png

Non clean profile, but without enabled addons.
https://gist.github.com/wellington1993/f529adcb88789dd6989c54565626becc

Thanks!

(In reply to Wellington Torrejais da Silva from comment #10)

Sorry. Now I can open PiP in a clean windows...

But I've got that error in console:

23:04:57.503 can't access property "removeAttribute", controlsOverlay is null 2 PictureInPictureChild.jsm:725
    onMouseOverVideo resource://gre/actors/PictureInPictureChild.jsm:725
    checkLastMouseMove resource://gre/actors/PictureInPictureChild.jsm:659
    mousemoveDeferredTask resource://gre/actors/PictureInPictureChild.jsm:390
    _runTask resource://gre/modules/DeferredTask.jsm:333
    _timerCallback resource://gre/modules/DeferredTask.jsm:305
    _timerCallback resource://gre/modules/DeferredTask.jsm:324
    callback resource://gre/modules/DeferredTask.jsm:179
    (Async: ChromeUtils::IdleDispatch handler)
    _startIdleDispatch resource://gre/modules/DeferredTask.jsm:192
    callback resource://gre/modules/DeferredTask.jsm:173

When does this happen? When the PiP window opens, or when it closes, or at some other point? Do you have steps to reproduce this from a clean profile?

(In reply to Wellington Torrejais da Silva from comment #11)

But not working in my current profile with all addons disabled...

Can you go to about:support in that current profile w/ add-ons disabled, click "copy raw data to clipboard", and paste as an attachment at https://bugzilla.mozilla.org/attachment.cgi?bugid=1614827&action=enter ?

Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(wtds.trabalho)
Attached file about-support-raw
Hi,

Occurs when I try to open PiP clicking in PiP button from Youtube video inside de iframe.

Thanks!

Looks like you're enabling fission and in this case the video (and thus the PiP stuff) is in a subframe. I can reproduce if I restart with fission enabled and load the URL from comment #0. Mike, is that supposed to work at this point and/or is there a different bug tracking this?

Status: UNCONFIRMED → NEW
Fission Milestone: --- → ?
Ever confirmed: true
Flags: needinfo?(wtds.trabalho) → needinfo?(mconley)
Summary: PiP, I can't open modal for embedded video (Youtube) → Fission - PiP from youtube subframe doesn't work

This is being tracked by bug 1575868.

Depends on: 1575868
Flags: needinfo?(mconley)

Gonna backlog this for now; we're aware there's some fission work remaining for PiP and it'll get prioritized as part of that.

Priority: -- → P3

(In reply to :Gijs (he/him) from comment #18)

Gonna backlog this for now; we're aware there's some fission work remaining for PiP and it'll get prioritized as part of that.

Duping to meta bug 1575868 because YouTube is just one case of PiP that will be fixed by bug 1575868.

Status: NEW → RESOLVED
Fission Milestone: ? → M6
Closed: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1575868
You need to log in before you can comment on or make changes to this bug.