If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

when style="display: none;" changed to style="display:;" via DOM, image within doesn't appear.

RESOLVED WORKSFORME

Status

()

Core
Layout: Images
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Aaron Gustafson, Assigned: Stuart Parmenter)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 5 obsolete attachments)

(Reporter)

Description

15 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; H010818)
BuildID:    2002053012

go to www.easy-designs.net/branding/index.php and click one of the thumbnails 
at the top and you will see the following:

the text appears, but not the image.

each is in a separate layer, but that is not the problem. the image exists 
("View Image" will bring it up), so that is not the problem.

i am going to try to see if i can create a workaround by preloading the images 
when i get home tonight. maybe that will work, but this should be addressed in 
the future.

Reproducible: Always
Steps to Reproduce:
1.go to the page
2.click a thumbnail

Actual Results:  no image appears

Expected Results:  image should appear

same issue in NS7.0 pre-release and all 6.0 versions. also, any idea when the 
width attribute for CSS will be implemented (see main nav in lower right in IE)?

Comment 1

15 years ago
WFM 2002072204 Linux

Reporter, could you try with a newer version of Mozilla?

I see a navigation thing in the lower-right corner as well; but please only file
one issue per bug report!

Comment 2

15 years ago
I see this with BuildID 2002080508 on WinXP, but if you right click, view image
and then go back image appears. Once this happens it will always display it
until you clear disk/memory cache.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Over to image layout.
Assignee: jst → pavlov
Component: DOM HTML → Image: Layout
QA Contact: stummala → tpreston
The testcase URL times out on me... any chance of attaching the testcase to this
bug using http://bugzilla.mozilla.org/attachment.cgi?bugid=161486&action=enter ?
(Reporter)

Comment 5

15 years ago
Created attachment 94553 [details]
the main page - required pages to follow

this is the page the bug is on
(Reporter)

Comment 6

15 years ago
Created attachment 94554 [details]
required .js

here is the .js file
(Reporter)

Comment 7

15 years ago
Created attachment 94555 [details]
the main .css

here's the main css
(Reporter)

Comment 8

15 years ago
Created attachment 94556 [details]
the common PHP functions i am using to generate the page
(Reporter)

Comment 9

15 years ago
Created attachment 94557 [details]
the image that isn't appearing
Attachment #94555 - Attachment mime type: text/plain → text/css
(Reporter)

Comment 10

15 years ago
ok the files are in. also tested in mozilla {2002041711}. same problem.
(Reporter)

Comment 11

15 years ago
oh.. preloading the image doesn't make it work either.
Aaron, how about a non-PHP version of the whole thing?  An easy way to do it:

1)  Open the page in Mozilla
2)  Save as "Web page, complete"
3)  zip up all the files involved.
4)  Attach to bug.
(Reporter)

Comment 13

15 years ago
Created attachment 94560 [details]
the whole she-bang

you know, i thought of that about halfway though uploading the individual files
but wasn't sure how it would handle the .js, etc. regardless, without further
ado, here it is... the complete page.
Attachment #94553 - Attachment is obsolete: true
Attachment #94554 - Attachment is obsolete: true
Attachment #94555 - Attachment is obsolete: true
Attachment #94556 - Attachment is obsolete: true
Attachment #94557 - Attachment is obsolete: true
(Reporter)

Comment 14

15 years ago
yup, it loses all the formatting from the css
(Reporter)

Updated

15 years ago
Attachment #94554 - Attachment is obsolete: false
(Reporter)

Updated

15 years ago
Attachment #94555 - Attachment is obsolete: false
(Reporter)

Updated

15 years ago
Attachment #94557 - Attachment is obsolete: false
Well... the CSS is in the "easy-designs.net   web_files" folder... you need to
zip that up and attach it.  ;)
(Reporter)

Comment 16

15 years ago
Created attachment 94572 [details]
the zip

sorry... it's been an exceedingly long day
Attachment #94554 - Attachment is obsolete: true
Attachment #94555 - Attachment is obsolete: true
Attachment #94557 - Attachment is obsolete: true
(Reporter)

Comment 17

15 years ago
ok preloading the images seems to be a workaround for this, so i will drop the 
severity to normal, but this is something that should be addressed in the next 
build of mozilla/netscape.

thanks for all of your help. please make a note of this workaround where 
appropriate so others don't run into the same problem. i will get the word out 
as well.

again, thank you.
Severity: major → normal
Is this still a problem?  The attached testcase worksforme...
Aaron Gustafson or anyone else CCed: Is this still a problem?  The attached
testcase worksforme.

Comment 20

14 years ago
worksforme with 2004021709 seamonkey build on winXP.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.