Closed Bug 1614889 Opened 9 months ago Closed 8 months ago

Rename Eager Evaluation to Instant Evaluation

Categories

(DevTools :: Console, defect, P3)

defect

Tracking

(firefox75 verified)

VERIFIED FIXED
Firefox 75
Tracking Status
firefox75 --- verified

People

(Reporter: Honza, Assigned: udaymewada1, Mentored)

References

(Blocks 1 open bug)

Details

(Keywords: good-first-bug)

Attachments

(2 files)

Attached image image.png

The Console panel is offering and option allowing the user to disable Eager Evaluation feature. It should be rename to Instant Evaluation.

Honza

Harald, can you please confirm?
Honza

Flags: needinfo?(hkirschner)

Yes, Instant Evaluation was the winner in our team voting. Let's use it for now and see if users can make more sense of it than eager eval (which is a snappy project name bit a too technical product feature name).

Adding the reasoning from our planning doc:

“Eager evaluation” isn’t used much when developers describe it, so there might be a better name. Beyond the checkbox in the settings dropdown in the Console, the name isn’t user-facing in Chrome.

Auditing articles & tweets:

  • “type an expression in the Console, the Console can now show a preview of the result of that expression below your cursor.”
  • “Eager Evaluation shows a preview of that expression's return value.” (via)
  • “Instant Evaluation of JavaScript Expressions”, “side-effect free expressions will evaluate instantly” (via)
  • “grey preview of the evaluation of the expression” (via)
  • “allows the evaluation of statements in the console as you write them and also displays the signature of the method” (via)
  • “enables expression evaluation of code in the Console, provided the expression does not have side effects (i.e. execution does something other than returning a value)” (via)
  • Chrome DevTools: Instant Evaluation of JavaScript Expressions
Flags: needinfo?(hkirschner)
Mentor: nchevobbe

should we change the text of the tooltip too?

Yes, "eagerly" --> "instantly"

Hello
Can I take up this issue?
Thanks
Aarushi

thanks for offering help Aarushi, but this is a good first bug, and you already did a few bug, so let's keep this one for people who need an easy first bug to work on :)

No problem :)

Hello
should I try this?

Hello Uday, I assigned the bug to you :)

This is the file you should make the changes in: devtools/client/locales/en-US/webconsole.properties#338-341.

Since we're going to change the content, we also need to update the keys, so localizers know something changed and they might have to change the translation too.

If it's your first bug, you might want to read this https://docs.firefox-dev.tools/getting-started/ to setup the work environment.
Make sure to select "Artifact builds" when asked as it speeds up the workflow quite a bit :)
Also, you can come and chat on our Slack https://devtools-html-slack.herokuapp.com/

Assignee: nobody → udaymewada1
Status: NEW → ASSIGNED

(In reply to Nicolas Chevobbe [:nchevobbe] from comment #9)

Hello Uday, I assigned the bug to you :)

This is the file you should make the changes in: devtools/client/locales/en-US/webconsole.properties#338-341.

Since we're going to change the content, we also need to update the keys, so localizers know something changed and they might have to change the translation too.

If it's your first bug, you might want to read this https://docs.firefox-dev.tools/getting-started/ to setup the work environment.
Make sure to select "Artifact builds" when asked as it speeds up the workflow quite a bit :)
Also, you can come and chat on our Slack https://devtools-html-slack.herokuapp.com/

should I change only Eager Evolution to Instant Evolution in the file: devtools/client/locales/en-US/webconsole.properties#339.

And if change eagerEvolution of this line devtools/client/locales/en-US/webconsole.properties#339 too in the file then I have to make changes in other files also(I guess).

sorry, In the last link text the line number is 341 but the link is correct.

(In reply to Uday Mewada from comment #10)

should I change only Eager Evolution to Instant Evolution

you should do that and:

  • change webconsole.console.settings.menu.item.eagerEvaluation.label to a new key (for example, webconsole.console.settings.menu.item.instantEvaluation.label
  • which mean you need to change the code that retrieves the string (devtools/client/webconsole/components/FilterBar/ConsoleSettings.js#165)
  • change If you enable this option the input will be eagerly evaluated as you type in it to If you enable this option the input will be instantly evaluated as you type in it
  • and change its key
  • and update the code that retrieves it as well.

I did that as you referred in comment #12.
should I change the onClick: () => dispatch(actions.eagerEvaluationToggle()), in the file devtools/client/webconsole/components/FilterBar/ConsoleSettings.js#170 and corresponding files in which it is defined.

(In reply to Uday Mewada from comment #13)

should I change the onClick: () => dispatch(actions.eagerEvaluationToggle()), in the file devtools/client/webconsole/components/FilterBar/ConsoleSettings.js#170 and corresponding files in which it is defined.

no that's fine for now. These are internal functions, this bug is only meant to rename what's visible for the user.

Submitted the patch, have a look

Sir, yesterday I got stuck in a problem and due to that this bug becomes dependent on my previous bug which is resolved and the new patch is submitted on both the bugs.
Any guidance on how to overcome this problem.

Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/22786a2d9e42
Renamed Eager Evaluation to Instant Evaluation. r=nchevobbe
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 75

Confirmed the rename with 75.0a1 (2020-03-08) on Windows 10, macOS 10.15, Ubuntu 19.04.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.