Printing this page hangs mozilla with 100% CPU




Printing: Output
16 years ago
14 years ago


(Reporter: Peter Weilbacher, Assigned: Chris Waterson)


({crash, hang})

crash, hang

Firefox Tracking Flags

(Not tracked)





16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020722
BuildID:    2002072204

Printing the above URL to a PS file hangs mozilla (forever it seems) while using
100% CPU.

Reproducible: Always
Steps to Reproduce:
1. To to the above URL
2. Press the print button
3. Select "File" and filename and press "Print"

Comment 1

16 years ago
Confirming with 2002-08-04-08-trunk on Solaris/SPARC using PostScript module.

My debug build produces an endless sequence of
-- snip --
###!!! ASSERTION: no prev in flow: 'PR_FALSE', file
line 5516
Break: at file
line 5516
###!!! ASSERTION: no prev in flow: 'PR_FALSE', file
line 5516
Break: at file
line 5516
###!!! ASSERTION: no prev in flow: 'PR_FALSE', file
line 5516
Break: at file
line 5516
-- snip --
Ever confirmed: true

Comment 3

16 years ago
Assignee: rods → waterson

Comment 4

16 years ago
Here is another page which freezes at least Build-ID 2002101808 on HP-UX 11.0
when trying to print:

Comment 5

16 years ago
The same thing (well, only something like 97.2% of the CPU) happens with build
2002101612 on Linux if I try to print the print version of a query result from, pages that contaim mostly small tables.

Comment 6

16 years ago
I reverted to Mozilla 1.1 and it prints the page from 
But it crashed yesterday on a page containing lots of large tables


15 years ago
Severity: normal → critical
Keywords: hang

Comment 7

15 years ago
I just printed the pages again to a file, and with the build I am
currently using (Linux 2003020522), it even crashes!!! I could confirm it with a
fresh profile. It is reproducible every time and I let it send Talkbacks for the
last three tries, not sure where those end up... Isn't this a real blocker?

Comment 8

15 years ago
Recreated again with Linux 1.3beta release (2003021003), got a crash both times.
Now I also know how to find out the talkback IDs: TB17452663H and TB17452667K.
Keywords: crash

Comment 9

15 years ago
Oh, surprise! I just tried to print the two URLs from and and with
1.3 nightly 2003022611 under Linux. It did not crash nor did it hang!

If somebody else can confirm then this bug should be resolved WFM.

I suggest another test case
Both print preview and print hangs with 100% cpu and slowly increasing memory

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030406
Also true on 1.3 on Windows XP SP1
With Lexmark and HP printers, local and network printers

Doesn't look to be completely solved...

Comment 11

15 years ago
OK, I can confirm with Linux build 2003040808. Here it hangs with both printing
to file and while preparing print-preview. This is probably not the same problem
as on the original page (on, which prints OK for me), but perhaps we
leave it in this bug...
still true with Windows build 2003050211
works for me on w2k build 1.5rc1
WFM, 2003-11-10-05 trunk Linux.
I print-previewed and print-to-file of all URLs in this bug without any problem.

Comment 16

15 years ago
I am running Linux 1.4.1 here:
   Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031008

And printing of the address is definitely not fixed. It still hangs
while printing to file and print-previewing. Therefore changing Version to "1.4
Version: Trunk → 1.4 Branch
works for me on 1.6a win xp (while the page layout is pretty inappopriate : 3
pages with one with the header, one with directions, one with the footer, in
shrink and fit mode)

Comment 18

14 years ago
It's definetly not fixed in 1.5 on linux  (Mozilla/5.0 (X11; U; Linux i686;
en-US; rv:1.5) Gecko/20031016).  One big difference seems to be that CPU no
longer pegs out but the stall is near total.  There was no obvious fix listed in
the 1.6b rough changelog. 

Mozilla is totally unresponsive and KDE slows to almost complete
unresponsiveness until mozilla-bin is killed off.  The title bar of the
preparing box isn't erased when the box is moved leading to trailing window images. 

df and top show the system to be basically idle.  CPU is very low (typically <
2%) and disk usage/available blocks are pretty stable.

I left the system for 8 hours and saw no change.  System usage remained stable
over this time too.

I've found other examples of pages that stall the system (I'm starting to
collect some).  Factors that make no difference:  http/https/file(saved page),
color/b+w printing.

Print environment is CUPS with a usb connected HP OJv40.


works for me on 1.7b build 2004031508 winxp
works for me on win 2K/xp with 1.7rc1

Comment 21

14 years ago
-> linux/trunk per comments
OS: All → Linux
Version: 1.4 Branch → Trunk

Comment 22

14 years ago
I just upgraded to 1.7 via rpms [Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040619] and the problem still exists.

The URLS in #2, #4, #10 worked fine.

The URL in #5 hung mozilla
as before.

Comment 24

14 years ago
The webpages have a different design since I reported this bug, and
hence we cannot really say if the original problem is still there (which I
doubt, since they were working already before the redesign if I recall correctly).

Anyway, I also tested all the URLs on both 1.7 and the current trunk
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a3) Gecko/20040812, and in a fresh
profile and my normal work profile. No problems at all, even if I follow the
recipe from comment 5 to find a train connection and print that instead of the
main page of reiseauskunft, also in the print view.

So I am marking this one finally WFM.
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.