Crash while setting up a new mail account

VERIFIED DUPLICATE of bug 161530

Status

SeaMonkey
MailNews: Account Configuration
--
blocker
VERIFIED DUPLICATE of bug 161530
16 years ago
13 years ago

People

(Reporter: marina, Assigned: racham)

Tracking

({smoketest})

Trunk
x86
Windows XP
smoketest

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
*** observed with 2002-08-07 trunk build ***
When clicking on the "finish" button on the last screen of the Account setup i
experience a consistent crash. 

Incident ID: 9069144

 Call Stack:     (Signature = 0x00000001 d720f42c)
     0x00000001  
     0x02f36a98  
     nsMsgDBFolder::ReadDBFolderInfo
[c:/builds/seamonkey/mozilla/mailnews/base/util/nsMsgDBFolder.cpp, line 423]
     nsMsgDBFolder::SetFlag
[c:/builds/seamonkey/mozilla/mailnews/base/util/nsMsgDBFolder.cpp, line 1111]
     nsMsgLocalMailFolder::GetSubFolders
[c:/builds/seamonkey/mozilla/mailnews/local/src/nsLocalMailFolder.cpp, line 450]
     nsMsgFolderDataSource::createFolderChildNode
[c:/builds/seamonkey/mozilla/mailnews/base/src/nsMsgFolderDataSource.cpp, line 1861]
     nsMsgFolderDataSource::createFolderNode
[c:/builds/seamonkey/mozilla/mailnews/base/src/nsMsgFolderDataSource.cpp, line 1048]
     nsMsgFolderDataSource::GetTarget
[c:/builds/seamonkey/mozilla/mailnews/base/src/nsMsgFolderDataSource.cpp, line 387]
     CompositeDataSourceImpl::GetTarget
[c:/builds/seamonkey/mozilla/rdf/base/src/nsCompositeDataSource.cpp, line 832]
     nsRDFConInstanceTestNode::FilterInstantiations
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsRDFConInstanceTestNode.cpp,
line 177]
     TestNode::Propagate
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsRuleNetwork.cpp, line 1045]
     TestNode::Propagate
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsRuleNetwork.cpp, line 1049]
     TestNode::Propagate
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsRuleNetwork.cpp, line 1049]
     nsXULTemplateBuilder::Propagate
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTemplateBuilder.cpp,
line 525]
     nsXULTemplateBuilder::OnAssert
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTemplateBuilder.cpp,
line 596]
     CompositeDataSourceImpl::OnAssert
[c:/builds/seamonkey/mozilla/rdf/base/src/nsCompositeDataSource.cpp, line 1559]
     nsMsgRDFDataSource::assertEnumFunc
[c:/builds/seamonkey/mozilla/mailnews/base/src/nsMsgRDFDataSource.cpp, line 404]
     nsSupportsArray::EnumerateForwards
[c:/builds/seamonkey/mozilla/xpcom/ds/nsSupportsArray.cpp, line 646]
     nsMsgRDFDataSource::NotifyObservers
[c:/builds/seamonkey/mozilla/mailnews/base/src/nsMsgRDFDataSource.cpp, line 391]
     nsMsgAccountManagerDataSource::OnServerLoaded
[c:/builds/seamonkey/mozilla/mailnews/base/src/nsMsgAccountManagerDS.cpp, line 1191]
     nsMsgAccountManager::NotifyServerLoaded
[c:/builds/seamonkey/mozilla/mailnews/base/src/nsMsgAccountManager.cpp, line 1736]
     nsMsgAccount::SetIncomingServer
[c:/builds/seamonkey/mozilla/mailnews/base/src/nsMsgAccount.cpp, line 198]
     XPTC_InvokeByIndex
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp,
line 106]
     XPCWrappedNative::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 1996]
     XPC_WN_GetterSetter
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1291]
     js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 840]
     js_InternalInvoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 931]
     js_SetProperty [c:/builds/seamonkey/mozilla/js/src/jsobj.c, line 2690]
     js_Interpret [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 2634]
     js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 856]
     fun_apply [c:/builds/seamonkey/mozilla/js/src/jsfun.c, line 1555]
     js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 840]
     js_Interpret [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 2792]
     js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 856]
     js_Interpret [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 2792]
     js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 856]
     nsXPCWrappedJSClass::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp, line 1195]
     nsXPCWrappedJS::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp, line 430]
     PrepareAndDispatch
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp,
line 117]
     SharedStub
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp,
line 139]
     nsEventListenerManager::HandleEventSubType
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, line
1275]
     nsEventListenerManager::HandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, line
2263]
     nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3453]
     PresShell::HandleDOMEventWithTarget
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6155]
     nsButtonBoxFrame::MouseClicked
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsButtonBoxFrame.cpp, line 195]
     nsButtonBoxFrame::HandleEvent
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsButtonBoxFrame.cpp, line 142]
     PresShell::HandleEventInternal
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6124]
     PresShell::HandleEventWithTarget
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6075]
     nsEventStateManager::CheckForAndDispatchClick
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp, line 2758]
     nsEventStateManager::PostHandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp, line 1762]
     PresShell::HandleEventInternal
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6128]
     PresShell::HandleEvent
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6030]
     nsViewManager::HandleEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 2098]
     nsView::HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 306]
     nsViewManager::DispatchEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 1909]
     HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 83]
     nsWindow::DispatchEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1038]
     nsWindow::DispatchWindowEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1055]
     nsWindow::DispatchMouseEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 5127]
     ChildWindow::DispatchMouseEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 5382]
     nsWindow::ProcessMessage
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 3834]
     nsWindow::WindowProc
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1304]

Comment 1

16 years ago
I am now seeing this on windows98 with trunk build 2002-08-07-11-trunk:

clicking finish in account wizard crashes.

also note: with an existing profile I crash in the password dialog.


talkback for that:
Stack Signature  morkTable::morkTable 5a1ea873
Email Address twalker@netscape.com
Product ID MozillaTrunk
Build ID 2002080711
Trigger Time 2002-08-07 12:26:30
Platform Win32
Operating System Windows 98 4.10 build 67766446
Module MORK.DLL
URL visited
User Comments crash opening mail app
Trigger Reason Access violation
Source File Name c:/builds/seamonkey/mozilla/db/mork/src/morkTable.cpp
Trigger Line No. 155
Stack Trace
morkTable::morkTable [c:/builds/seamonkey/mozilla/db/mork/src/morkTable.cpp,
line 155]
morkRowSpace::NewTableWithTid
[c:/builds/seamonkey/mozilla/db/mork/src/morkRowSpace.cpp, line 329]
morkStore::OidToTable [c:/builds/seamonkey/mozilla/db/mork/src/morkStore.cpp,
line 1321]
morkStore::NewTableWithOid
[c:/builds/seamonkey/mozilla/db/mork/src/morkStore.cpp, line 2045]
nsMsgDatabase::InitNewDB
[c:/builds/seamonkey/mozilla/mailnews/db/msgdb/src/nsMsgDatabase.cpp, line 1273]
nsMsgDatabase::OpenMDB
[c:/builds/seamonkey/mozilla/mailnews/db/msgdb/src/nsMsgDatabase.cpp, line 1018]
nsImapMailDatabase::Open
[c:/builds/seamonkey/mozilla/mailnews/db/msgdb/src/nsImapMailDatabase.cpp, line 121]
nsMsgDatabase::OpenFolderDB
[c:/builds/seamonkey/mozilla/mailnews/db/msgdb/src/nsMsgDatabase.cpp, line 923]
nsImapMailFolder::GetDatabase
[c:/builds/seamonkey/mozilla/mailnews/imap/src/nsImapMailFolder.cpp, line 606]
nsMsgDBFolder::GetMsgDatabase
[c:/builds/seamonkey/mozilla/mailnews/base/util/nsMsgDBFolder.cpp, line 649]
XPTC_InvokeByIndex
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp,
line 106]
XPCWrappedNative::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 1996]
XPC_WN_CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1267]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 840]
js_Interpret [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 2792]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 856]
js_InternalInvoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 931]
JS_CallFunctionValue [c:/builds/seamonkey/mozilla/js/src/jsapi.c, line 3430]
nsJSContext::CallEventHandler
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp, line 1044]
nsJSEventListener::HandleEvent
[c:/builds/seamonkey/mozilla/dom/src/events/nsJSEventListener.cpp, line 184]
nsEventListenerManager::HandleEventSubType
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, line
1275]
nsEventListenerManager::HandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, line
1874]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3453]
nsTreeSelection::FireOnSelectHandler
[c:/builds/seamonkey/mozilla/layout/xul/base/src/tree/src/nsTreeSelection.cpp,
line 743]
nsTreeSelection::Select
[c:/builds/seamonkey/mozilla/layout/xul/base/src/tree/src/nsTreeSelection.cpp,
line 369]
XPTC_InvokeByIndex
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp,
line 106]
XPCWrappedNative::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 1996]
XPC_WN_CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1267]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 840]
js_Interpret [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 2792]
js_Execute [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 1020]
JS_EvaluateUCScriptForPrincipals [c:/builds/seamonkey/mozilla/js/src/jsapi.c,
line 3381]
nsJSContext::EvaluateString
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp, line 702]
GlobalWindowImpl::RunTimeout
[c:/builds/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp, line 4570]
GlobalWindowImpl::TimerCallback
[c:/builds/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp, line 4935]
nsTimerImpl::Fire [c:/builds/seamonkey/mozilla/xpcom/threads/nsTimerImpl.cpp,
line 340]
USER32.DLL + 0x580d (0xbff5580d)
nsAppShell::Run [c:/builds/seamonkey/mozilla/widget/src/windows/nsAppShell.cpp,
line 134]
nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 452]
main1 [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1532]
main [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1883]
WinMain [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1901]
WinMainCRTStartup()
KERNEL32.DLL + 0x1b560 (0xbff8b560)
KERNEL32.DLL + 0x1b412 (0xbff8b412)
KERNEL32.DLL + 0x19dd5 (0xbff89dd5) 
Keywords: smoketest

Updated

16 years ago
Blocks: 161512

Comment 2

16 years ago
I'm sure this is a dup of 161530 - but I'm not able to reproduce this with a
debug build - the code in question hasn't changed in a very long time, so I
suspect something is going very wrong elsewhere.

Comment 3

16 years ago
are linux or mac builds showing similar problems?

Comment 4

16 years ago
could this be related to todays crash in selection code? (bug 161444)

Comment 5

16 years ago
no, not related to the selection crash.

Comment 6

16 years ago
building now, will take a look. 
FYI: no crash with a 15min old win32 optimized build and a pop3 Account (tested
also a new profile)

Comment 8

16 years ago
dup - I'll go mark the other one as a smoketest blocker, in case respinning
doesn't fix the problem.

*** This bug has been marked as a duplicate of 161530 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 9

16 years ago
verified (fixed) on windows commercial 2002-08-08-07-trunk
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.