Closed Bug 1615150 Opened 3 years ago Closed 3 years ago

diff-artifact-win64-aarch64-eme-validation builds broken when they fail

Categories

(Firefox Build System :: General, defect)

defect
Not set
normal

Tracking

(firefox75 fixed)

RESOLVED FIXED
mozilla75
Tracking Status
firefox75 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

They fail trying to diff the generated-files they can't get from the artifact build because artifact builds don't produce them.

As opposed to what was intended, the directories weren't eliminated
correctly.

Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/cbcd388f3fad
Fix the logic that skips generated-files diffing when there aren't generated-files to compare. r=froydnj
https://hg.mozilla.org/integration/autoland/rev/9b745a730adc
Drive-by fix error reporting in diffoscope tasks failure summary. r=dmajor
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla75
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.