Closed Bug 1615273 Opened 2 years ago Closed 2 years ago

Perma late beta /encoding/streams/decode-utf8.any.sharedworker.html | Error in remote /encoding/streams/decode-utf8.any.js: TypeError: self[arrayBufferOrSharedArrayBuffer] is not a constructor when Gecko 75 merges to Beta on 2020-03-09

Categories

(Core :: Internationalization, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla75
Tracking Status
firefox-esr68 --- unaffected
firefox73 --- unaffected
firefox74 --- unaffected
firefox75 + verified

People

(Reporter: noemi_erli, Assigned: tt)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]:

Central as beta:
https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Cretry%2Cusercancel%2Crunnable&revision=b34ccc8bc31172024c0b7413b87dc8ba8d24d9f0&selectedJob=288712754

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=288712754&repo=try&lineNumber=4907

[task 2020-02-13T13:09:10.515Z] 13:09:10 INFO - TEST-START | /encoding/streams/decode-utf8.any.sharedworker.html
[task 2020-02-13T13:09:10.518Z] 13:09:10 INFO - Closing window 79
[task 2020-02-13T13:09:10.676Z] 13:09:10 INFO - PID 20679 | Gtk-Message: 13:09:10.667: Failed to load module "canberra-gtk-module"
[task 2020-02-13T13:09:10.683Z] 13:09:10 INFO - PID 20679 | Gtk-Message: 13:09:10.678: Failed to load module "canberra-gtk-module"
[task 2020-02-13T13:09:10.891Z] 13:09:10 INFO - TEST-UNEXPECTED-ERROR | /encoding/streams/decode-utf8.any.sharedworker.html | Error in remote http://web-platform.test:8000/encoding/streams/decode-utf8.any.js: TypeError: self[arrayBufferOrSharedArrayBuffer] is not a constructor
[task 2020-02-13T13:09:10.891Z] 13:09:10 INFO - TEST-INFO expected TIMEOUT | took 376ms
[task 2020-02-13T13:09:10.907Z] 13:09:10 INFO - PID 20679 | 1581599350895 Marionette INFO Stopped listening on port 58455
[task 2020-02-13T13:09:11.507Z] 13:09:11 INFO - Browser exited with return code 0
[task 2020-02-13T13:09:11.507Z] 13:09:11 INFO - PROCESS LEAKS None
[task 2020-02-13T13:09:11.508Z] 13:09:11 INFO - PROCESS LEAKS None
[task 2020-02-13T13:09:11.509Z] 13:09:11 INFO - Closing logging queue
[task 2020-02-13T13:09:11.509Z] 13:09:11 INFO - queue closed
[task 2020-02-13T13:09:11.530Z] 13:09:11 INFO - Setting up ssl
[task 2020-02-13T13:09:11.558Z] 13:09:11 INFO - certutil |
[task 2020-02-13T13:09:11.594Z] 13:09:11 INFO - certutil |
[task 2020-02-13T13:09:11.614Z] 13:09:11 INFO - certutil |
[task 2020-02-13T13:09:11.615Z] 13:09:11 INFO - Certificate Nickname Trust Attributes
[task 2020-02-13T13:09:11.615Z] 13:09:11 INFO - SSL,S/MIME,JAR/XPI
[task 2020-02-13T13:09:11.615Z] 13:09:11 INFO -
[task 2020-02-13T13:09:11.615Z] 13:09:11 INFO - web-platform-tests CT,,
[task 2020-02-13T13:09:11.615Z] 13:09:11 INFO -
[task 2020-02-13T13:09:11.636Z] 13:09:11 INFO - Application command: /builds/worker/workspace/build/application/firefox/firefox --marionette about:blank -profile /tmp/tmpIqo0qD.mozrunner
[task 2020-02-13T13:09:11.656Z] 13:09:11 INFO - Starting runner
[task 2020-02-13T13:09:11.721Z] 13:09:11 INFO - PID 21800 | Gtk-Message: 13:09:11.719: Failed to load module "canberra-gtk-module"
[task 2020-02-13T13:09:11.722Z] 13:09:11 INFO - PID 21800 | Gtk-Message: 13:09:11.721: Failed to load module "canberra-gtk-module"
[task 2020-02-13T13:09:12.000Z] 13:09:12 INFO - PID 21800 | 1581599351993 addons.webextension.doh-rollout@mozilla.org WARN Loading extension 'doh-rollout@mozilla.org': Reading manifest: Invalid extension permission: networkStatus
[task 2020-02-13T13:09:12.467Z] 13:09:12 INFO - PID 21800 | 1581599352466 addons.webextension.screenshots@mozilla.org WARN Loading extension 'screenshots@mozilla.org': Reading manifest: Invalid extension permission: mozillaAddons
[task 2020-02-13T13:09:12.469Z] 13:09:12 INFO - PID 21800 | 1581599352466 addons.webextension.screenshots@mozilla.org WARN Loading extension 'screenshots@mozilla.org': Reading manifest: Invalid extension permission: telemetry
[task 2020-02-13T13:09:12.469Z] 13:09:12 INFO - PID 21800 | 1581599352466 addons.webextension.screenshots@mozilla.org WARN Loading extension 'screenshots@mozilla.org': Reading manifest: Invalid extension permission: resource://pdf.js/
[task 2020-02-13T13:09:12.470Z] 13:09:12 INFO - PID 21800 | 1581599352467 addons.webextension.screenshots@mozilla.org WARN Loading extension 'screenshots@mozilla.org': Reading manifest: Invalid extension permission: about:reader*
[task 2020-02-13T13:09:13.015Z] 13:09:13 INFO - PID 21800 | Gtk-Message: 13:09:13.012: Failed to load module "canberra-gtk-module"
[task 2020-02-13T13:09:13.016Z] 13:09:13 INFO - PID 21800 | Gtk-Message: 13:09:13.014: Failed to load module "canberra-gtk-module"
[task 2020-02-13T13:09:13.153Z] 13:09:13 INFO - PID 21800 | Gtk-Message: 13:09:13.149: Failed to load module "canberra-gtk-module"
[task 2020-02-13T13:09:13.154Z] 13:09:13 INFO - PID 21800 | Gtk-Message: 13:09:13.151: Failed to load module "canberra-gtk-module"
[task 2020-02-13T13:09:14.249Z] 13:09:14 INFO - PID 21800 | GLib-GIO-Message: 13:09:14.245: Using the 'memory' GSettings backend. Your settings will not be saved or shared with other applications.
[task 2020-02-13T13:09:15.020Z] 13:09:15 INFO - PID 21800 | Gtk-Message: 13:09:15.015: Failed to load module "canberra-gtk-module"
[task 2020-02-13T13:09:15.020Z] 13:09:15 INFO - PID 21800 | Gtk-Message: 13:09:15.017: Failed to load module "canberra-gtk-module"
[task 2020-02-13T13:09:15.189Z] 13:09:15 INFO - PID 21800 | 1581599355182 Marionette INFO Listening on port 58455

Flags: needinfo?(sgiesecke)

I don't think so, but I will check. How can I create a "central-as-beta" build locally to verify that?

Flags: needinfo?(sgiesecke)
Flags: needinfo?(nerli)

(In reply to Simon Giesecke [:sg] [he/him] from comment #2)

I don't think so, but I will check. How can I create a "central-as-beta" build locally to verify that?

You can find more steps on how to do that here: https://wiki.mozilla.org/Sheriffing/How_To/Beta_simulations#TRUNK_AS_EARLY_BETA

Flags: needinfo?(nerli)

Unfortunately, there's no information on how to do a local build there.

Sebastian, can you please share your thoughts here?

Flags: needinfo?(aryx.bugmail)

This is a regression from bug 1603484 (treeherder hides the central-as-beta revision because it had already been pushed): https://treeherder.mozilla.org/#/jobs?repo=try&revision=ac368f1b82331d8b715e8de83db90d24d5b1b48d&selectedJob=288756173

Regarding the question how to do local central-as-beta builds: If a debug or normal opt build are sufficient, run the command mentioned at https://wiki.mozilla.org/Sheriffing/How_To/Beta_simulations#TRUNK_AS_EARLY_BETA with the also mentioned --no-push, hg commit and run the build

Component: web-platform-tests → Internationalization
Flags: needinfo?(aryx.bugmail) → needinfo?(perry)
Product: Testing → Core
Regressed by: 1603484
Summary: Perma /encoding/streams/decode-utf8.any.sharedworker.html | Error in remote http://web-platform.test:8000/encoding/streams/decode-utf8.any.js: TypeError: self[arrayBufferOrSharedArrayBuffer] is not a constructor when Gecko 75 merges to Beta on 2020-03-09 → Perma late beta /encoding/streams/decode-utf8.any.sharedworker.html | Error in remote /encoding/streams/decode-utf8.any.js: TypeError: self[arrayBufferOrSharedArrayBuffer] is not a constructor when Gecko 75 merges to Beta on 2020-03-09
Version: Version 3 → unspecified

Tom, I think this is related to SAB interfaces being exposed or not, can you take a look?

Flags: needinfo?(perry) → needinfo?(ttung)

The error message looks like cannot sharedwork construct arrayBufferOrSharedArrayBuffer anymore?
I did an AB test and D62371 affects the result. Will look into it more.

(In reply to Tom Tung [:tt, :ttung] from comment #8)

The error message looks like cannot sharedwork construct arrayBufferOrSharedArrayBuffer anymore?
I did an AB test and D62371 affects the result. Will look into it more.

I guess SharedWorker throws when constructing an SharedArrayBuffer so that the wpt test timeout'ed when SAB is disabled (it's only enabled on early Beta and Nightly). D62371 only reveals this issue.

Now the problem is why it SharedWorker behaves differently from other workers.

(In reply to Tom Tung [:tt, :ttung] from comment #9)

I guess SharedWorker throws when constructing an SharedArrayBuffer so that the wpt test timeout'ed when SAB is disabled (it's only enabled on early Beta and Nightly). D62371 only reveals this issue.

Now the problem is why it SharedWorker behaves differently from other workers.

Wait, I added try {} catch () {} block at [1] and it actually throws when it run in all kinds of workers and windows (when I ran all tests with a late Beta build).

[1] https://searchfox.org/mozilla-central/rev/fca0be7e2cf2f922c9b927423ce28e8a04b3fd90/testing/web-platform/tests/encoding/streams/decode-utf8.any.js#11-12

Ah, I think I figure the reason why. All other subtests (serviceworker, dedicated worker, windows) are expected "Error".

Flags: needinfo?(ttung)
Attachment #9127599 - Attachment description: Bug 1615273 - Cleanup decode-utf8.ini file; → Bug 1615273 - Cleanup decode-utf8.any.ini file;
Assignee: nobody → ttung
Status: NEW → ASSIGNED

(In reply to Andreea Pavel [:apavel] from comment #13)

(In reply to Tom Tung [:tt, :ttung] from comment #12)

m-c: https://treeherder.mozilla.org/#/jobs?repo=try&revision=23b5a6ad827c53430d46aaf17abf9c84a0787776
late Beta: https://treeherder.mozilla.org/#/jobs?repo=try&revision=228c1838faddd963c01ff5b369fdfe57a3bf555d

Please check the late beta try push.

There a few test failures, but I couldn't find any failure related to /encoding/streams/decode-utf8.any.sharedworker.html.

ni back in case you referred to something else.

Flags: needinfo?(ttung) → needinfo?(apavel)

(In reply to Tom Tung [:tt, :ttung] from comment #14)

There a few test failures, but I couldn't find any failure related to /encoding/streams/decode-utf8.any.sharedworker.html.

(Since the patch only change decode-utf8.any.ini, I'm going to land the patch)

Pushed by ttung@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b24519af3778
Cleanup decode-utf8.any.ini file; r=perry

(In reply to Tom Tung [:tt, :ttung] from comment #14)

(In reply to Andreea Pavel [:apavel] from comment #13)

(In reply to Tom Tung [:tt, :ttung] from comment #12)

m-c: https://treeherder.mozilla.org/#/jobs?repo=try&revision=23b5a6ad827c53430d46aaf17abf9c84a0787776
late Beta: https://treeherder.mozilla.org/#/jobs?repo=try&revision=228c1838faddd963c01ff5b369fdfe57a3bf555d

Please check the late beta try push.

There a few test failures, but I couldn't find any failure related to /encoding/streams/decode-utf8.any.sharedworker.html.

ni back in case you referred to something else.

No, wasn't referring to anything in particular, just the number of failures seemed a lot. Thanks for checking.

Flags: needinfo?(apavel)
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla75
You need to log in before you can comment on or make changes to this bug.