Closed Bug 1615279 Opened 1 year ago Closed 1 year ago

Intermittent 1:02.83 testing/raptor/test/test_cpu.py::test_no_device TEST-UNEXPECTED-FAIL | [Errno 17] File exists: '/builds/worker/.condprof-cache'

Categories

(Testing :: Raptor, defect, P5)

Version 3
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1614755

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: intermittent-failure)

Filed by: ncsoregi [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=288717544&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/emClwbaAQb-0Ja0CwVghDg/runs/0/artifacts/public/logs/live_backing.log


[task 2020-02-13T13:26:40.609Z] 1:02.83 ============================= test session starts ==============================
[task 2020-02-13T13:26:40.609Z] 1:02.83 platform linux -- Python 3.6.9, pytest-3.6.2, py-1.5.4, pluggy-0.6.0 -- /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_virtualenvs/gecko-QUm8IANb-3/bin/python
[task 2020-02-13T13:26:40.609Z] 1:02.83 rootdir: /builds/worker/checkouts/gecko, inifile: /builds/worker/checkouts/gecko/config/mozunit/mozunit/pytest.ini
[task 2020-02-13T13:26:40.609Z] 1:02.83 collecting ... collected 4 items
[task 2020-02-13T13:26:40.609Z] 1:02.83
[task 2020-02-13T13:26:40.609Z] 1:02.83 testing/raptor/test/test_cpu.py::test_no_device TEST-UNEXPECTED-FAIL
[task 2020-02-13T13:26:40.609Z] 1:02.83 testing/raptor/test/test_cpu.py::test_usage_with_invalid_data_returns_zero PASSED
[task 2020-02-13T13:26:40.609Z] 1:02.83 testing/raptor/test/test_cpu.py::test_usage_with_output PASSED
[task 2020-02-13T13:26:40.610Z] 1:02.83 testing/raptor/test/test_cpu.py::test_usage_with_fallback PASSED
[task 2020-02-13T13:26:40.610Z] 1:02.83
[task 2020-02-13T13:26:40.610Z] 1:02.83 =================================== FAILURES ===================================
[task 2020-02-13T13:26:40.610Z] 1:02.83 ________________________________ test_no_device ________________________________
[task 2020-02-13T13:26:40.610Z] 1:02.83
[task 2020-02-13T13:26:40.610Z] 1:02.83 def test_no_device():
[task 2020-02-13T13:26:40.610Z] 1:02.83 raptor = WebExtensionAndroid(
[task 2020-02-13T13:26:40.610Z] 1:02.83 "geckoview",
[task 2020-02-13T13:26:40.610Z] 1:02.83 "org.mozilla.org.mozilla.geckoview_example",
[task 2020-02-13T13:26:40.610Z] 1:02.83 cpu_test=True,
[task 2020-02-13T13:26:40.611Z] 1:02.83 > no_conditioned_profile=False,
[task 2020-02-13T13:26:40.611Z] 1:02.83 )
[task 2020-02-13T13:26:40.611Z] 1:02.83
[task 2020-02-13T13:26:40.611Z] 1:02.83 testing/raptor/test/test_cpu.py:26:
[task 2020-02-13T13:26:40.616Z] 1:02.83 _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _
[task 2020-02-13T13:26:40.616Z] 1:02.83 testing/raptor/raptor/webextension/android.py:32: in init
[task 2020-02-13T13:26:40.616Z] 1:02.83 app, binary, profile_class="firefox", **kwargs
[task 2020-02-13T13:26:40.616Z] 1:02.83 testing/raptor/raptor/webextension/base.py:37: in init
[task 2020-02-13T13:26:40.616Z] 1:02.83 super(WebExtension, self).init(*args, **kwargs)
[task 2020-02-13T13:26:40.616Z] 1:02.83 testing/raptor/raptor/perftest.py:173: in init
[task 2020-02-13T13:26:40.616Z] 1:02.83 self.build_browser_profile()
[task 2020-02-13T13:26:40.616Z] 1:02.83 testing/raptor/raptor/perftest.py:528: in build_browser_profile
[task 2020-02-13T13:26:40.616Z] 1:02.83 super(PerftestAndroid, self).build_browser_profile()
[task 2020-02-13T13:26:40.616Z] 1:02.83 testing/raptor/raptor/webextension/base.py:139: in build_browser_profile
[task 2020-02-13T13:26:40.616Z] 1:02.83 super(WebExtension, self).build_browser_profile()
[task 2020-02-13T13:26:40.616Z] 1:02.83 testing/raptor/raptor/perftest.py:241: in build_browser_profile
[task 2020-02-13T13:26:40.617Z] 1:02.83 self.get_conditioned_profile()
[task 2020-02-13T13:26:40.617Z] 1:02.83 testing/raptor/raptor/perftest.py:203: in get_conditioned_profile
[task 2020-02-13T13:26:40.617Z] 1:02.83 cond_prof_target_dir = get_profile(temp_download_dir, platform, "settled")
[task 2020-02-13T13:26:40.617Z] 1:02.83 testing/condprofile/condprof/client.py:75: in get_profile
[task 2020-02-13T13:26:40.617Z] 1:02.83 os.makedirs(download_dir)
[task 2020-02-13T13:26:40.617Z] 1:02.83 _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _
[task 2020-02-13T13:26:40.617Z] 1:02.83
[task 2020-02-13T13:26:40.617Z] 1:02.83 name = '/builds/worker/.condprof-cache', mode = 511, exist_ok = False
[task 2020-02-13T13:26:40.617Z] 1:02.83
[task 2020-02-13T13:26:40.617Z] 1:02.83 def makedirs(name, mode=0o777, exist_ok=False):
[task 2020-02-13T13:26:40.617Z] 1:02.83 """makedirs(name [, mode=0o777][, exist_ok=False])
[task 2020-02-13T13:26:40.617Z] 1:02.83
[task 2020-02-13T13:26:40.617Z] 1:02.83 Super-mkdir; create a leaf directory and all intermediate ones. Works like
[task 2020-02-13T13:26:40.617Z] 1:02.83 mkdir, except that any intermediate path segment (not just the rightmost)
[task 2020-02-13T13:26:40.617Z] 1:02.83 will be created if it does not exist. If the target directory already
[task 2020-02-13T13:26:40.617Z] 1:02.83 exists, raise an OSError if exist_ok is False. Otherwise no exception is
[task 2020-02-13T13:26:40.617Z] 1:02.83 raised. This is recursive.
[task 2020-02-13T13:26:40.617Z] 1:02.83
[task 2020-02-13T13:26:40.617Z] 1:02.83 """
[task 2020-02-13T13:26:40.617Z] 1:02.83 head, tail = path.split(name)
[task 2020-02-13T13:26:40.617Z] 1:02.83 if not tail:
[task 2020-02-13T13:26:40.617Z] 1:02.83 head, tail = path.split(head)
[task 2020-02-13T13:26:40.617Z] 1:02.83 if head and tail and not path.exists(head):
[task 2020-02-13T13:26:40.617Z] 1:02.83 try:
[task 2020-02-13T13:26:40.617Z] 1:02.83 makedirs(head, mode, exist_ok)
[task 2020-02-13T13:26:40.617Z] 1:02.83 except FileExistsError:
[task 2020-02-13T13:26:40.617Z] 1:02.83 # Defeats race condition when another thread created the path
[task 2020-02-13T13:26:40.617Z] 1:02.83 pass
[task 2020-02-13T13:26:40.617Z] 1:02.83 cdir = curdir
[task 2020-02-13T13:26:40.617Z] 1:02.83 if isinstance(tail, bytes):
[task 2020-02-13T13:26:40.617Z] 1:02.83 cdir = bytes(curdir, 'ASCII')
[task 2020-02-13T13:26:40.617Z] 1:02.83 if tail == cdir: # xxx/newdir/. exists if xxx/newdir exists
[task 2020-02-13T13:26:40.617Z] 1:02.83 return
[task 2020-02-13T13:26:40.617Z] 1:02.83 try:
[task 2020-02-13T13:26:40.617Z] 1:02.83 > mkdir(name, mode)
[task 2020-02-13T13:26:40.617Z] 1:02.83 E FileExistsError: [Errno 17] File exists: '/builds/worker/.condprof-cache'

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1614755
You need to log in before you can comment on or make changes to this bug.