Navigation links should not print

RESOLVED DUPLICATE of bug 110152

Status

()

Bugzilla
User Interface
P4
enhancement
RESOLVED DUPLICATE of bug 110152
16 years ago
11 years ago

People

(Reporter: Stephen Ostermiller, Assigned: myk)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
An engineer at our status meeting had printed out several bug reports and bug
lists.  Each of them had the yellow box "This is Bugzilla: the Mozilla bug
system"... at the bottom of the page.  The instructions and navigation options
in that box are fairly useless on paper.

I modified my bugzilla installation (2.16) so that these would not print (using
stylesheets).  Here are the changes:
Create a printable.css file with the contents:
.bugzillaNavigationBox {
  display:none;
}

Reference this stylesheet for printing in each pages header by adding the
following line to template/en/default/global/header.html.tmpl anywhere in the
<head> section.
<link rel="stylesheet" media="print" href="printable.css" type="text/css">

make the things that shouldn't print the bugzillaNavigationBox class:
in template/en/default/global/header.html.tmpl change the outermost table to:
<table border="0" class="bugzillaNavigationBox">

in template/en/default/bug/navigate.html.tmpl add the following div around most
of the content:
<div class="bugzillaNavigationBox">
</div>

in template/en/default/bug/navigate.html.tmpl add the following div around most
of the content:
<div class="bugzillaNavigationBox">
</div>

in template/en/default/list/list.html.tmpl add the following div around the
navigation bar:
<div class="bugzillaNavigationBox">
</div>

The problems that I see with this fix are: 
1. The style sheet is a relative reference, it should probably be absolute.  I
don't know what the template variable for the bugzilla root installation url is.

2. Bugzilla appears to have some other style sheet mechanism.  This patch
shouldn't interterfere with it, but it might be possible to integrate the two. 
If that were done, problem one would be moot because the style sheets would be
inline rather than files.

I don't know how to create patch files.  If somebody could point me in the right
direction, I would be glad to do so.
Patches are created with cvs diff -u for a CVS directory and diff -u oldfile
newfile or diff -ru olddir newdir for non-CVS directories.
Priority: -- → P4
Target Milestone: --- → Future
(Reporter)

Comment 2

15 years ago
Created attachment 97750 [details] [diff] [review]
Patch against  Bugzilla_Stable that labels several items that are useless to print with their own style and then uses a style sheet not show them when printing.
(Reporter)

Comment 3

15 years ago
Created attachment 97751 [details]
style sheet used in patch when printing, it should be named printable.css and it goes in the bugzilla root directory.
(Reporter)

Updated

15 years ago
Attachment #97751 - Attachment description: style sheet used in patch when printing. → style sheet used in patch when printing, it should be named printable.css and it goes in the bugzilla root directory.
The User Interface component now belongs to Gerv.  Reassigning all UNCONFIRMED
and NEW (but not ASSIGNED) bugs currently owned by Myk (the previous component
owner) to Gerv.
Assignee: myk → gerv
Reassigning back to Myk.  That stuff about Gerv taking over the User Interface
component turned out to be short-lived.  Please pardon our confusion, and I'm
very sorry about the spam.
Assignee: gerv → myk

Updated

15 years ago
OS: Linux → All
Hardware: PC → All
Severity: normal → enhancement
Target Milestone: Future → Bugzilla 2.20
Bugzilla 2.20 feature set is now frozen as of 15 Sept 2004.  Anything flagged
enhancement that hasn't already landed is being pushed out.  If this bug is
otherwise ready to land, we'll handle it on a case-by-case basis, please set the
blocking2.20 flag to '?' if you think it qualifies.
Target Milestone: Bugzilla 2.20 → Bugzilla 2.22

Updated

12 years ago
QA Contact: mattyt-bugzilla → default-qa
Target Milestone: Bugzilla 2.22 → ---
Depends on: 330600
Whiteboard: [blocker fill fix]

Comment 7

11 years ago

*** This bug has been marked as a duplicate of 110152 ***
Status: NEW → RESOLVED
Last Resolved: 11 years ago
No longer depends on: 330600
Resolution: --- → DUPLICATE
Whiteboard: [blocker fill fix]
You need to log in before you can comment on or make changes to this bug.