Closed Bug 1615420 Opened 2 years ago Closed 2 years ago

Don't ship DirectComposition in the places where Chrome blocks it

Categories

(Core :: Graphics: WebRender, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla76
Tracking Status
firefox74 --- fixed
firefox75 --- fixed
firefox76 --- fixed

People

(Reporter: jrmuizel, Assigned: jrmuizel)

References

Details

Attachments

(2 files)

Blocks: wr-74
Assignee: nobody → jmuizelaar
Status: NEW → ASSIGNED

Comment on attachment 9129197 [details]
Bug 1615420. Disable DirectComposition in more situations.

Beta/Release Uplift Approval Request

  • User impact if declined: DirectComposition might be used in situations where it is buggy
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is pretty low risk. It just disables DirectComposition in a bunch of configurations to minimize initial shipping risk
  • String changes made/needed:
Attachment #9129197 - Flags: approval-mozilla-beta?

Comment on attachment 9129197 [details]
Bug 1615420. Disable DirectComposition in more situations.

Uplift approved for 74 beta 9, thanks.

Attachment #9129197 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

We need to land something like this in 75

Blocks: wr-75
No longer blocks: wr-74

This is similar to a change that landed directly into 74. We don't want to
roll-out to these users yet and we don't want to have to think about it every
release.

Duplicate of this bug: 1602948
Pushed by jmuizelaar@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/08766c2e3d6a
Disable DirectComposition on AMD and older Intel drivers on beta & release. r=aosmond

Comment on attachment 9132649 [details]
Bug 1615420. Disable DirectComposition on AMD and older Intel drivers on beta & release.

Beta/Release Uplift Approval Request

  • User impact if declined: Higher risk that shipping DirectComposition will break things
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): It just minimize the initial roll-out of DirectComposition. We don't know of any actual problems that it prevents.
  • String changes made/needed:
Attachment #9132649 - Flags: approval-mozilla-beta?
Attachment #9129197 - Flags: approval-mozilla-beta+ → approval-mozilla-beta?
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla76

Comment on attachment 9129197 [details]
Bug 1615420. Disable DirectComposition in more situations.

approved for 75.0b5

Attachment #9129197 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9132649 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment on attachment 9129197 [details]
Bug 1615420. Disable DirectComposition in more situations.

Actually do we need both patches here? (one landed on 74, the other on 76)
They seem to conflict.

Flags: needinfo?(jmuizelaar)
Attachment #9129197 - Flags: approval-mozilla-beta+ → approval-mozilla-beta?
Flags: needinfo?(jmuizelaar)
Attachment #9129197 - Flags: approval-mozilla-beta?
You need to log in before you can comment on or make changes to this bug.