Closed Bug 1615452 Opened 2 years ago Closed 7 months ago

Poor performance on obank.com.ua

Categories

(Core :: Graphics, defect, P3)

72 Branch
Desktop
Windows 10
defect

Tracking

()

RESOLVED FIXED
Webcompat Priority ?
Performance ?

People

(Reporter: ksenia, Unassigned)

References

()

Details

(Keywords: perf)

We've got a report in https://github.com/webcompat/web-bugs/issues/48167 where browsing experience on https://obank.com.ua/ is slow on Windows compared to Chrome and Edge

Steps to reproduce:

  1. Visit https://obank.com.ua/ and observe the site

Note: I can't reproduce this on my virtual Windows machine, however I see that there are a lot of elements created using box-shadow (a couple thousands!) and then they're being animated to achieve the floating effect:

 #stars {
  width:3px;
  height:3px;
  background:transparent;
  box-shadow: 319px 1395px #D65592 , 508px 2665px #D65592 , 2228px 1817px #D65592 , 2763px 2887px #D65592 , 3134px 675px #D65592 , 6182px 2694px #D65592 , 4455px 7964px #D65592 , 7879px 7136px #D65592 , 3384px 6130px #D65592 , 7607px 3302px #D65592 , 2433px 3205px #D65592 , 362px 5816px #D65592 , 3909px 875px #D65592 , 609px 398px #D65592 , 2252px 74px #D65592 , 2046px 2674px #D65592 , 7922px 1760px #D65592 , 3201px 3419px #D65592 , 4466px 2874px #D65592 , 4027px 6608px #D65592 , 4110px 7244px #D65592 , 2465px 3155px #D65592 , 7422px 6051px #D65592 , 4391px 5170px #D65592 , 1540px 6341px #D65592 , 5131px 382px #D65592 , 7566px 6723px #D65592 , 7555px 591px #D65592 , 3939px 2971px #D65592 , 2694px 211px #D65592 , 7115px 3127px #D65592 , 5095px 2323px #D65592 , 2339px 1634px #D65592 , 6834px 765px #D65592 , 4292px 3163px #D65592 , 3082px 4177px #D65592 , 1814px 3719px #D65592 , 6854px 5513px #D65592 , 5576px 3679px #D65592 , 6694px 4021px #D65592 , 6445px 5918px #D65592 , 1627px 6361px #D65592 , 6015px 3446px #D65592... 
  animation:animStar 70s linear infinite;
  border-radius:50%
}

Including perf profile from my machine https://perfht.ml/2SsQhox

Priority: -- → P3

Hello there!
I noticed that when I use WebRender (setting gfx.webrender.all to true) on my Windows 10 machine running Intel graphics, I am unable to reproduce this.
Seems WebRender handles this case just fine. But old renderer is unable to handle this website.

Webcompat Priority: --- → ?

It seems it has been fixed.

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Performance: --- → ?
Whiteboard: qf
You need to log in before you can comment on or make changes to this bug.