Closed Bug 1615575 Opened 2 months ago Closed 1 month ago

WebRender + Profiler on Fenix breaks about:config

Categories

(Core :: Graphics: WebRender, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla75
Tracking Status
firefox75 --- fixed

People

(Reporter: mark.paxman99, Assigned: ktaeleman)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:74.0) Gecko/20100101 Firefox/74.0

Steps to reproduce:

Today's Fenix
Open a tab on about:config
Toggle gfx.webrender.all to TRUE
Toggle gfx.webrender.debug.profiler to TRUE
Restart Fenix
Go back to about:config
toggle gfx.webrender.smart-profiler to TRUE
(I think any other toggle works just as well)
-> Can no longer use about:config,
---> toggles don't work any more for any item
---> can't use the Search box top right
Have to restart Fenix to sort this out.

Samsung Galaxy A40, Android 9.0.0
Today's Fenix Nightly

Product: Firefox for Android → GeckoView

Asking the GV team to triage this bug.

Component: General → Graphics: WebRender
Flags: needinfo?(ktaeleman)
Product: GeckoView → Core

Probably a dup of 1612998

Assignee: nobody → ktaeleman
Pushed by ktaeleman@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/97f4ab4661b1
Fix copy instead of reference of structure causing deletion issues. r=aosmond
Flags: needinfo?(ktaeleman)
Status: UNCONFIRMED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla75
Duplicate of this bug: 1612998
See Also: → 1612998
You need to log in before you can comment on or make changes to this bug.