Extra Spaces in Print Preview where display: none;

VERIFIED DUPLICATE of bug 127422

Status

()

Core
Print Preview
--
trivial
VERIFIED DUPLICATE of bug 127422
16 years ago
16 years ago

People

(Reporter: Jay Knight, Assigned: rods (gone))

Tracking

({testcase})

Trunk
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b)
Gecko/20020806 MultiZilla/v1.1.18
BuildID:    2002080604

When display: none is set on an inline element will produce extra spaces in
print preview (PP) (probably print, haven't checked).  I've also seen extra
spaces near dynamic content (with :before and :after) in PP.

Reproducible: Always
Steps to Reproduce:
1. Load the testcase.
2. Choose File->Print Preview
3. Notice the space between "printed" and "."

Actual Results:  Extra Space

Expected Results:  No Space
(Reporter)

Comment 1

16 years ago
Created attachment 94393 [details]
Testcase showing bug

Load the test case, and do a print preview to see the bug.
(Reporter)

Updated

16 years ago
Keywords: testcase
What do you mean by "extra spaces"?
(Assignee)

Comment 3

16 years ago
The problem is that in PP we reflow/layout with the correct font metrics but
when we display we are not picking up a font that is an exact match to the
printer font. This is a known issue.

*** This bug has been marked as a duplicate of 127422 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.