Closed Bug 1615727 Opened 10 months ago Closed 6 months ago

Enable base profiler for startup Talos tests

Categories

(Testing :: Talos, task, P3)

Version 3
task

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1586939

People

(Reporter: mconley, Unassigned)

References

Details

(Whiteboard: [fxperf:p1])

Attachments

(1 file)

The base profiler work in bug 1492121 makes it possible to get samples from before XPCOM starts up. This is useful data to have for things like startup performance.

So we should enable the base profiler for our startup performance tests.

Whiteboard: [fxperf] → [fxperf][perftest:triage]
Assignee: nobody → mconley
Status: NEW → ASSIGNED

Marking fxperf:p1 because there's already a patch, but given bug 1586939 should (hopefully soon) remove the need for this patch, I would otherwise have given this a lower priority.

Whiteboard: [fxperf][perftest:triage] → [fxperf:p1][perftest:triage]
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7dee76ec48c4
Enable base profiler when profiling Talos startup tests. r=davehunt
Whiteboard: [fxperf:p1][perftest:triage] → [fxperf:p1]
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla75

This appears to have contributed to bug 1220362.

Hey malexandru, would you be able to back out 7dee76ec48c4 when you have a moment?

Flags: needinfo?(malexandru)
See Also: → 1220362

Done, thank you!

Status: RESOLVED → REOPENED
Flags: needinfo?(malexandru)
Resolution: FIXED → ---
Target Milestone: mozilla75 → ---
Backout by malexandru@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5490c9f430b8
Backed out changeset 7dee76ec48c4 for causing Talos failures.

Hey Mike, I assume we still want that? Are you going to continue working on the bug?

Flags: needinfo?(mconley)

Maybe we should simply wait for bug 1586939 to be fixed?

(In reply to Henrik Skupin (:whimboo) [⌚️UTC+2] from comment #10)

Maybe we should simply wait for bug 1586939 to be fixed?

Gerald, maybe you can add some feedback here? Given that you know more about the ETA here. I'm fairly sure it can still wait for a moment.

Flags: needinfo?(gsquelart)
Assignee: mconley → nobody
Status: REOPENED → NEW
Priority: P1 → P3

Alright, I'll start tomorrow! Sorry for the delay.

Flags: needinfo?(gsquelart)

Thanks. I assume we can mark it as dependent then.

Depends on: 1586939
Flags: needinfo?(mconley)

Gerald, is there anything else we would have to do for Talos, or shall we dupe this bug to bug 1586939?

Flags: needinfo?(gsquelart)

Henrik: Now that bug 1586939 has landed, Base Profiler should Just Work™!

I don't know how the profiler is activated in these tests. If you set the environment variable MOZ_PROFILER_STARTUP=1 before starting Firefox, the output profile should contain new tracks named "GeckoMain (pre-xul)" with profiling information from before the main Gecko Profiler start in XUL. E.g.: https://share.firefox.dev/36NLPpK

To calibrate expectations: At the moment it's only the main thread, and there are no markers and few labels, so you'll only see stack sampling during that time. Markers&labels could be added outside of XUL, through "BaseProfiler.h" functions.

Flags: needinfo?(gsquelart)

Yes, I can see those tracks in the appropriate Talos jobs now that are related to profiling the startup. Here one example for the startup about:home paint:

https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&tier=1%2C2%2C3&searchStr=talos%2Cprof&selectedTaskRun=AZLuBbpaRw6Qo029sK09Bg-0

Profile: https://share.firefox.dev/3cpxW2c

Mike or Florian, I assume that looks all fine now and we can close this bug as fixed?

Flags: needinfo?(mconley)
Flags: needinfo?(florian)

Yes, looks good to me now! Thanks for checking the profiles :-).

Status: NEW → RESOLVED
Closed: 9 months ago6 months ago
Flags: needinfo?(mconley)
Flags: needinfo?(florian)
Resolution: --- → FIXED
Assignee: nobody → mconley
Assignee: mconley → nobody
Resolution: FIXED → DUPLICATE
Duplicate of bug: 1586939
You need to log in before you can comment on or make changes to this bug.