Closed Bug 16158 Opened 21 years ago Closed 21 years ago

wrong value passed

Categories

(Core :: Layout: Form Controls, defect, P3)

Other
Other
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: marcel, Assigned: kmcclusk)

References

()

Details

(Whiteboard: Have fix in my tree)

submitting a form like this :
< FORM>
< SELECT NAME="test">
< OPTION VALUE=""> nothing
< OPTION VALUE="value"> value
< /SELECT>
< /FORM>
with the current option being "nothing" the value for test in the resulting form
 would be 'nothing'. but it should be empty ('').

see http://www.w3.org/TR/REC-html40/interact/forms.html#edef-OPTION
for the html4 definition
Reassigning to Rod.
Assignee: rods → kmcclusk
*** Bug 16290 has been marked as a duplicate of this bug. ***
Whiteboard: Have fix in my tree
Status: NEW → ASSIGNED
Target Milestone: M12
Setting milestone to M12
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Fixed in Oct 14, 1999 5:00PM build.
Status: RESOLVED → VERIFIED
OK... but I don't understand what the URL above has to do with this. There is no
form at that URL. Verifying as fixed & begging kmmcclusk for a reopen if it
somehow wasn't fixed...
You need to log in before you can comment on or make changes to this bug.