Closed Bug 1615814 Opened 4 years ago Closed 4 years ago

360° video plays as 2 views on youtube.

Categories

(Core :: Graphics: CanvasWebGL, defect, P1)

74 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1616132
Tracking Status
firefox-esr68 --- unaffected
firefox73 --- unaffected
firefox74 + fixed
firefox75 + fixed

People

(Reporter: caseydonders, Assigned: jgilbert)

References

(Regression, )

Details

(Keywords: regression)

Attachments

(1 file)

Attached image firefox_GrtwXP0CIM.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:75.0) Gecko/20100101 Firefox/75.0

Steps to reproduce:

Search a 360 video on youtube and click play.

Actual results:

Shows a video of a panoramic top half with bottom half is behind the camera

Expected results:

It should have been a 360 video.

Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Untriaged → Audio/Video: Playback
Ever confirmed: true
Flags: needinfo?(jgilbert)
Keywords: regression
Product: Firefox → Core
Regressed by: webgl-ipc-refactor
Summary: 360 video plays as 2 views on youtube. → 360° video plays as 2 views on youtube.
Version: 75 Branch → 74 Branch
Version: 74 Branch → 75 Branch
Version: 75 Branch → 74 Branch

Ohh apologies for that

This is a really weird failure case, and I'm not sure what's up. I can reproduce it, but I don't know where to start looking into it. I don't even get the drag-to-pan hand cursor in Firefox, which shouldn't have anything to do with WebGL.

Flags: needinfo?(jgilbert)
Priority: -- → P1

:bryce, is there someone that can work on this P1 issue (tracked as regression for FF74 and 75) ?

Flags: needinfo?(bvandyk)

it seems as if WebGL is disabled on YouTube, i managed to get the same effect in Google Chrome by disabling WebGL.

Chrome Version 80.0.3987.106 (Official Build) (64-bit) with scriptsafe plugin to disable WebGL

This may be due to a failed sanity check in youtube: Bug 1616132

See Also: → 1616132
Severity: normal → critical
Component: Audio/Video: Playback → Canvas: WebGL

Fixed by bug 1616132.

Assignee: nobody → jgilbert
Status: NEW → ASSIGNED

:jgilbert, can we close this as dupe then? Thank you!

Flags: needinfo?(jgilbert)

Works again for me in Nightly.

Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Flags: needinfo?(jgilbert)
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: