/leave should close the view even if channel not connected

RESOLVED FIXED

Status

Other Applications
ChatZilla
RESOLVED FIXED
15 years ago
13 years ago

People

(Reporter: Rodger, Assigned: Robert Ginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
When I try to join a channel and the join is refused I can't /leave that
channel.  If I /hide the channel and then attempt to /join another channel, the
hidden window opens and the new successfully joined channel is hidden.  The new
channel seems to be open but the window is showing the information from the
"un-joined" channel.  It's simple to duplicate.

Comment 1

15 years ago
There's two problems here.  The first is that I broke /hide with the conversion
to <deck>.  The second is that /leave should probably close the view even if the
channel hasn't been connected to. (Or possibly a /close command for that)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

15 years ago
*** Bug 163896 has been marked as a duplicate of this bug. ***

Comment 3

15 years ago
It appears that Ctrl+X does what is expected--it closes the tab. The right click
context menu that says "Leave '#channel'  Ctrl+X" doesn't behave correctly. I'd
expect /leave and the context menu to both close the channel tab even if it
isn't joined.

Observed with Mozilla 2002091908 on win2k.

Comment 4

15 years ago
Changing summary.
OS: Windows 98 → All
Hardware: PC → All
Summary: /leave does not work if channel not joined causing new /join problems → /leave should close the view even if channel not connected

Comment 5

15 years ago
Got hit by this one as well. Tried to join an +i channel which was refused.
Subsequently there was no way to close the channel window. Leave would simply
state that I hadn't joined. Take this spam as a vote for this bug :-)

Comment 6

15 years ago
You can use /hide or /delete to make the view go away.  Or using the menus,
View->Close View.

Updated

14 years ago
Depends on: 229545

Comment 7

14 years ago
Chatzilla 0.9.54 is now available and has landed on the trunk (cvs). This should
have resolved this bug; if it has not, please reopen it.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.