Closed Bug 1616035 Opened 6 months ago Closed 4 months ago

Port |Bug 491577 - add API for deleting a single closed window| and |Bug 415941 – nsISessionStore documentation: clarify the meaning of "window"| to SeaMonkey

Categories

(SeaMonkey :: Session Restore, task)

task
Not set
normal

Tracking

(seamonkey2.53 affected, seamonkey2.57esr affected)

RESOLVED FIXED
seamonkey 2.73
Tracking Status
seamonkey2.53 --- affected
seamonkey2.57esr --- affected

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Port the following to SeaMonkey:

  • Bug 491577 - add API for deleting a single closed window
  • Bug 415941 – nsISessionStore documentation: clarify the meaning of "window"

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: none
Testing completed (on m-c, etc.): 2.53.2
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: none

Attachment #9127167 - Flags: review?(frgrahl)
Attachment #9127167 - Flags: approval-comm-release?
Attachment #9127167 - Flags: approval-comm-esr60?
Comment on attachment 9127167 [details] [diff] [review]
Add delete single window API

> -[scriptable, uuid(a2f14785-c4d4-4bac-b048-a849d2e74513)]
> +[scriptable, uuid(27a8bd2b-dd76-4cee-82eb-a25f6a94478f)]

As far as I know this no longer is needed. If I remember correctly the checking hooks were removed some time ago and the id can stay the same. Does not hurt so can stay.

> +      throw (Components.returnCode = Cr.NS_ERROR_INVALID_ARG);
Bug 944073 Use Components.Exceptions instead of Components.returnCode seems to be a good follow-up for later.
Attachment #9127167 - Flags: review?(frgrahl)
Attachment #9127167 - Flags: review+
Attachment #9127167 - Flags: approval-comm-release?
Attachment #9127167 - Flags: approval-comm-release+
Attachment #9127167 - Flags: approval-comm-esr60?
Attachment #9127167 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/8e78266d3e9d
Port |Bug 491577 - add API for deleting a single closed window| and |Bug 415941 – nsISessionStore documentation: clarify the meaning of "window"| to SeaMonkey. r=frg

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey 2.73
You need to log in before you can comment on or make changes to this bug.