Must close all mozilla instances, so 'su' can launch moz as root

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
minor
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: knucklehead, Assigned: Matti)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0.0) Gecko/20020510
BuildID:    Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0.0) Gecko/20020510

I found that in order for a "su"ed root to launch mozilla as root I must first
close all other user instances of mozilla currently running.

Reproducible: Always
Steps to Reproduce:
1.Launch mozilla as a regular user
2.from an xterm, su your way to root, then "# mozilla&"
3.the root-launched mozilla will be a mozilla with user permissions, settings.
4. Close all instances of mozilla running on your system, then try the same
command "# mozilla&"  -- launches as root, with all the permissions, settings, etc.

Actual Results:  Same as the first time.

Expected Results:  Launch a root-priveleged mozilla from a "su"ed root while
other user-priv'ed mozillas run on same system.

Comment 1

16 years ago
A dup, but i can't find it.. 
If you were running on same X-display, this is by design. CC Blizzard for comment
What is LOGNAME set to after you su to root?

Comment 3

16 years ago
WFM Linux 2002-08-30-05

Use "su -" to switch to root, not "su". Please reopen if you've used "su -".
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.