All users were logged out of Bugzilla on October 13th, 2018

right click 'Search Messages ...' on Inbox will cause selected message to be marked un-read

VERIFIED DUPLICATE of bug 142408

Status

VERIFIED DUPLICATE of bug 142408
16 years ago
10 years ago

People

(Reporter: pyrometr, Assigned: naving)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

There are multiple ways of Searching Messages in the mail client.

1) right click on folder and choose 'Search Messages ...'
2) menu item Tools -> Search Messages ...
3) keyboard short-cut Ctrl+Shift+F

If I have a message selected in the Inbox and I choose the first method of
searching for messages in say my Inbox then it will mark that message as read. 
This seems silly.

The other two methods of searching messages do not produce this problem.

Reproducible: Always
Steps to Reproduce:
1. Select an un-read message in the Inbox
2. Right click on the 'Inbox' and select 'Search Messages ...'
3. Notice the 'selected' message has now been marked as un-read (green icon)

Actual Results:  THe search dialogue appears but the selected message in the
Inbox has been marked as un-read.

Expected Results:  The search dialogue should have appeared and the message
should not have been marked un-read.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 142408 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
marking verified as a duplicate
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Search → MailNews: Message Display
QA Contact: laurel → search
You need to log in before you can comment on or make changes to this bug.