Closed Bug 1616308 Opened 3 years ago Closed 5 months ago

Gmail eats text that you insert at the start of the "signature" section, if your Default Text Style and signature both use Verdana and your signature starts with blank lines (STEPS TO REPRO IN COMMENT 17)

Categories

(Web Compatibility :: Desktop, defect, P3)

Tracking

(firefox76 wontfix, firefox77 wontfix, firefox78 fix-optional)

RESOLVED WORKSFORME
Tracking Status
firefox76 --- wontfix
firefox77 --- wontfix
firefox78 --- fix-optional

People

(Reporter: nosh27, Unassigned)

References

()

Details

(Keywords: webcompat:site-wait)

Attachments

(6 files, 1 obsolete file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:73.0) Gecko/20100101 Firefox/73.0

Steps to reproduce:

Compose email in gmail.
Click white space between current text and signature, begin to type.

Actual results:

Instead of text appearing on the screen, the line disappears and no text appears.

Expected results:

Text should have appeared on the screen. This has not occurred in any other browser (Chrome, Brave, Vivaldi, Opera, and Safari were all tested).

Summary: Gmail compose, cursor disappears, blank space inserted → Gmail compose, cursor disappears, no text appears when typing, blank line disappears

Hi NahtTelling,

Thanks for reporting this bug and providing us with a video.

I tried to reproduce the behavior reported on Firefox Nightly 76.0a1 on Mac OSX 10.14 but I was unable to. Could you please download the latest Firefox Nightly version and confirm if you are able to reproduce it on your end? You can download it from here: https://nightly.mozilla.org/

Are there are any other additional steps we can try to reproduce this issue? We'd be happy to take another look.

Thanks,
Virginia

Flags: needinfo?(nosh27)

Hi,

I'm marking this as Resolved-Incomplete due to lack of response. If the issue is still reproducible with the latest Firefox version, feel free to reopen the bug with more information.

Regards,
Virginia

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → INCOMPLETE

Sorry about the delayed reply.

I have downloaded the latest nightly build (77.0a1 (2020-04-13) (64-bit)) and am still experiencing the same issue. I am attaching a video again.

Flags: needinfo?(nosh27)

Just to add more detail, the new video was made on a different computer than the original--so the problem is persistent even on different machines.

Status: RESOLVED → UNCONFIRMED
OS: Unspecified → macOS
Hardware: Unspecified → Desktop
Resolution: INCOMPLETE → ---
Version: 73 Branch → 75 Branch

Also wanted to add I am on OSX 10.15.4 (19E266).

Virginia,

Just tagging you to let you know I added more info and reopened the bug.

Flags: needinfo?(virginia.balducci)

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Graphics
Product: Firefox → Core
Component: Graphics → Layout

I've been trying to reproduce this on the latest Nightly, but so far am unsuccessful. I tried both with and without a custom signature (similar to what is show in the reporter's video) without much luck. Granted, I'm on OS X 10.14.

jfkthame: Any ideas?

Component: Layout → Layout: Text and Fonts
Flags: needinfo?(virginia.balducci) → needinfo?(jfkthame)

I also tried this in Nightly (currently on 10.15.4 Beta (19E224g)), but wasn't able to reproduce it.

Reporter, could you please attach the about:support text (use the "Copy text to clipboard" button there, then paste it into a new attachment here) from your system?

If you run Firefox in Safe Mode (Help > Restart with Add-ons Disabled), does the problem still occur?

Flags: needinfo?(jfkthame) → needinfo?(nosh27)

Problem still occurred in this test. See other new attachments.

Flags: needinfo?(nosh27)

This was my 3rd test with a different email address. None of the three tests replicated the issue until I changed another setting (see other attachment).

In this test, I changed the "default text style" to Verdana to match the original email settings. The problem returned, so it must be related to that setting.

The "second line" is only present, however, due to the signature settings. The signature has 2 blank lines prior to the word "Best". If those lines are removed, the problem also goes away (since there are lines between the first line and the start of the signature (with "best"). So it's something with the interaction between those extra lines and the default text.

I will also attach the about:support as requested.

Severity: normal → S2
Flags: needinfo?(dholbert)
Priority: -- → P3

[NOTE: I'm editing this comment to update/clarify my steps to reproduce, and which browsers are affected]

I've been able to reproduce this.

Here are the steps that I followed, which were sufficient to trigger the bug for me in two independent Gmail accounts.

(0) Be using Firefox (or Safari, or Edge, or Chrome-with-a-Firefox-user-agent)
(1) In Gmail Settings, change the default text style to "Verdana" as explained at the bottom of article at https://support.google.com/mail/answer/8260
(2) A little bit further down in the same Gmail Settings page, create a Gmail signature, with this text (starting with 2 blank lines):



abc

After you've created this signature, with the signature still in the signature entry box, do a "select-all" operation and choose Verdana as the font for the whole signature, using the dropdown menu below the signature-entry textbox.

(3) Under the next section of settings, "Signature Defaults", choose this signature for my default "from" email address (in the "For new emails use" section).

(4) Scroll to the bottom of the page and click "Save".

(5) Compose a new message

(6) Click the blank space immediately underneath the "--" divider (which separates the not-yet-filled-out email body from my "Best, blah blah" signature)

(7) Try to type anything (e.g. type an "a" character)

ACTUAL RESULTS:

  • The two blank lines collapse to one blank line, and the cursor and the text that I'm typing is not shown.
  • If you have the web console open (ctrl+shift+k in Firefox) when the issue happens, you'll see an error saying something like TypeError: can't access property "Fh", this.yd().Hg() is null

From looking at the DOM Inspector while typing, and from looking at the actual resulting email, it seems this is not a text-layout bug (i.e. there's not text in the page that is getting clipped or is failing to get laid out).

Instead, the actual text that you type seems to be getting swallowed up and is not getting inserted into the page at all, probably due to gmail hitting some sort of unexpected condition while handling a boundary condition between inline elements.

So: not 100% sure where the bug lies, but this is likely a DOM bug, or a "contenteditable" bug, or a bug in Gmail's own logic/expectations (or some combination thereof).

Moreover: the exact same bug happens in Edge 18 (before Edge switched to be Chromium-based) -- I just tested and was able to reproduce the bug there.

So, bottom-line: Gmail is broken in the exact same way, in two completely independent-from-each-other browser engine implementations. This is strong evidence that the fault here lies with Gmail, not with the browsers; Gmail is probably accidentally depending on some Chrome behavioral quirk (or possibly even a Chrome bug).

--> Reclassifying as WebCompat

Status: UNCONFIRMED → NEW
Component: Layout: Text and Fonts → Desktop
Ever confirmed: true
Flags: needinfo?(jfkthame)
Product: Core → Web Compatibility
Summary: Gmail compose, cursor disappears, no text appears when typing, blank line disappears → Gmail eats text that you insert at the start of the "signature" section, if your Default Text Style and signature both use Verdana and your signature starts with blank lines
Version: 75 Branch → unspecified
OS: macOS → All
Hardware: Desktop → All
Version: unspecified → Trunk

Definitive proof that this is entirely a Gmail bug:

  • I verified that I can reproduce in Safari 13.1 on MacOS (along with reproducing in Firefox and pre-chromium EdgeHTML)
  • I verified that I can reproduce in Chrome itself, IF I make Chrome use a Firefox user-agent string.
  • ...and similarly, if I use Firefox with a Chrome user-agent string, then the bug goes away.

So: this is 100% a bug in the version of Gmail that gets served to non-Chrome browsers.

Also: at the moment the bug happens (in both Firefox and Chrome-pretending-to-be-Firefox), a TypeError shows up in the web console:

cause: TypeError: can't access property "Fh", this.yd().Hg() is null
​> message: "Error in protected function: can't access property "Fh", this.yd().Hg() is null"

Devtools says this is for the following URL & line/column (though I'm not sure this info is precisely accurate or at least useful, given that it's obfuscated/minified):
https://mail.google.com/_/scs/mail-static/_/js/k=gmail.main.en.[...SNIP...]R9mIA/m=e
lineNumber: 46
columnNumber: 440
​​
(I've redacted part of the URL with [...SNIP...] because it's super-long and perhaps somewhat specific to my account, not sure.)

Here's a short screencast of me reproducing the bug, performing steps 5-7 of the STR from comment 17. (I've already performed the prior steps before hitting record here.)

When you see the blank line disappear in this screencast, that's when I started typing.

Attachment #9145345 - Attachment is obsolete: true

I just reached out to some folks at Google to give them a heads-up about this. Hopefully they can take a look soon.

Thanks again for the bug report!

(In reply to Daniel Holbert [:dholbert] from comment #19)

Moreover: the exact same bug happens in Edge 18 (before Edge switched to be Chromium-based)

Also worth noting (and not surprising): the new Chromium-based Edge does not reproduce this bug -- presumably it gets the same non-buggy version/codepath that Chrome gets.

(But: if I use Edge's devtools to force this new Edge to have a Firefox user agent string, then it does show the bug - just like Chrome does when I make similar UA-string-tweaks to it, per second bullet point in Comment 20)

Summary: Gmail eats text that you insert at the start of the "signature" section, if your Default Text Style and signature both use Verdana and your signature starts with blank lines → Gmail eats text that you insert at the start of the "signature" section, if your Default Text Style and signature both use Verdana and your signature starts with blank lines (STEPS TO REPRO IN COMMENT 17)

Daniel, I was not able to reproduce the issue following your steps to reproduce. The two blank lines do not collapse to one blank line, and the caret is shown, with text being accepted:

https://prnt.sc/-hojtF2jtuaA

Is the issue still reproducible on your side?

Tested with:

Browser / Version: Firefox Release 101.0.1 (64-bit)/ Firefox Nightly 104.0a1 (2022-06-27) (64-bit)
Operating System: Mac OSX Catalina 10.15.7

Flags: needinfo?(dholbert)

I can't repro either. I tested with my personal gmail account and with my Mozilla-email gmail account (which is on a slightly-older Gmail UI). Seems like this is WORKSFORME in both cases.

Reporter, as one additional data-point: if you could confirm that it works for you as well, that would be great!

(side note: while testing, I noticed that Gmail's "--" signature-separator (with newlines on each side) seems to use the "Sans Serif" font, as reported in the Gmail compose UI itself, despite the fact that [per the STR] I've chosen Verdana as the default everywhere. I'm guessing that part of the issue here [on Gmail's end] had to do with the fact that the text was being inserted right at the threshold between a section using that font and the Verdana-formatted signature.)

Status: NEW → RESOLVED
Closed: 3 years ago5 months ago
Flags: needinfo?(dholbert)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.