Closed Bug 1616353 Opened 8 months ago Closed 7 months ago

BrowsingContext should support being used as `nsILoadContext`.

Categories

(Core :: DOM: Navigation, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
mozilla77
Fission Milestone M6
Tracking Status
firefox77 --- fixed

People

(Reporter: nika, Assigned: nika)

References

Details

Attachments

(23 files, 1 obsolete file)

47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review

For various changes to how we navigate, it is important to have the information required to start a load available in the parent process. Currently some of this information is only available through the nsILoadContext interface, implemented by nsDocShell, and the LoadContext IPC helper type.

The new(-ish) BrowsingContext type could be made to support these LoadContext operations, which would enable reading information stored on the LoadContext, such as the private browsing state, in any process, as well as helping enable parent-process initiated loads.

This flag tries to change nsILoadContext flags late during browser creation,
which won't be possible after this patch stack.

This is necessary to avoid the use of setOriginAttributesBeforeLoading, which is
being removed in this patch set.

This could cause issues, as we could incorrectly override the decision made by
nsWindowWatcher, and then override the decision again after the method returns.
This could cause the initial content browser to be configured incorrectly.

This is OK, as all chrome BrowsingContext instances are always in the same
BrowsingContextGroup, so we don't need to have the initial opener avaliable when
creating the BrowsingContext to determine its BrowsingContextGroup.

This is used in part 7.2 to avoid propagating the opener window around when
creating chrome windows.

This also moves nsDocShell's implementation of nsILoadContext to be based on its
BrowsingContext.

This patch does not, by itself, fix all places which try to mutate
nsILoadContext. Those are fixed by the other parts of this patch stack.

This API is no longer possible to implement, as it will always try to set the
OriginAttributes on a content BrowsingContext after it has been attached, and JS
can never observe a detached BrowsingContext.

Users of this API are instead changed to perform assertions that
originAttributes have already been set correctly.

Many of these setters are redundant, and duplicate work done elsewhere. As it is
no longer correct to set nsILoadContext attributes at these times, they're being
replaced with assertions.

Previously, a load of the URI within a chrome docshell would start before the
chrome docshell has had a chance to be configured. This could cause problems, as
the load would be configured incorrectly.

After these changes, starting the load is delayed until after nsILoadContext
configuration is complete.

This is necessary as, by this point, the BrowsingContext has already been
attached, and can no longer have its nsILoadContext flags updated.

This type replaces the individual properties, like nextRemoteTabId and
presetOpenerWindow, which were passed around by frontend code for window opening
requests performed by Gecko. This new type is intentionally native-only to make
it easier to pass more information down to newly created windows in the future.

This patch builds on top of part 7.1 by creating this object within
nsWindowWatcher and ContentParent to carry the relevant information through
provider interfaces when creating new content windows. The nsOpenWindowInfo
object is not created for new chrome windows.

This patch does not propagate these flags all of the way through to the
nsFrameLoader. That change is performed in later parts to keep each part
smaller.

This patch adds a openWindowInfo XPCOM attribute to the nsIBrowser interface
supported by the browser custom element. This attribute is then read by
XULFrameElement, and passed to nsFrameLoader to ensure the relevant flags
are used for newly opened windows.

This patch does not add support for passing openWindowInfo into mozbrowser
elements.

The interface changes which browser.js and tabbrowser.js are being updated for
are performed in earlier parts. This patch just covers the required changes to
frontend code to propagate this information down to the nsFrameLoader when it is
created.

The interface changes which GeckoViewNavigation.jsm is being updated for are
performed in earlier parts. This patch just covers the required changes to
frontend code to propagate this information down to the nsFrameLoader when it is
created.

The interface changes which ssb.jsm is being updated for are performed in
earlier parts. This patch just covers the required changes to frontend code to
propagate this information down to the nsFrameLoader when it is created.

These properties used to be passed to newly created content windows in many
different ways, but are now unified under nsOpenWindowInfo. This patch cleans up
the remaining properties.

Due to the earlier changes, mozbrowser doesn't handle opening windows properly
anymore.

This method is no longer necessary, as frontend will always make the correct
decisions for the remoteness of the intial content browser by reading
openWindowInfo.

Attachment #9133694 - Attachment description: Bug 1616353 - Part 7.8: [WIP] Disable window opening stuff for mozbrowser, r= → Bug 1616353 - Part 10.1: Remove special handling of window.open in mozbrowser,
Attachment #9133696 - Attachment description: Bug 1616353 - Part 9: [WIP] Remove or fix tests which try to set OriginAttributes too late, r= → Bug 1616353 - Part 12: Remove or fix tests which try to set OriginAttributes too late,
Duplicate of this bug: 1616603

Failing test docshell/test/unit/test_setUsePrivateBrowsing.js | - Missing expected exception. Should not be able to change private browsing state after initial load has started in bug 1607984, likely because of this issue.

Blocks: 1607984
Pushed by nlayzell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/11a279c8da08
Part 1: Remove unused aIsPreallocated flag from NotifyTabContextUpdated, r=kmag
https://hg.mozilla.org/integration/autoland/rev/2692c2c1396b
Part 2: Remove the isPrivate flag from ParentShowInfo, r=kmag
https://hg.mozilla.org/integration/autoland/rev/1ab9d22c73bb
Part 3: Use an attribute to set geckoViewUserContextId on a browser, r=geckoview-reviewers,esawin
https://hg.mozilla.org/integration/autoland/rev/f42bb5b48c1b
Part 4: Don't second-guess CHROME_{REMOTE,FISSION}_WINDOW flags, r=kmag
https://hg.mozilla.org/integration/autoland/rev/ae6058552969
Part 5: Always set the opener for chrome windows late, r=kmag
https://hg.mozilla.org/integration/autoland/rev/f89a89015114
Part 6.1: Implement nsILoadContext on BrowsingContext, r=smaug
https://hg.mozilla.org/integration/autoland/rev/cb88e0bbb3b9
Part 6.2: Remove setOriginAttributesBeforeLoading API, r=smaug
https://hg.mozilla.org/integration/autoland/rev/ea966e78b296
Part 6.3: Replace many nsILoadContext mutators with assertions, r=smaug
https://hg.mozilla.org/integration/autoland/rev/6b6b99af186d
Part 6.4: Delay loading chrome window URIs until docshell has been configured, r=smaug
https://hg.mozilla.org/integration/autoland/rev/ada17fb8fca7
Part 6.5: Assert nsILoadContext attributes are correctly set when opening windows, r=smaug
https://hg.mozilla.org/integration/autoland/rev/8a13355b4ac4
Part 7.1: Introduce a new nsOpenWindowInfo type, r=Gijs,kmag
https://hg.mozilla.org/integration/autoland/rev/765d3364cca0
Part 7.2: Create and use nsOpenWindowInfo types in nsWindowWatcher logic, r=kmag
https://hg.mozilla.org/integration/autoland/rev/e414df387524
Part 7.3: Use nsOpenWindowInfo for initializing xul:browser elements, r=kmag
https://hg.mozilla.org/integration/autoland/rev/363c13296fda
Part 7.4: Pass nsOpenWindowInfo through tabbrowser, r=Gijs
https://hg.mozilla.org/integration/autoland/rev/bd1706c57d91
Part 7.5: Pass nsOpenWindowInfo through Geckoview, r=geckoview-reviewers,esawin,agi
https://hg.mozilla.org/integration/autoland/rev/a4735096e01b
Part 7.6: Pass nsOpenWindowInfo through the single-site browser, r=Gijs
https://hg.mozilla.org/integration/autoland/rev/a7700472807a
Part 7.7: Remove window initialization properties which are redundant with nsOpenWindowInfo, r=kmag
https://hg.mozilla.org/integration/autoland/rev/6955906262c0
Part 8: Remove forceInitialBrowserNonRemote, r=Gijs
https://hg.mozilla.org/integration/autoland/rev/6f09bc1c476d
Part 9: Ensure the correct OriginAttributes are set on opened TabContext, r=kmag
https://hg.mozilla.org/integration/autoland/rev/580e790c5d17
Part 10.1: Remove special handling of window.open in mozbrowser, r=kmag
https://hg.mozilla.org/integration/autoland/rev/c026b06063a5
Part 10.2: Remove tests for window.open in mozbrowser, r=kmag
https://hg.mozilla.org/integration/autoland/rev/3aacc7cfe33f
Part 11: Remove broken TabGroup assertion, r=farre
https://hg.mozilla.org/integration/autoland/rev/cb77e9149cf8
Part 12: Remove or fix tests which try to set OriginAttributes too late, r=kmag
https://hg.mozilla.org/integration/autoland/rev/3a43210e4900
Part 13: Don't create an extra BrowsingContext when opening a new tab from content, r=kmag
Backout by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8974adf9926b
Backed out 24 changesets for fission assertion failures nsGlobalWindowOuter.cpp.

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=testfailed%2Cbusted%2Cexception&revision=3a43210e49005094bab673e7f963e19901c39fe2&selectedJob=296449332

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=296449332&repo=autoland

Backout link: https://hg.mozilla.org/integration/autoland/rev/8974adf9926b

[task 2020-04-06T16:39:36.246Z] 16:39:36     INFO - TEST-START | docshell/test/navigation/test_grandchild.html
[task 2020-04-06T16:39:36.619Z] 16:39:36     INFO - GECKO(1225) | ### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to /tmp/tmpntljVn.mozrunner/runtests_leaks_tab_pid1691.log
[task 2020-04-06T16:39:36.639Z] 16:39:36     INFO - GECKO(1225) | [Child 1452, Main Thread] WARNING: NS_ENSURE_TRUE(request) failed: file /builds/worker/checkouts/gecko/netwerk/base/nsLoadGroup.cpp, line 591
[task 2020-04-06T16:39:36.661Z] 16:39:36     INFO - GECKO(1225) | [Child 1452, Main Thread] WARNING: NS_ENSURE_TRUE(request) failed: file /builds/worker/checkouts/gecko/netwerk/base/nsLoadGroup.cpp, line 591
[task 2020-04-06T16:39:36.666Z] 16:39:36     INFO - GECKO(1225) | [Child 1452, Main Thread] WARNING: NS_ENSURE_TRUE(request) failed: file /builds/worker/checkouts/gecko/netwerk/base/nsLoadGroup.cpp, line 591
[task 2020-04-06T16:39:36.672Z] 16:39:36     INFO - GECKO(1225) | [Child 1452, Main Thread] WARNING: NS_ENSURE_TRUE(request) failed: file /builds/worker/checkouts/gecko/netwerk/base/nsLoadGroup.cpp, line 591
[task 2020-04-06T16:39:36.700Z] 16:39:36     INFO - GECKO(1225) | [Child 1452, Main Thread] WARNING: NS_ENSURE_TRUE(currentInner) failed: file /builds/worker/checkouts/gecko/dom/base/WindowDestroyedEvent.cpp, line 106
[task 2020-04-06T16:39:36.719Z] 16:39:36     INFO - GECKO(1225) | [Child 1452, Main Thread] WARNING: NS_ENSURE_TRUE(currentInner) failed: file /builds/worker/checkouts/gecko/dom/base/WindowDestroyedEvent.cpp, line 106
[task 2020-04-06T16:39:36.720Z] 16:39:36     INFO - GECKO(1225) | [Child 1452, Main Thread] WARNING: NS_ENSURE_TRUE(currentInner) failed: file /builds/worker/checkouts/gecko/dom/base/WindowDestroyedEvent.cpp, line 106
[task 2020-04-06T16:39:36.721Z] 16:39:36     INFO - GECKO(1225) | [Child 1452, Main Thread] WARNING: NS_ENSURE_TRUE(currentInner) failed: file /builds/worker/checkouts/gecko/dom/base/WindowDestroyedEvent.cpp, line 106
[task 2020-04-06T16:39:36.922Z] 16:39:36     INFO - GECKO(1225) | Couldn't convert chrome URL: chrome://branding/locale/brand.properties
[task 2020-04-06T16:39:37.103Z] 16:39:37     INFO - GECKO(1225) | [Child 1691, Main Thread] WARNING: could not set real-time limit at process startup: file /builds/worker/checkouts/gecko/dom/ipc/ContentChild.cpp, line 1687
[task 2020-04-06T16:39:37.144Z] 16:39:37     INFO - GECKO(1225) | [Child 1691, Main Thread] WARNING: NS_ENSURE_TRUE(mPresShell) failed: file /builds/worker/checkouts/gecko/layout/base/nsPresContext.cpp, line 844
[task 2020-04-06T16:39:37.340Z] 16:39:37     INFO - GECKO(1225) | [Child 1691, Main Thread] WARNING: '!topWindow', file /builds/worker/checkouts/gecko/dom/html/HTMLIFrameElement.cpp, line 246
[task 2020-04-06T16:39:37.368Z] 16:39:37     INFO - GECKO(1225) | [Child 1691, Main Thread] WARNING: '!topWindow', file /builds/worker/checkouts/gecko/dom/html/HTMLIFrameElement.cpp, line 246
[task 2020-04-06T16:39:37.389Z] 16:39:37     INFO - GECKO(1225) | [Child 1691, Main Thread] WARNING: '!topWindow', file /builds/worker/checkouts/gecko/dom/html/HTMLIFrameElement.cpp, line 246
[task 2020-04-06T16:39:37.409Z] 16:39:37     INFO - GECKO(1225) | [Child 1691, Main Thread] WARNING: '!topWindow', file /builds/worker/checkouts/gecko/dom/html/HTMLIFrameElement.cpp, line 246
[task 2020-04-06T16:39:37.546Z] 16:39:37     INFO - GECKO(1225) | JavaScript error: http://test1.example.org/tests/docshell/test/navigation/parent.html, line 9: TypeError: can't access property "postMessage", opener is null
[task 2020-04-06T16:39:37.546Z] 16:39:37     INFO - GECKO(1225) | JavaScript error: http://test1.example.org/tests/docshell/test/navigation/parent.html, line 9: TypeError: can't access property "postMessage", opener is null
[task 2020-04-06T16:39:37.550Z] 16:39:37     INFO - GECKO(1225) | JavaScript error: http://test1.example.org/tests/docshell/test/navigation/parent.html, line 9: TypeError: can't access property "postMessage", opener is null
[task 2020-04-06T16:39:37.568Z] 16:39:37     INFO - GECKO(1225) | JavaScript error: http://test1.example.org/tests/docshell/test/navigation/parent.html, line 9: TypeError: can't access property "postMessage", opener is null
[task 2020-04-06T16:39:37.644Z] 16:39:37     INFO - GECKO(1225) | [Child 1691, Main Thread] WARNING: NS_ENSURE_TRUE(request) failed: file /builds/worker/checkouts/gecko/netwerk/base/nsLoadGroup.cpp, line 591
[task 2020-04-06T16:39:37.689Z] 16:39:37     INFO - GECKO(1225) | [Child 1691, Main Thread] WARNING: NS_ENSURE_TRUE(request) failed: file /builds/worker/checkouts/gecko/netwerk/base/nsLoadGroup.cpp, line 591
[task 2020-04-06T16:39:37.711Z] 16:39:37     INFO - GECKO(1225) | Assertion failure: testGroup == toJoin, at /builds/worker/checkouts/gecko/dom/base/nsGlobalWindowOuter.cpp:7639
[task 2020-04-06T16:40:02.081Z] 16:40:02     INFO - GECKO(1225) | #01: nsGlobalWindowInner::MaybeTabGroupInner() [dom/base/nsGlobalWindowInner.cpp:7091]
[task 2020-04-06T16:40:02.082Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.082Z] 16:40:02     INFO - GECKO(1225) | #02: nsGlobalWindowInner::TabGroupInner() [dom/base/nsGlobalWindowInner.cpp:7119]
[task 2020-04-06T16:40:02.082Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.082Z] 16:40:02     INFO - GECKO(1225) | #03: mozilla::dom::Document::SetScopeObject(nsIGlobalObject*) [dom/base/Document.cpp:6811]
[task 2020-04-06T16:40:02.083Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.083Z] 16:40:02     INFO - GECKO(1225) | #04: mozilla::dom::Document::SetScriptGlobalObject(nsIScriptGlobalObject*) [dom/base/Document.cpp:6997]
[task 2020-04-06T16:40:02.084Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.084Z] 16:40:02     INFO - GECKO(1225) | #05: nsGlobalWindowOuter::SetNewDocument(mozilla::dom::Document*, nsISupports*, bool, mozilla::dom::WindowGlobalChild*) [dom/base/nsGlobalWindowOuter.cpp:2379]
[task 2020-04-06T16:40:02.084Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.084Z] 16:40:02     INFO - GECKO(1225) | #06: nsDocumentViewer::InitInternal(nsIWidget*, nsISupports*, mozilla::dom::WindowGlobalChild*, mozilla::gfx::IntRectTyped<mozilla::gfx::UnknownUnits> const&, bool, bool, bool) [layout/base/nsDocumentViewer.cpp:973]
[task 2020-04-06T16:40:02.084Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.084Z] 16:40:02     INFO - GECKO(1225) | #07: nsDocumentViewer::Init(nsIWidget*, mozilla::gfx::IntRectTyped<mozilla::gfx::UnknownUnits> const&, mozilla::dom::WindowGlobalChild*) [layout/base/nsDocumentViewer.cpp:762]
[task 2020-04-06T16:40:02.084Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.084Z] 16:40:02     INFO - GECKO(1225) | #08: nsDocShell::SetupNewViewer(nsIContentViewer*, mozilla::dom::WindowGlobalChild*) [docshell/base/nsDocShell.cpp:7922]
[task 2020-04-06T16:40:02.084Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.084Z] 16:40:02     INFO - GECKO(1225) | #09: nsDocShell::Embed(nsIContentViewer*, mozilla::dom::WindowGlobalChild*) [docshell/base/nsDocShell.cpp:5650]
[task 2020-04-06T16:40:02.084Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.085Z] 16:40:02     INFO - GECKO(1225) | [Child 1691, Main Thread] WARNING: NS_ENSURE_TRUE(request) failed: file /builds/worker/checkouts/gecko/netwerk/base/nsLoadGroup.cpp, line 591
[task 2020-04-06T16:40:02.085Z] 16:40:02     INFO - GECKO(1225) | #10: nsDocShell::CreateAboutBlankContentViewer(nsIPrincipal*, nsIPrincipal*, nsIContentSecurityPolicy*, nsIURI*, bool, bool, mozilla::dom::WindowGlobalChild*) [docshell/base/nsDocShell.cpp:6517]
[task 2020-04-06T16:40:02.086Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.087Z] 16:40:02     INFO - GECKO(1225) | #11: nsDocShell::CreateContentViewerForActor(mozilla::dom::WindowGlobalChild*) [docshell/base/nsDocShell.cpp:6551]
[task 2020-04-06T16:40:02.087Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.087Z] 16:40:02     INFO - GECKO(1225) | #12: nsWebBrowser::Create(nsIWebBrowserChrome*, nsIWidget*, mozilla::OriginAttributes const&, mozilla::dom::BrowsingContext*, mozilla::dom::WindowGlobalChild*, bool) [toolkit/components/browser/nsWebBrowser.cpp:189]
[task 2020-04-06T16:40:02.088Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.089Z] 16:40:02     INFO - GECKO(1225) | #13: mozilla::dom::BrowserChild::Init(mozIDOMWindowProxy*, mozilla::dom::WindowGlobalChild*) [dom/ipc/BrowserChild.cpp:501]
[task 2020-04-06T16:40:02.089Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.090Z] 16:40:02     INFO - GECKO(1225) | #14: mozilla::dom::ContentChild::RecvConstructBrowser(mozilla::ipc::ManagedEndpoint<mozilla::dom::PBrowserChild>&&, mozilla::ipc::ManagedEndpoint<mozilla::dom::PWindowGlobalChild>&&, mozilla::dom::IdType<mozilla::dom::BrowserParent> const&, mozilla::dom::IdType<mozilla::dom::BrowserParent> const&, mozilla::dom::IPCTabContext const&, mozilla::dom::WindowGlobalInit const&, unsigned int const&, mozilla::dom::IdType<mozilla::dom::ContentParent> const&, bool const&, bool const&) [dom/ipc/ContentChild.cpp:1820]
[task 2020-04-06T16:40:02.090Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.091Z] 16:40:02     INFO - GECKO(1225) | #15: mozilla::dom::PContentChild::OnMessageReceived(IPC::Message const&) [s3:gecko-generated-sources:2def71d8893a591779ec71a168aace95fafac7e71f57aff3cfd7ad63fc90abf5191c84ca7be0377fc0a252aae91c364a87412b07dfe74df998929eec2254429d/ipc/ipdl/PContentChild.cpp::8482]
[task 2020-04-06T16:40:02.091Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.092Z] 16:40:02     INFO - GECKO(1225) | #16: mozilla::ipc::MessageChannel::DispatchAsyncMessage(mozilla::ipc::ActorLifecycleProxy*, IPC::Message const&) [ipc/glue/MessageChannel.cpp:2188]
[task 2020-04-06T16:40:02.093Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.093Z] 16:40:02     INFO - GECKO(1225) | #17: mozilla::ipc::MessageChannel::DispatchMessage(IPC::Message&&) [ipc/glue/MessageChannel.cpp:2114]
[task 2020-04-06T16:40:02.094Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.094Z] 16:40:02     INFO - GECKO(1225) | #18: mozilla::ipc::MessageChannel::RunMessage(mozilla::ipc::MessageChannel::MessageTask&) [ipc/glue/MessageChannel.cpp:0]
[task 2020-04-06T16:40:02.095Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.096Z] 16:40:02     INFO - GECKO(1225) | #19: mozilla::ipc::MessageChannel::MessageTask::Run() [ipc/glue/MessageChannel.cpp:1992]
[task 2020-04-06T16:40:02.096Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.097Z] 16:40:02     INFO - GECKO(1225) | #20: mozilla::SchedulerGroup::Runnable::Run() [xpcom/threads/SchedulerGroup.cpp:282]
[task 2020-04-06T16:40:02.097Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.098Z] 16:40:02     INFO - GECKO(1225) | #21: nsThread::ProcessNextEvent(bool, bool*) [xpcom/threads/nsThread.cpp:1220]
[task 2020-04-06T16:40:02.098Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.099Z] 16:40:02     INFO - GECKO(1225) | #22: NS_ProcessNextEvent(nsIThread*, bool) [xpcom/threads/nsThreadUtils.cpp:481]
[task 2020-04-06T16:40:02.100Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.100Z] 16:40:02     INFO - GECKO(1225) | #23: mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) [ipc/glue/MessagePump.cpp:0]
[task 2020-04-06T16:40:02.101Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.101Z] 16:40:02     INFO - GECKO(1225) | #24: MessageLoop::RunInternal() [ipc/chromium/src/base/message_loop.cc:315]
[task 2020-04-06T16:40:02.102Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.103Z] 16:40:02     INFO - GECKO(1225) | #25: MessageLoop::Run() [ipc/chromium/src/base/message_loop.cc:291]
[task 2020-04-06T16:40:02.103Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.104Z] 16:40:02     INFO - GECKO(1225) | #26: nsBaseAppShell::Run() [widget/nsBaseAppShell.cpp:139]
[task 2020-04-06T16:40:02.104Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.105Z] 16:40:02     INFO - GECKO(1225) | #27: XRE_RunAppShell() [toolkit/xre/nsEmbedFunctions.cpp:909]
[task 2020-04-06T16:40:02.105Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.106Z] 16:40:02     INFO - GECKO(1225) | #28: mozilla::ipc::MessagePumpForChildProcess::Run(base::MessagePump::Delegate*) [ipc/glue/MessagePump.cpp:237]
[task 2020-04-06T16:40:02.107Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.107Z] 16:40:02     INFO - GECKO(1225) | #29: MessageLoop::RunInternal() [ipc/chromium/src/base/message_loop.cc:315]
[task 2020-04-06T16:40:02.108Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.108Z] 16:40:02     INFO - GECKO(1225) | #30: MessageLoop::Run() [ipc/chromium/src/base/message_loop.cc:291]
[task 2020-04-06T16:40:02.109Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.109Z] 16:40:02     INFO - GECKO(1225) | #31: XRE_InitChildProcess(int, char**, XREChildData const*) [toolkit/xre/nsEmbedFunctions.cpp:740]
[task 2020-04-06T16:40:02.110Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.300Z] 16:40:02     INFO - GECKO(1225) | #32: content_process_main(mozilla::Bootstrap*, int, char**) [ipc/contentproc/plugin-container.cpp:57]
[task 2020-04-06T16:40:02.302Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.303Z] 16:40:02     INFO - GECKO(1225) | #33: main [browser/app/nsBrowserApp.cpp:303]
[task 2020-04-06T16:40:02.304Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.305Z] 16:40:02     INFO - GECKO(1225) | #34: libc.so.6 + 0x21b97
[task 2020-04-06T16:40:02.306Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.307Z] 16:40:02     INFO - GECKO(1225) | #35: _start
[task 2020-04-06T16:40:02.308Z] 16:40:02     INFO - 
[task 2020-04-06T16:40:02.308Z] 16:40:02     INFO - GECKO(1225) | [Child 1691, Main Thread] WARNING: NS_ENSURE_TRUE(request) failed: file /builds/worker/checkouts/gecko/netwerk/base/nsLoadGroup.cpp, line 591
[task 2020-04-06T16:40:02.309Z] 16:40:02     INFO - GECKO(1225) | [Child 1691, Main Thread] WARNING: '!topWindow', file /builds/worker/checkouts/gecko/dom/html/HTMLIFrameElement.cpp, line 246
[task 2020-04-06T16:40:02.309Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.309Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.309Z] 16:40:02     INFO - GECKO(1225) | [Child 1691, Main Thread] WARNING: '!topWindow', file /builds/worker/checkouts/gecko/dom/html/HTMLIFrameElement.cpp, line 246
[task 2020-04-06T16:40:02.310Z] 16:40:02     INFO - GECKO(1225) | [Child 1691, Main Thread] WARNING: NS_ENSURE_TRUE(request) failed: file /builds/worker/checkouts/gecko/netwerk/base/nsLoadGroup.cpp, line 591
[task 2020-04-06T16:40:02.313Z] 16:40:02     INFO - GECKO(1225) | [Child 1691, Main Thread] WARNING: NS_ENSURE_TRUE(request) failed: file /builds/worker/checkouts/gecko/netwerk/base/nsLoadGroup.cpp, line 591
[task 2020-04-06T16:40:02.313Z] 16:40:02    ERROR - GECKO(1225) | A content process crashed and MOZ_CRASHREPORTER_SHUTDOWN is set, shutting down
[task 2020-04-06T16:40:02.313Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/workspace/obj-build/dist/include/mozilla/ipc/ProtocolUtils.h, line 294
[task 2020-04-06T16:40:02.313Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.313Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.314Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.315Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.316Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.316Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.317Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.317Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.318Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.319Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.319Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.320Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.320Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/workspace/obj-build/dist/include/mozilla/ipc/ProtocolUtils.h, line 294
[task 2020-04-06T16:40:02.321Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.321Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.322Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.323Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.323Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.324Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.324Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.324Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.327Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.329Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.329Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.330Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.330Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.331Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.331Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.331Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/workspace/obj-build/dist/include/mozilla/ipc/ProtocolUtils.h, line 294
[task 2020-04-06T16:40:02.332Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/checkouts/gecko/ipc/glue/ProtocolUtils.cpp, line 476
[task 2020-04-06T16:40:02.332Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/workspace/obj-build/dist/include/mozilla/ipc/ProtocolUtils.h, line 294
[task 2020-04-06T16:40:02.332Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/workspace/obj-build/dist/include/mozilla/ipc/ProtocolUtils.h, line 294
[task 2020-04-06T16:40:02.333Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/workspace/obj-build/dist/include/mozilla/ipc/ProtocolUtils.h, line 294
[task 2020-04-06T16:40:02.333Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/workspace/obj-build/dist/include/mozilla/ipc/ProtocolUtils.h, line 294
[task 2020-04-06T16:40:02.333Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/workspace/obj-build/dist/include/mozilla/ipc/ProtocolUtils.h, line 294
[task 2020-04-06T16:40:02.334Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/workspace/obj-build/dist/include/mozilla/ipc/ProtocolUtils.h, line 294
[task 2020-04-06T16:40:02.334Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/workspace/obj-build/dist/include/mozilla/ipc/ProtocolUtils.h, line 294
[task 2020-04-06T16:40:02.335Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/workspace/obj-build/dist/include/mozilla/ipc/ProtocolUtils.h, line 294
[task 2020-04-06T16:40:02.335Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: IPC message discarded: actor cannot send: file /builds/worker/workspace/obj-build/dist/include/mozilla/ipc/ProtocolUtils.h, line 294
[task 2020-04-06T16:40:02.335Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: '!inner', file /builds/worker/checkouts/gecko/dom/ipc/JSWindowActorService.cpp, line 188
[task 2020-04-06T16:40:02.336Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: '!inner', file /builds/worker/checkouts/gecko/dom/ipc/JSWindowActorService.cpp, line 188
[task 2020-04-06T16:40:02.337Z] 16:40:02     INFO - GECKO(1225) | [GPU 1264, Compositor] WARNING: Possibly dropping task posted to updater thread: file /builds/worker/checkouts/gecko/gfx/layers/apz/src/APZUpdater.cpp, line 371
[task 2020-04-06T16:40:02.338Z] 16:40:02     INFO - GECKO(1225) | [2020-04-06T16:39:39Z WARN  xulstore::persist] tried to remove key that isn't in the store
[task 2020-04-06T16:40:02.338Z] 16:40:02     INFO - GECKO(1225) | [2020-04-06T16:39:39Z WARN  xulstore::persist] tried to remove key that isn't in the store
[task 2020-04-06T16:40:02.341Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80040111: file /builds/worker/checkouts/gecko/netwerk/cache/nsCacheService.cpp, line 853
[task 2020-04-06T16:40:02.342Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80040111: file /builds/worker/checkouts/gecko/netwerk/cache/nsCacheService.cpp, line 816
[task 2020-04-06T16:40:02.342Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80040111: file /builds/worker/checkouts/gecko/netwerk/cache/nsApplicationCacheService.cpp, line 161
[task 2020-04-06T16:40:02.343Z] 16:40:02     INFO - GECKO(1225) | [Child 1691, Main Thread] WARNING: Extra shutdown CC: 'i < NORMAL_SHUTDOWN_COLLECTIONS', file /builds/worker/checkouts/gecko/xpcom/base/nsCycleCollector.cpp, line 3352
[task 2020-04-06T16:40:02.343Z] 16:40:02     INFO - GECKO(1225) | nsStringStats
[task 2020-04-06T16:40:02.344Z] 16:40:02     INFO - GECKO(1225) |  => mAllocCount:          11253
[task 2020-04-06T16:40:02.344Z] 16:40:02     INFO - GECKO(1225) |  => mReallocCount:            0
[task 2020-04-06T16:40:02.345Z] 16:40:02     INFO - GECKO(1225) |  => mFreeCount:           11253
[task 2020-04-06T16:40:02.345Z] 16:40:02     INFO - GECKO(1225) |  => mShareCount:          11211
[task 2020-04-06T16:40:02.346Z] 16:40:02     INFO - GECKO(1225) |  => mAdoptCount:            267
[task 2020-04-06T16:40:02.346Z] 16:40:02     INFO - GECKO(1225) |  => mAdoptFreeCount:        303
[task 2020-04-06T16:40:02.347Z] 16:40:02     INFO - GECKO(1225) |  => Process ID: 1691, Thread ID: 140401383192448
[task 2020-04-06T16:40:02.347Z] 16:40:02     INFO - GECKO(1225) | [Child 1308, Main Thread] WARNING: Extra shutdown CC: 'i < NORMAL_SHUTDOWN_COLLECTIONS', file /builds/worker/checkouts/gecko/xpcom/base/nsCycleCollector.cpp, line 3352
[task 2020-04-06T16:40:02.348Z] 16:40:02     INFO - GECKO(1225) | nsStringStats
[task 2020-04-06T16:40:02.348Z] 16:40:02     INFO - GECKO(1225) |  => mAllocCount:          25252
[task 2020-04-06T16:40:02.349Z] 16:40:02     INFO - GECKO(1225) |  => mReallocCount:            0
[task 2020-04-06T16:40:02.349Z] 16:40:02     INFO - GECKO(1225) |  => mFreeCount:           25252
[task 2020-04-06T16:40:02.350Z] 16:40:02     INFO - GECKO(1225) |  => mShareCount:          12474
[task 2020-04-06T16:40:02.350Z] 16:40:02     INFO - GECKO(1225) |  => mAdoptCount:            449
[task 2020-04-06T16:40:02.352Z] 16:40:02     INFO - GECKO(1225) |  => mAdoptFreeCount:        481
[task 2020-04-06T16:40:02.353Z] 16:40:02     INFO - GECKO(1225) |  => Process ID: 1308, Thread ID: 139890846168960
[task 2020-04-06T16:40:02.353Z] 16:40:02     INFO - GECKO(1225) | nsStringStats
[task 2020-04-06T16:40:02.354Z] 16:40:02     INFO - GECKO(1225) |  => mAllocCount:           8608
[task 2020-04-06T16:40:02.357Z] 16:40:02     INFO - GECKO(1225) |  => mReallocCount:            0
[task 2020-04-06T16:40:02.358Z] 16:40:02     INFO - GECKO(1225) |  => mFreeCount:            8608
[task 2020-04-06T16:40:02.358Z] 16:40:02     INFO - GECKO(1225) |  => mShareCount:           4384
[task 2020-04-06T16:40:02.359Z] 16:40:02     INFO - GECKO(1225) |  => mAdoptCount:             74
[task 2020-04-06T16:40:02.360Z] 16:40:02     INFO - GECKO(1225) |  => mAdoptFreeCount:         74
[task 2020-04-06T16:40:02.360Z] 16:40:02     INFO - GECKO(1225) |  => Process ID: 1394, Thread ID: 139671677347712
[task 2020-04-06T16:40:02.360Z] 16:40:02     INFO - GECKO(1225) | [Child 1421, Main Thread] WARNING: Extra shutdown CC: 'i < NORMAL_SHUTDOWN_COLLECTIONS', file /builds/worker/checkouts/gecko/xpcom/base/nsCycleCollector.cpp, line 3352
[task 2020-04-06T16:40:02.360Z] 16:40:02     INFO - GECKO(1225) | nsStringStats
[task 2020-04-06T16:40:02.360Z] 16:40:02     INFO - GECKO(1225) |  => mAllocCount:          13413
[task 2020-04-06T16:40:02.361Z] 16:40:02     INFO - GECKO(1225) |  => mReallocCount:            0
[task 2020-04-06T16:40:02.361Z] 16:40:02     INFO - GECKO(1225) |  => mFreeCount:           13413
[task 2020-04-06T16:40:02.361Z] 16:40:02     INFO - GECKO(1225) |  => mShareCount:          14773
[task 2020-04-06T16:40:02.361Z] 16:40:02     INFO - GECKO(1225) |  => mAdoptCount:            610
[task 2020-04-06T16:40:02.362Z] 16:40:02     INFO - GECKO(1225) |  => mAdoptFreeCount:        614
[task 2020-04-06T16:40:02.363Z] 16:40:02     INFO - GECKO(1225) |  => Process ID: 1421, Thread ID: 139802829207424
[task 2020-04-06T16:40:02.363Z] 16:40:02     INFO - GECKO(1225) | 1586191182361	Marionette	TRACE	Received observer notification xpcom-will-shutdown
[task 2020-04-06T16:40:02.365Z] 16:40:02     INFO - GECKO(1225) | 1586191182361	Marionette	INFO	Stopped listening on port 2828
[task 2020-04-06T16:40:02.367Z] 16:40:02     INFO - GECKO(1225) | 1586191182362	Marionette	DEBUG	Marionette stopped listening
[task 2020-04-06T16:40:02.367Z] 16:40:02     INFO - GECKO(1225) | nsStringStats
[task 2020-04-06T16:40:02.367Z] 16:40:02     INFO - GECKO(1225) |  => mAllocCount:           6131
[task 2020-04-06T16:40:02.368Z] 16:40:02     INFO - GECKO(1225) |  => mReallocCount:            0
[task 2020-04-06T16:40:02.369Z] 16:40:02     INFO - GECKO(1225) |  => mFreeCount:            6131
[task 2020-04-06T16:40:02.369Z] 16:40:02     INFO - GECKO(1225) |  => mShareCount:           6259
[task 2020-04-06T16:40:02.369Z] 16:40:02     INFO - GECKO(1225) |  => mAdoptCount:              0
[task 2020-04-06T16:40:02.370Z] 16:40:02     INFO - GECKO(1225) |  => mAdoptFreeCount:          0
[task 2020-04-06T16:40:02.370Z] 16:40:02     INFO - GECKO(1225) |  => Process ID: 1264, Thread ID: 139781047400320
[task 2020-04-06T16:40:02.370Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file /builds/worker/checkouts/gecko/js/xpconnect/loader/mozJSComponentLoader.cpp, line 228
[task 2020-04-06T16:40:02.371Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file /builds/worker/checkouts/gecko/js/xpconnect/loader/mozJSComponentLoader.cpp, line 255
[task 2020-04-06T16:40:02.371Z] 16:40:02     INFO - GECKO(1225) | [Parent 1225, Main Thread] WARNING: Extra shutdown CC: 'i < NORMAL_SHUTDOWN_COLLECTIONS', file /builds/worker/checkouts/gecko/xpcom/base/nsCycleCollector.cpp, line 3352
[task 2020-04-06T16:40:02.371Z] 16:40:02     INFO - GECKO(1225) | nsStringStats
[task 2020-04-06T16:40:02.372Z] 16:40:02     INFO - GECKO(1225) |  => mAllocCount:         323492
[task 2020-04-06T16:40:02.372Z] 16:40:02     INFO - GECKO(1225) |  => mReallocCount:            0
[task 2020-04-06T16:40:02.372Z] 16:40:02     INFO - GECKO(1225) |  => mFreeCount:          323492
[task 2020-04-06T16:40:02.373Z] 16:40:02     INFO - GECKO(1225) |  => mShareCount:         392517
[task 2020-04-06T16:40:02.374Z] 16:40:02     INFO - GECKO(1225) |  => mAdoptCount:           5439
[task 2020-04-06T16:40:02.375Z] 16:40:02     INFO - GECKO(1225) |  => mAdoptFreeCount:       6787
[task 2020-04-06T16:40:02.375Z] 16:40:02     INFO - GECKO(1225) |  => Process ID: 1225, Thread ID: 140238947030912
[task 2020-04-06T16:40:02.376Z] 16:40:02     INFO - TEST-INFO | Main app process: exit 0 ```
Flags: needinfo?(nika)

These assertions should be fixed now that bug 1620594 has landed, so re-landing.

Flags: needinfo?(nika)
Pushed by nlayzell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c0c291c63aad
Part 1: Remove unused aIsPreallocated flag from NotifyTabContextUpdated, r=kmag
https://hg.mozilla.org/integration/autoland/rev/21902d8957de
Part 2: Remove the isPrivate flag from ParentShowInfo, r=kmag
https://hg.mozilla.org/integration/autoland/rev/9bae7eb4e34a
Part 3: Use an attribute to set geckoViewUserContextId on a browser, r=geckoview-reviewers,esawin
https://hg.mozilla.org/integration/autoland/rev/f144394b822c
Part 4: Don't second-guess CHROME_{REMOTE,FISSION}_WINDOW flags, r=kmag
https://hg.mozilla.org/integration/autoland/rev/61695e8e03ee
Part 5: Always set the opener for chrome windows late, r=kmag
https://hg.mozilla.org/integration/autoland/rev/43300434daa0
Part 6.1: Implement nsILoadContext on BrowsingContext, r=smaug
https://hg.mozilla.org/integration/autoland/rev/c8c7d1ab9fb4
Part 6.2: Remove setOriginAttributesBeforeLoading API, r=smaug
https://hg.mozilla.org/integration/autoland/rev/50aa16aa36fb
Part 6.3: Replace many nsILoadContext mutators with assertions, r=smaug
https://hg.mozilla.org/integration/autoland/rev/4da3f25efcda
Part 6.4: Delay loading chrome window URIs until docshell has been configured, r=smaug
https://hg.mozilla.org/integration/autoland/rev/2c2f09f7e3a4
Part 6.5: Assert nsILoadContext attributes are correctly set when opening windows, r=smaug
https://hg.mozilla.org/integration/autoland/rev/7ccbbb127b7f
Part 7.1: Introduce a new nsOpenWindowInfo type, r=Gijs,kmag
https://hg.mozilla.org/integration/autoland/rev/fde2d124a1b1
Part 7.2: Create and use nsOpenWindowInfo types in nsWindowWatcher logic, r=kmag
https://hg.mozilla.org/integration/autoland/rev/59b467bcd836
Part 7.3: Use nsOpenWindowInfo for initializing xul:browser elements, r=kmag
https://hg.mozilla.org/integration/autoland/rev/f3e16dc2311d
Part 7.4: Pass nsOpenWindowInfo through tabbrowser, r=Gijs
https://hg.mozilla.org/integration/autoland/rev/80293d85c3b6
Part 7.5: Pass nsOpenWindowInfo through Geckoview, r=geckoview-reviewers,esawin,agi
https://hg.mozilla.org/integration/autoland/rev/39efd9c5c22a
Part 7.6: Pass nsOpenWindowInfo through the single-site browser, r=Gijs
https://hg.mozilla.org/integration/autoland/rev/fbc669bbf02f
Part 7.7: Remove window initialization properties which are redundant with nsOpenWindowInfo, r=kmag
https://hg.mozilla.org/integration/autoland/rev/2203b9e3146e
Part 8: Remove forceInitialBrowserNonRemote, r=Gijs
https://hg.mozilla.org/integration/autoland/rev/80a41538bf94
Part 9: Ensure the correct OriginAttributes are set on opened TabContext, r=kmag
https://hg.mozilla.org/integration/autoland/rev/d974c814ab4d
Part 10.1: Remove special handling of window.open in mozbrowser, r=kmag
https://hg.mozilla.org/integration/autoland/rev/b61e7793d30a
Part 10.2: Remove tests for window.open in mozbrowser, r=kmag
https://hg.mozilla.org/integration/autoland/rev/201104c9d192
Part 12: Remove or fix tests which try to set OriginAttributes too late, r=kmag
https://hg.mozilla.org/integration/autoland/rev/f3001bff2377
Part 13: Don't create an extra BrowsingContext when opening a new tab from content, r=kmag
Attachment #9133967 - Attachment is obsolete: true
Regressions: 1629176
Regressions: 1629181

Looks like this caused wpt failures like TEST-UNEXPECTED-TIMEOUT | /screen-capture/getdisplaymedia.https.html | getDisplayMedia() <something>
Backing it out and then pushing to try caused the wpt4 jobs to be successful:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=e25efd13710baa96618347ec6e5b83c594a3040e&selectedJob=297310292

Here's an example: https://treeherder.mozilla.org/#/jobs?repo=autoland&searchStr=wpt4&revision=f09ef9c6f56ab0addf33e1de2edf028d97bd2e4a&selectedJob=297271748

Flags: needinfo?(nika)

The apparently-related intermittent bug 1601077 does seem to have spiked recently, but I have absolutely no idea how a timeout here could be related to these changes.
From a quick scan, it appears to be mostly failing on macOS, which is interesting, as getDisplayMedia seems like it'd have OS interaction.

:jesup, any chance you'd know what could be going on here?

Flags: needinfo?(nika) → needinfo?(rjesup)

Seems odd, though perhaps there's a (new-ish??) race in the code that this happens to make more common or permafail (witness bug 1601077 having popped up in the last few weeks).

jib?

Flags: needinfo?(rjesup) → needinfo?(jib)

failing on macOS, which is interesting, as getDisplayMedia seems like it'd have OS interaction.

It was only for Catalina (10.15) that we added an extra getDisplaymedia-specific OS permission check some months ago. It can be disabled by setting media.macos.screenrecording.oscheck.enabled to false, but I think all our tests already run with media.navigator.permission.disabled which should mean that whole permission code wouldn't even run (should be bypassed) AFAIK. That is: getDisplayMedia() in tests works without a prompt, always returning entire desktop (useful for some output-verifying tests).

Also the test machines failing here appear to be 10.14, not 10.15, plus I also see occasional linux timeouts there, so I don't think that can be it. cc'ing Haik who worked on it to be sure.

I don't know of any recent changes in that media code.

Flags: needinfo?(haftandilian)

Clearing ni? in case you want to ask me something else.

Flags: needinfo?(jib)
Blocks: 1624155

(In reply to Jan-Ivar Bruaroey [:jib] (needinfo? me) from comment #36)

Also the test machines failing here appear to be 10.14, not 10.15, plus I also see occasional linux timeouts there, so I don't think that can be it. cc'ing Haik who worked on it to be sure.

That's right. The recent work done on bug 1580900 that added calls to nsIOSPermissionRequest.getScreenCapturePermissionState() from JS into platform code should have had a very minimal effect on timing on CI. When not running on 10.15+, the new code essentially returns NS_OK/allowed without doing any checks. The Macs used for testing on CI run 10.14. So when not on 10.15+, we make an additional call into platform code, but it doesn't do any work.

Flags: needinfo?(haftandilian)
Duplicate of this bug: 1609798
Regressions: 1653530
No longer regressions: 1653530
Regressions: 1638793
You need to log in before you can comment on or make changes to this bug.