microsoft.com - msdn does not send http://msdn.microsoft.com/404/default.asp as a 404

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
17 years ago
4 years ago

People

(Reporter: timeless, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
... something tells me we did the wrong thing here.
nop - he has a <base href="somewhere as MSDN">

Comment 2

17 years ago
Wrong in the way it displays in the JS Console?
If not maybe the site is showing the stylesheet of MIME type text/html
(Reporter)

Comment 3

17 years ago
bah. I hate having to explain myself. ok, here's what's happening:
mozilla 2002080508 w32
There's a page on msdn which references a style sheet.
Google sent me something like a copy of that msdn page.
Mozilla tried to resolve the stylesheet, it managed to present a url to the msdn
webserver which triggered a 404.  MSDN responded with a 404 html error.
Mozilla ignored that it was an error page (and that it was text/html) and
decided that the author obviously wanted the 404 text/html error page to be used
as a style sheet (text/html). Mozilla warns me that it's doing something stupid.
I filed a bug.

Comment 4

17 years ago
I'll rephrase, cos I'm a dumbass and that last comment took me far too long to 
understand.

In quirks mode, Mozilla does not require that stylesheets are served as 
text/css.  In strict mode, a non-text/css stylesheet will be ignored.

The warning is letting you know that the stylesheet will be loaded even though 
it is the 'wrong' MIME type.

However, the stylesheet is the HTML result of a 404 error page - the stylesheet 
doesn't exist.  We shouldn't issue an error or attempt to parse the stylesheet 
if the stylesheet wasn't found.  (Note: I don't know if we *do* try to parse 
the HTML page as a stylesheet, but we certainly issue an error).

Is that right?
(Reporter)

Comment 5

17 years ago
yeah. and for my comment it should have said "style sheet (text/css)" it's early.
i'm pretty sure we do display it, otherwise we wouldn't bother warning, or the
warning would be worded differently (it did say "stylesheet ... was loaded").

someone might want us to load a 404 text/css stylesheet, but that's not what
happened.

Comment 7

17 years ago
Ack.  Got it.
The page that the stylesheet refers to generates a 302 Moved to 
http://msdn.microsoft.com/404/default.asp.  That page is a 200 OK, not a 404 
Not Found, and it happens to be an HTML error page.

So, resolve as INVALID or reassign to evang, because we're doing the 'right' 
thing (although Microsoft aren't, arguably).

I've checked locally, and we definitely do not load (or warn about) stylesheets 
that are delivered with a genuine 404 return.
->invalid.  See previous comment.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 9

17 years ago
i'd prefer to evangelize.
Status: RESOLVED → UNCONFIRMED
Component: Style System → US General
Product: Browser → Tech Evangelism
Resolution: INVALID → ---
Summary: Warning: The stylesheet http://msdn.microsoft.com/404/default.asp was loaded as CSS even though its MIME type, "text/html", is not "text/css". → msdn does not send http://msdn.microsoft.com/404/default.asp as a 404
Version: other → unspecified
(Reporter)

Comment 10

17 years ago
can we ask them to send out a 404 header?
Assignee: dbaron → susiew
QA Contact: ian → zach
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
Keywords: evang500

Updated

16 years ago
Blocks: 114158

Comment 11

16 years ago
tech evang june 2003 reorg
Assignee: susiew → english-us
QA Contact: zach → english-us

Updated

16 years ago
Summary: msdn does not send http://msdn.microsoft.com/404/default.asp as a 404 → microsoft.com - msdn does not send http://msdn.microsoft.com/404/default.asp as a 404
INCOMPLETE due to lack of activity since the end of 2009.

If someone is willing to investigate the issues raised in this bug to determine whether they still exist, *and* work with the site in question to fix any existing issues, please feel free to re-open and assign to yourself.

Sorry for the bugspam; filter on "NO MORE PRE-2010 TE BUGS" to remove.
Status: NEW → RESOLVED
Last Resolved: 17 years ago8 years ago
Resolution: --- → INCOMPLETE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.