Closed Bug 1616630 Opened 2 years ago Closed 2 years ago

Use py3_action for GENERATED_FILES that already work in py3

Categories

(Firefox Build System :: General, task)

task
Not set
normal

Tracking

(firefox75 fixed)

RESOLVED FIXED
mozilla75
Tracking Status
firefox75 --- fixed

People

(Reporter: mshal, Assigned: mshal)

References

Details

Attachments

(2 files)

Bug 1611326 now allows us to use py3_action for GENERATED_FILES, but didn't start to use py3 for anything. We can enable py3 for scripts that already work with it (roughly half).

Without PYTHON3 defined, we can't actually run any GENERATED_FILES
scripts in the fastermake backend.

We may get another round of easy wins after bug 1613263 sticks, too. At least generate_bookmarks.py falls into that category.

Pushed by mshal@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dcb7dc51633b
Add PYTHON3 to fastermake variables; r=firefox-build-system-reviewers,rstewart
https://hg.mozilla.org/integration/autoland/rev/15016546c954
Use py3_action for GENERATED_FILES that already support it; r=firefox-build-system-reviewers,kvark,rstewart

Backed out for Android (Bgv) bustage.

backout: https://hg.mozilla.org/integration/autoland/rev/02795141211466d3d07aacde5f8ced4073631120

push: https://treeherder.mozilla.org/#/jobs?repo=autoland&group_state=expanded&searchStr=android%2C4.0%2Capi16%2B%2Cgeckoview%2Cmulti-arch%2Cfat%2Caar%2Copt%2Cbuild-fat-aar-android-geckoview-fat-aar%2Fopt%2C%28bgv%29&revision=85a9747acb63f46067604d146a7107ff6e4fb2a2&selectedJob=289735915

failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=289735832&repo=autoland&lineNumber=1574

[task 2020-02-20T19:13:45.253Z] 19:13:45 INFO - Disallowed: Path "chrome/toolkit/featuregates/feature_definitions.json" has architecture-specific versions:
[task 2020-02-20T19:13:45.253Z] 19:13:45 INFO - arm64-v8a -> 0b5d8d7494aca26561817c691098b75913fc591e
[task 2020-02-20T19:13:45.253Z] 19:13:45 INFO - armeabi-v7a -> fcbddc7649cec509f3ca97d100e9b78420584f7a
[task 2020-02-20T19:13:45.253Z] 19:13:45 INFO - x86 -> 44ea677cd8679e0e4bfe5fb8212e2248073d4ac4
[task 2020-02-20T19:13:45.253Z] 19:13:45 INFO - x86_64 -> b0907db0ed1b1568e0e2183953f323772b0a6088
[task 2020-02-20T19:13:45.254Z] 19:13:45 INFO - Makefile:150: recipe for target 'recurse_android-fat-aar-artifact' failed
[task 2020-02-20T19:13:45.254Z] 19:13:45 ERROR - make[3]: *** [recurse_android-fat-aar-artifact] Error 1
[task 2020-02-20T19:13:45.254Z] 19:13:45 INFO - make[3]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox'
[task 2020-02-20T19:13:45.254Z] 19:13:45 INFO - /builds/worker/workspace/build/src/config/recurse.mk:32: recipe for target 'android-fat-aar-artifact' failed
[task 2020-02-20T19:13:45.254Z] 19:13:45 ERROR - make[2]: *** [android-fat-aar-artifact] Error 2
[task 2020-02-20T19:13:45.254Z] 19:13:45 INFO - /builds/worker/workspace/build/src/config/rules.mk:394: recipe for target 'default' failed
[task 2020-02-20T19:13:45.254Z] 19:13:45 ERROR - make[1]: *** [default] Error 2
[task 2020-02-20T19:13:45.254Z] 19:13:45 INFO - client.mk:125: recipe for target 'build' failed
[task 2020-02-20T19:13:45.254Z] 19:13:45 INFO - make: *** [build] Error 2
[task 2020-02-20T19:13:45.300Z] 19:13:45 INFO - 0 compiler warnings present.
[task 2020-02-20T19:13:45.364Z] 19:13:45 ERROR - Return code: 2
[task 2020-02-20T19:13:45.364Z] 19:13:45 WARNING - setting return code to 2
[task 2020-02-20T19:13:45.364Z] 19:13:45 FATAL - 'mach build -v' did not run successfully. Please check log for errors.
[task 2020-02-20T19:13:45.364Z] 19:13:45 FATAL - Running post_fatal callback...
[task 2020-02-20T19:13:45.364Z] 19:13:45 FATAL - Exiting -1

Flags: needinfo?(mshal)

It looks like py3 writes out the feature_definitions.json file in a random order, which is causing the allow check to fail. I'll leave that as py2 for now.

:nalexander, do you know if there a reason we don't want Bgv builds to run on 'try -p all'? This is the 2nd time I've hit an issue that is green everywhere except this particular build, which I didn't notice because it doesn't run on -p all.

Flags: needinfo?(mshal) → needinfo?(nalexander)
Pushed by mshal@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/38324526e578
Add PYTHON3 to fastermake variables; r=firefox-build-system-reviewers,rstewart
https://hg.mozilla.org/integration/autoland/rev/730261800398
Use py3_action for GENERATED_FILES that already support it; r=firefox-build-system-reviewers,kvark,rstewart
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla75
Regressions: 1617131

(In reply to Michael Shal [:mshal] from comment #6)

It looks like py3 writes out the feature_definitions.json file in a random order, which is causing the allow check to fail. I'll leave that as py2 for now.

:nalexander, do you know if there a reason we don't want Bgv builds to run on 'try -p all'? This is the 2nd time I've hit an issue that is green everywhere except this particular build, which I didn't notice because it doesn't run on -p all.

No. I'm sure that it was just because GV-builds were a thing built off to the side, and then became the mainline, and whatever the "include in all" flag wasn't flipped. Please flip it!

Flags: needinfo?(nalexander)
You need to log in before you can comment on or make changes to this bug.