Closed Bug 1616730 Opened 3 years ago Closed 3 years ago

[wpt-sync] Sync PR 21893 - [FlexNG] Don't let min size go negative

Categories

(Core :: Layout: Flexbox, task, P4)

task

Tracking

()

RESOLVED FIXED
mozilla75
Tracking Status
firefox75 --- fixed

People

(Reporter: mozilla.org, Unassigned)

References

()

Details

(Whiteboard: [wptsync downstream])

Sync web-platform-tests PR 21893 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/web-platform-tests/wpt/pull/21893
Details from upstream follow.

David Grogan <dgrogan@chromium.org> wrote:

[FlexNG] Don't let min size go negative

We were subtracting border_padding when it wasn't present if the item
had min-size:auto but didn't qualify for the special flex min-size:auto
behavior because, for instance, it has overflow: hidden.

This fixes the telemetry_perf_unittests failure FlexNG was hitting on
the bots, which was caused by a recorded google docs page.

Change-Id: Ia6bde490651daf63e4ca77f9525870987bb9fe5c

Reviewed-on: https://chromium-review.googlesource.com/2065626
WPT-Export-Revision: 2fe68768608c83f86126ab1cfd584337b3fb9a54

Component: web-platform-tests → Layout: Flexbox
Product: Testing → Core

CI Results

Ran 0 Firefox configurations based on mozilla-central, and Firefox, and Chrome on GitHub CI

Total 1 tests

Status Summary

Firefox

PASS: 1

Chrome

PASS: 1

Links

GitHub PR Head
GitHub PR Base

Pushed by wptsync@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4de181fb852b
[wpt PR 21893] - [FlexNG] Don't let min size go negative, a=testonly
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla75
You need to log in before you can comment on or make changes to this bug.