Preferences > Appearance > Colors horked, JS error

VERIFIED FIXED

Status

VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: glazou, Assigned: caillon)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

17 years ago
1. launch Mozilla (trunk)
2. open Preferences
3. choose Appearance > Colors
4. change radio-choice "Always use the colors..." & "Use my chosen colors..."
5. click on OK

Expected result : applies changes and closes window
Actual result : does not apply change, does not close window, outputs error on
console :

JavaScript error:
chrome://communicator/content/pref/pref-navigator.js line 141:
document.getElementById("startupPage") has no properties

Tested on Win2K and Linux RH72 with trunk (fresh pull 2002-aug-08 06:00am
pacific time)

Comment 1

17 years ago
this makes preferences unusable in the average case
Assignee: ben → caillon
Severity: critical → blocker
Keywords: smoketest

Comment 2

17 years ago
Created attachment 94490 [details] [diff] [review]
patch (first half checked in)

Comment 3

17 years ago
ben: this patch makes the pref dialog handle failures in ok/cancel handlers.
we've run into this problem before and it's really really bad for the ok and
cancel buttons not to work. -- you've been notified as per the heading of the
file, however i do intend to check this in unless you respond quickly indicating
why this is much worse than risking users locked in a pref dialog in the event
that a cancel and an ok handler throw exceptions

Comment 4

17 years ago
Comment on attachment 94490 [details] [diff] [review]
patch (first half checked in)

ok, I'll sr= the first file in that patch, but I refuse to let the 2nd one in -
if you're going to touch the file, fix the bug the right way!
Attachment #94490 - Flags: superreview+

Comment 5

17 years ago
Comment on attachment 94490 [details] [diff] [review]
patch (first half checked in)

r=FrodoB (ditto on AlecF's comment).  I don't know why the OK and Cancel
handlers would fail, but these checks aren't bad to have even if they couldn't.
:)
Attachment #94490 - Flags: review+

Comment 6

17 years ago
Comment on attachment 94490 [details] [diff] [review]
patch (first half checked in)

ok. I checked the first half in. caillon can now take some time to fix this bug
Attachment #94490 - Attachment description: patch → patch (first half checked in)
Attachment #94490 - Attachment is obsolete: true

Updated

17 years ago
Severity: blocker → normal
Keywords: smoketest

Comment 7

17 years ago
*** Bug 161733 has been marked as a duplicate of this bug. ***
Yes, silly mistake.  I thought I had handled that already but I must have
reverted patches and went a different route.  *sigh*.
Status: NEW → ASSIGNED

Comment 10

17 years ago
Comment on attachment 94517 [details] [diff] [review]
The Real Fix

sr=alecf
Attachment #94517 - Flags: superreview+

Comment 11

17 years ago
Comment on attachment 94517 [details] [diff] [review]
The Real Fix

drop 'us' from the comment for r=timeless
Attachment #94517 - Flags: review+
Checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 13

17 years ago
*** Bug 161785 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
*** Bug 161835 has been marked as a duplicate of this bug. ***

Comment 15

17 years ago
*** Bug 161875 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
*** Bug 161905 has been marked as a duplicate of this bug. ***

Comment 17

17 years ago
*** Bug 161933 has been marked as a duplicate of this bug. ***
btw, this also appears to fix a long standing rfe whereby the current page data
is now saved before any of the ok handlers are called, allowing the ok handlers
to read the page data without worrying whether the page is current or not, in
which case can someone please confirm that in my rfe to remind me to update the
patch.
vrfy'd fixed using 2002.09.16.08 comm trunk builds.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.