Closed Bug 1616793 Opened 2 years ago Closed 2 years ago

Stop hiding top sites if they are disabled in the new tab page

Categories

(Firefox :: Address Bar, defect, P1)

defect
Points:
1

Tracking

()

VERIFIED FIXED
Firefox 75
Iteration:
75.1 - Feb 10 - Feb 23
Tracking Status
firefox-esr68 --- unaffected
firefox73 --- unaffected
firefox74 --- verified
firefox75 --- verified

People

(Reporter: mak, Assigned: dao)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Our initial assumption in bug 1608359 was wrong, users hide Top Sites in the New Tab Page for the most various reasons among which starting with a clean slate or the remove-bloat placebo effect.
Those same users are now surprised that we removed the top sites list from the urlbar, and the connection between the two features is totally hidden and undiscoverable.

Type: task → defect
Points: --- → 1
No longer depends on: 1608359
Keywords: regression
Regressed by: 1608359
See Also: → 1616820
Points: 1 → 2
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Points: 2 → 1
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9df342c9d05d
Stop hiding top sites if they are disabled in the new tab page. r=mak
Iteration: --- → 75.1 - Feb 10 - Feb 23
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 75

Dao, should we uplift that to beta given that this is a P1?

Flags: needinfo?(dao+bmo)

Comment on attachment 9127816 [details]
Bug 1616793 - Stop hiding top sites if they are disabled in the new tab page. r=mak

Beta/Release Uplift Approval Request

  • User impact if declined: Address bar wouldn't automatically show top sites to users who removed top sites from the new tab page
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Remove top sites from the new tab page, then check that they're still offered when focusing the address bar
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Trivial code removal
  • String changes made/needed:
Flags: needinfo?(dao+bmo)
Attachment #9127816 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9127816 [details]
Bug 1616793 - Stop hiding top sites if they are disabled in the new tab page. r=mak

P1 for a potential upcoming feature, uplift approved for 74.0b7, thanks.

Attachment #9127816 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Hi, not sure if I understand this report correctly. But the fix here should be, if I hide Top Sites on the NTP, then still show me them always in the URL Bar when I click into it, right? This works until I quit and relaunch Nightly :(

Duplicate of this bug: 1616726
Blocks: 1617345

(In reply to Mehmet from comment #8)

Hi, not sure if I understand this report correctly. But the fix here should be, if I hide Top Sites on the NTP, then still show me them always in the URL Bar when I click into it, right? This works until I quit and relaunch Nightly :(

Thanks for mentioning this. That's a bug and isn't intended. I filed bug 1617345 for it.

(In reply to Drew Willcoxon :adw from comment #10)

Thanks for mentioning this. That's a bug and isn't intended. I filed bug 1617345 for it.

Thanks for filing the report.

QA Whiteboard: [qa-triaged]

Hello, the fix seems to be present, the following behavior occurs:

Steps:

  1. Disable Top sites
  2. Open a new tab
  3. Focus the Address Bar

Actual: the top sites are listed in the drop-down.

HOWEVER, as Mehmet mentioned in Comment 8, this behavior only lasts until the browser is restarted.
I would classify this as a partial fix, and until bug 1617345 is fixed, we should delay the uplift.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

In the latest 74 beta update, I can't get the urlbar topsites dropdown to work even though I do have top sites enabled on the new tab page.

When I click the addressbar no dropdown is shown

(In reply to Daniel Kolsis from comment #12)

HOWEVER, as Mehmet mentioned in Comment 8, this behavior only lasts until the browser is restarted.
I would classify this as a partial fix, and until bug 1617345 is fixed, we should delay the uplift.

It's already uplifted. We'll just track the remaining issue in bug 1617345.

Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED

Confirmed the issue using Firefox 75.0a1 2020-02-20-09-35-08 on Windows 10.
Verified with 74.0b7 and 75.0a1 2020-02-24-16-27-17 Windows 10, macOS 10.13, Ubuntu 19.

  • Additional note: On Ubuntu 19 with latest Nightly the address bar hides the top sites only after a browser restart.

Awesome!
Updating the bug status as well.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

As Brandon mentioned in Comment 13, even after the bug 1617345 was uplifted to beta, the address bar dropdown is not displayed, regardless if the Top Sites pref is set on or off. I can't seem to find the root cause on my own, could you please investigate this?
Note: There seems to be no issue on the latest Nightly, both this issue and bug 1617345 are verified.

Status: VERIFIED → REOPENED
Flags: needinfo?(dao+bmo)
Resolution: FIXED → ---

Please, stop reopening bugs, that only complicates our tracking of issues, file new bugs when things are broken, and mark the previous bugs as dependencies.

Did you set browser.urlbar.openViewOnFocus? Which other prefs did you set? Can you please file a new bug so we can discuss there and keep things cleaner?

Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Flags: needinfo?(dao+bmo) → needinfo?(daniel.kolsis)
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED

I've set browser.urlbar.openViewOnFocus to true and everything seems to be alright now. Will this pref be set to true by default? At this point it set to false, even though on Nightly its default is true.

Flags: needinfo?(daniel.kolsis)

yes, that preference is part of the feature.
The feature is disabled in late Beta because we want to ship it in Firefox 75, it was only enabled in early Beta.

You need to log in before you can comment on or make changes to this bug.