Closed Bug 1617111 Opened 2 years ago Closed 2 years ago

2.46 - 5.14% raptor-motionmark-animometer-firefox (linux64-shippable-qr, windows10-64-shippable-qr) regression on push 95fe1470b3718d04e5c45605faedda62da140071 (Tue February 18 2020)

Categories

(Core :: XPCOM, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla76
Tracking Status
firefox-esr68 --- unaffected
firefox74 --- unaffected
firefox75 --- wontfix
firefox76 --- fixed

People

(Reporter: alexandrui, Assigned: smaug)

References

(Regression)

Details

(Keywords: perf, perf-alert, regression)

Attachments

(1 file)

Raptor has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=95fe1470b3718d04e5c45605faedda62da140071

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

5% raptor-motionmark-animometer-firefox linux64-shippable-qr opt 51.14 -> 48.52
5% raptor-motionmark-animometer-firefox linux64-shippable-qr opt 51.18 -> 48.69
2% raptor-motionmark-animometer-firefox windows10-64-shippable-qr opt 44.59 -> 43.49

You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=25039

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a Treeherder page showing the Raptor jobs in a pushlog format.

To learn more about the regressing test(s) or reproducing them, please see: https://wiki.mozilla.org/TestEngineering/Performance/Raptor

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/TestEngineering/Performance/Talos/RegressionBugsHandling

Flags: needinfo?(bugs)
Component: Performance → XPCOM
Product: Testing → Core
Version: Version 3 → unspecified
Flags: needinfo?(jstutte)
Flags: needinfo?(jstutte)

Hi Olli, can we set a priority here?

randomly selecting P1 :)

The initial results of the tweak looked ok, triggered some more test runs.

Flags: needinfo?(bugs)
Priority: -- → P1
Assignee: nobody → bugs
Status: NEW → ASSIGNED

The tweak might not be enough, but hard to get reliable numbers.

Pushed by opettay@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2bb5b1e1caf6
reduce the time forced to be used outside animation frame callbacks, r=farre
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: mozilla75 → mozilla76

(not sure this is really fixed. So far "tweaked")

The patch landed in nightly and beta is affected.
:smaug, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(bugs)

I'm going to call this wontfix for 75 because we're at the last beta.

Flags: needinfo?(bugs)
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.