Closed Bug 1617120 Opened 8 months ago Closed 8 months ago

Picture-in-picture toggle is missing on YouTube videos on 144p quality

Categories

(Toolkit :: Video/Audio Controls, defect, P3)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
mozilla75
Tracking Status
firefox-esr68 --- unaffected
firefox73 --- wontfix
firefox74 --- wontfix
firefox75 --- verified

People

(Reporter: poke.arnold, Assigned: mconley)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Affected versions

  • 74.0a1
  • 75.0b6
  • 73.0.1

Affected platforms

  • Windows 10 x64
  • Windows 8.1 x64
  • Windows 7 x32
  • Ubuntu 18.04 x64
  • macOS 10.15

Steps to reproduce

  1. Open Firefox
  2. Go to youtube.com
  3. Open a video
  4. Set the video quality to 144p
  5. Hover the video

Expected result

  • Picture-in-picture toggle is displayed on the right side of the video.

Actual result

  • The Picture-in-picture toggle is not displayed.

Regression range
I will check if this is a regression as soon as possible.

Encountered the same issue with macOS 10.11.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Has Regression Range: --- → no
Has STR: --- → yes

This is likely due to the fact that the underlying video is less than 160px wide / high, and I suppose for 144p videos, they're probably 144 x 144.

Hey astevenson, any objection if we modify the restriction to hide the toggle for videos that are 140px or less in either dimension instead of 160px or less?

Flags: needinfo?(astevenson)
Priority: -- → P3
Blocks: videopip

No objections here, thanks Mike.

Flags: needinfo?(astevenson)

Regression range

Has Regression Range: no → yes
Regressed by: 1547795
Assignee: nobody → mconley
Status: NEW → ASSIGNED
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/155072b1601d
Reduce minimum for Picture-in-Picture video dimensions from 160 to 140 pixels. r=jaws
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla75

Verified the fix on Nightly 75.0a1 (2020-03-03) under Windows 10 x64, Ubuntu 18.04 and macOS 10.15. The issue is no longer reproducible.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.