View message/rfc822 in browser with inlined image fails

RESOLVED DUPLICATE of bug 174692

Status

()

RESOLVED DUPLICATE of bug 174692
16 years ago
14 years ago

People

(Reporter: kdriedge, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020807
BuildID:    2002080718

Open the attachment (message/rfc822) in the browser... it asks to save.

Reproducible: Always
Steps to Reproduce:
1. Compose message
2. fill in to and subject
3. in the body:
start:
<< 3a) click Insert>Image >>
<< 3b) pick and image and fill in alternate text >>
<< 3c) click OK >>
done.
4. Send
5. Find the message and save it (it should save as message.eml)
6. Open in browser.


Actual Results:  In Mozilla Aug 8, 2002: It asks to save the file.

In Mozilla 1.0: The image is broken but the data is inlined in the file.


Expected Results:  Mozilla should open this type of file in a view message
window.  Or display it correctly in the browser windows (i.e. With the body of
the message and the inline image).
(Reporter)

Comment 1

16 years ago
Created attachment 94479 [details]
rfc822 formatted message with an inline image

Comment 2

16 years ago
reporter (kevin): can you reproduce this bug with a recent build of mozilla (for
example, 1.2beta)? if so, please comment again with details. if not, please
resolve this bug as WORKSFORME. thanks.

Comment 3

16 years ago
no response from reporter. resolving WFM.

reporter - if this is still an issue with a recent build of mozilla, please
reopen and comment with details. thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 4

16 years ago
This bug report is in my opinion still valid and I can produce the same error as
described in the first posting with 1.2b running in Linux.  Could someone reopen
and have a look at this?

Comment 5

16 years ago
I can confirm that this bug has NOT been fixed in Mozilla 1.3.1 or newest
version from CVS (checkout start: Wed Jul 9 15:38:03 EEST 2003). This was tested
in a Linux environment.

I also noticed that when you right-click on the broken image icon and choose
"View  image" then you can see the image. When you go back with the
"Back"-button the image has now appeared in its correct place in the page.

Please reopen this bug!

Comment 6

16 years ago
Created attachment 128151 [details]
rfc822 message with inline image with correct content type (message/rfc822)

Comment 7

16 years ago
I added a new attachment with the content-type message/rfc822. The old
attachment didn't work because of the wrong content-type, it showed only the raw
source text of the e-mail.

I tested this bug exactly as stated in the bug description with the newest
nightly build (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624)
and the bug is still there. My previous comment on using "View image" is also
still valid.

Please reopen this bug, it doesn't seem to be resolved. Thanks!

Comment 8

15 years ago
Reopening per previous comments.

Can someone test this with a recent nightly build?
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 9

15 years ago
not sure this the right component.  confirming based on multiple reports.
Assignee: attinasi → other
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: petersen → ian

Comment 10

15 years ago
Tested with lastest nightly build for Linux:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030825

...and the bug is still there as described in the inital bug report.

Comment 11

14 years ago
see also Bug 267428 for encoding and javascript

Comment 12

14 years ago
(In reply to comment #5)
> I also noticed that when you right-click on the broken image icon and choose
> "View  image" then you can see the image. When you go back with the
> "Back"-button the image has now appeared in its correct place in the page.
same in bug 174692 comment 16 :-)

I see no differences to bug 174692. Because there is more information (and the
dupes) I would recommend to resolve this one as a duplicate of bug 174692. 


Comment 13

14 years ago
Feel free to reopen the bug if you disagree.

*** This bug has been marked as a duplicate of 174692 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.