1.0 wont start on solaris 7 [nsprpub/pr/src/io/prlog.c:510]

VERIFIED FIXED

Status

()

Core
XPCOM
--
critical
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: mcw, Assigned: dougt)

Tracking

({crash})

Trunk
Sun
Solaris
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
hi,

i am trying to build mozilla 1.0 for solaris 2.7.  after building
i type mozilla, and nothing happens.  a mozilla -splash brings up
the splash window but then nothing happens (i left it for a day,
so its not just my slow machine ;-)

details:
   i am using mozilla-source-1.0.tar.bz2
   i configure like so
         ../configure --prefix=/var/tmp/it --disable-tests --disable-debug
         --enable-optimize --disable-freetype2 --enable-crypto
         --enable-extensions --enable-toolkit-gtk
         --with-pthreads --without-system-jpeg --without-system-mng
         --without-system-nspr --without-system-png --without-system-zlib
   i build like so
         gmake ; gmake install
   then i do
         cd /var/tmp/it/lib/mozilla-1.0.0
         MOZILLA_FIVE_HOME=. LD_LIBRARY_PATH=. ./regchrome
         MOZILLA_FIVE_HOME=. LD_LIBRARY_PATH=. ./regxpcom
   then i change the first line of /var/tmp/it/bin/mozilla from
         #!/bin/sh
      to
         #!/cs/local/bin/bash
      so the script will run (/bin/sh complains, but our bash runs it
      fine)
   then i run /var/tmp/it/bin/mozilla -splash and then splash screen
   comes up then nothing, just hangs there.

any help would be much appreciated!

thx

matt

Comment 1

16 years ago
First off, I've been able to build mozilla (1.0 and more recent) fine on Sparc
Solaris 7.  Is there a particular reason that you are tring to build mozilla
instead of using the the pre-built binaries available from mozilla.org?  If you
haven't used the pre-built binaries before, please try them and make sure they
work for you.

Next, for compiling what compiler are you using?  What version of gtk?  What
error message is bin/mozilla script giving you?  That script should work fine
with Solaris 7 /bin/sh and you shouldn't have to use bash (if you do that is a bug).
Also, have you tried running mozilla out of its build directory? Just :
  cd build_dir/mozilla/dist/bin; ./mozilla &
to run mozilla and see if that works.

Post back to this bug on how that works, and we will go from there.
Component: Browser-General → Build Config
(Reporter)

Comment 2

16 years ago
>Is there a particular reason that you are tring to build mozilla
>instead of using the the pre-built binaries available from mozilla.org?  If you
>haven't used the pre-built binaries before, please try them and make sure they
>work for you.

they work fine thanks.  there are two reason for wanting to build my own. 
firstly i am building for linux, solaris sparc, solararis intel, and irix, and i
want all the achitecture independent stuff to go in one place so it can be
shared.  secondly when security advisories come out it is easier to fix whatever
the problem is if i have built from source.  i know what has been linked in and
so on.

>Next, for compiling what compiler are you using?

gcc 2.95.2

>What version of gtk?

gtk 1.2.9

>What error message is bin/mozilla script giving you?

/var/tmp/it/bin/mozilla: test: argument expected

when i uncomment the set -x in above script i get

moz_libdir=/var/tmp/it/lib/mozilla-1.0.0
MRE_HOME=/var/tmp/it/lib/mre/mre-1.0.0
+ [ -n  ] 
found=0
progname=/var/tmp/it/bin/mozilla
+ dirname /var/tmp/it/bin/mozilla 
curdir=/var/tmp/it/bin
run_moz=/var/tmp/it/bin/run-mozilla.sh
+ test -x /var/tmp/it/bin/run-mozilla.sh 
+ /bin/pwd 
here=/var/tmp/it/lib/mozilla-1.0.0
+ test 0 != 0 -o ! -L /var/tmp/it/bin/mozilla 
/var/tmp/it/bin/mozilla: test: argument expected

so perhaps my test is broken

>Also, have you tried running mozilla out of its build directory? Just :
>  cd build_dir/mozilla/dist/bin; ./mozilla &
>to run mozilla and see if that works.

actually i think it is build_dir/dist/bin, right?  anyway that didn't work, just
the same as before, hangs for ever.

i just tried a rebuild using gmake SHELL=ksh ; gmake install SHELL=ksh.  still
the same



Comment 3

16 years ago
Ok, here are some more things to try.

Try building without the with-pthreads option.  I haven't used that option
myself when building, and that seems like the type of thing that could cause
problems.  Be sure to run 'make clean' before rebuilding.

If that doesn't work, try re-building  with --enable-debug.  Then try running
mozilla under the debugger (mozilla -g) and see if you can at least find where
mozilla is getting hung up.
(Reporter)

Comment 4

16 years ago
thx for your help so far, i've been busy on other stuff but have finally got
round to doing some more building.

1.  i tried 1.1b and i don't get the shell issue (test was failing)

2.  i tried both 1.0 and 1.1b without the --with-pthreads option, but no
difference, still `hung'

3.  tried 1.0 without the --with-pthreads and with --with-debug, and got lots of
output for you!

first when i did my 
   MOZILLA_FIVE_HOME=. LD_LIBRARY_PATH=. ./regchrome
   MOZILLA_FIVE_HOME=. LD_LIBRARY_PATH=. ./regxpcom
i got loads and loads of stuff ending in:
*** Registering mdn account manager extension.
*** Registering smime account manager extension.
nNCL: registering deferred (0)
nNCL: registering deferred (0)
Getting service on shutdown. Denied.
  ContractID: @mozilla.org/js/xpc/ContextStack;1
         IID: {a1339ae0-05c1-11d4-8f92-0010a4e73d9a}
###!!! ASSERTION: Component Manager being held past XPCOM shutdown.: 'cnt == 0',
file ../../../xpcom/build/nsXPComInit.cpp, line 592
###!!! Break: at file ../../../xpcom/build/nsXPComInit.cpp, line 592

don't know if it matters.  anyway then i fired up 
/tmp/it/bin/mozilla -splash -g
and mozilla started in ddd and spat out loads more stuff and then before mozilla
appeared it _crashed_ with:
nsXKBModeSwitch::HandleMappingNotify:, file
../../../../widget/src/gtk/nsKeyboardUtils.cpp, line 154
WARNING:     gModeSwitch, file
../../../../widget/src/gtk/nsKeyboardUtils.cpp, line 155
WARNING:     gModeSwitch, file
../../../../widget/src/gtk/nsKeyboardUtils.cpp, line 156
GFX: dpi=75 t2p=0.0526316 p2t=19 depth=24
WEBSHELL+ = 1
Assertion failure: (offset < reg->hdr.avail), at
../../../../modules/libreg/src/reg.c:1538

Program received signal SIGABRT, Aborted.
0xfe959d94 in __sigprocmask () from /usr/lib/libthread.so.1
(gdb) 

so i'm guessing before when i thought it had `hung' it had infact crashed.

any clues?

thx

Comment 5

16 years ago
Ok, now we're getting somewhere.

First, its quite possible that mozilla is crashing when you run it under the
debugger, even though it just hung when you didn't run it under the debugger.

Next, to get a little more information about this crash, I'd like you to type 
"backtrace" at the debugger promt after the crash occurs and report back what it
says.  This will get us more information about what is happening when mozilla
crashes for you. Why don't you do this for a 1.1 version of the mozilla source.
Severity: normal → critical
Keywords: crash
(Reporter)

Comment 6

16 years ago
hi,

ok, i finally got time to build 1.1b and do a backtrace!  this is what i get:

Assertion failure: (offset < reg->hdr.avail), at
../../../../modules/libreg/src/reg.c:1538

Program received signal SIGABRT, Aborted.
0xfe959d94 in __sigprocmask () from /usr/lib/libthread.so.1
(gdb) backtrace
#0  0xfe959d94 in __sigprocmask () from /usr/lib/libthread.so.1
#1  0xfe94f3cc in _resetsig () from /usr/lib/libthread.so.1
#2  0xfe94eb88 in _sigon () from /usr/lib/libthread.so.1
#3  0xfe95195c in _thrp_kill () from /usr/lib/libthread.so.1
#4  0xfe9b9584 in abort () from /usr/lib/libc.so.1
#5  0xfef923c4 in Letext () at ../../../../../nsprpub/pr/src/io/prlog.c:510
(gdb) 

mmmm, any use?

matt

Comment 7

16 years ago
Well, now I can tell the source file that might be at fault. Re-assigning the
product to NSPR based on back trace.
Component: Build Config → NSPR
Product: Browser → NSPR
QA Contact: asa
Summary: 1.0 wont start on solaris 7 → 1.0 wont start on solaris 7 [nsprpub/pr/src/io/prlog.c:510]

Comment 8

16 years ago
Re-assigning based on last several touches of this file in cvs.
Assignee: Matti → wtc

Comment 9

16 years ago
This is an assertion failure:

Assertion failure: (offset < reg->hdr.avail), at
../../../../modules/libreg/src/reg.c:1538

Please reassign to the owner of that file.
Assignee: wtc → dougt
Component: NSPR → XPCOM Registry
Product: NSPR → Browser
QA Contact: dougt
(Reporter)

Comment 10

16 years ago
i just tried with 1.1 (i was using 1.1b before).  same problem.

matt

(Reporter)

Comment 11

16 years ago
just tried it on sol 9, same problem.  i wonder whats going on here, since the
precompiled packages work fine, perhaps i'm doing something silly in my build?  

anyway it does build ok and it is still crashing, is anyone actually looking at
this bug?

thx

matt
(Reporter)

Comment 12

16 years ago
solved it.  i was linking with gtk+-1.2.9 that had unfortunatly been built using
X11R5 (wow that is _old_).  rebuilding gtk+ to use X11R6 fixed the problem.

the interesting fact was that precompiled mozilla packages worked even though
mozilla-bin depended on libX11.so.4 (thats from X11R6 on solaris) AND
libgtk-1.2.so which depended on the libX11 from X11R5, so i had two completed
different X libs in there and it worked.  although, not for building.

matt
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 13

16 years ago
verified
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XPCOM Registry → XPCOM
QA Contact: doug.turner → xpcom
You need to log in before you can comment on or make changes to this bug.