Closed Bug 1617360 Opened 1 year ago Closed 1 year ago

On macOS when downloading a file, the progress bar on the dock icon does not work

Categories

(Core :: Widget: Cocoa, defect, P2)

73 Branch
x86_64
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1577120
Tracking Status
firefox73 --- wontfix

People

(Reporter: u657622, Unassigned)

Details

Attachments

(1 file)

Attached image Screenshot.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:73.0) Gecko/20100101 Firefox/73.0

Steps to reproduce:

1 - On macOS 10.15.3, start Firefox 73.0.1 from the icon in the dock.
2 - Paste https://www.mozilla.org/it/firefox/new/ into the address bar and press enter.
3 - Click on the "Download Now" button.
4 - In the window that appears, choose the "Save file" option and then click on the "Ok" button.

Actual results:

The progress bar in the dock icon appears but remains stationary.

Expected results:

The progress bar appears and advances until the file download is complete.

OS: Unspecified → macOS
Hardware: Unspecified → x86_64

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Widget: Cocoa
Product: Firefox → Core

Thank you for filing this bug. mozregression reveals that this started happening after bug 1562032 landed. :mstange, I'm hoping you could take a look.

https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=0c6e149ba01d55dfa0e21e0eed6cfa2ec9aad90f&tochange=9823d19217e209619c3f8d0e52d88119ba238fef

Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(mstange)
Priority: -- → P2
Regressed by: 1562032

It does work, it's just using a really bad color, which looks almost identical to the background.

Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(mstange)
No longer regressed by: 1562032
Resolution: --- → DUPLICATE
Duplicate of bug: 1577120
You need to log in before you can comment on or make changes to this bug.