Closed Bug 1617460 Opened 4 months ago Closed 4 months ago

"could not remove 'rustup-bin' file" when running mach bootstrap

Categories

(Firefox Build System :: General, defect)

x86_64
Windows 10
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: sebo, Unassigned)

References

(Blocks 1 open bug)

Details

When running mach bootstrap after updating to revision 4ee8b095bb52 I got the following error:

Your version of Mercurial (5.1.2) is sufficiently modern.
Your version of Python (2.7.16) is new enough.
Your version of Rust (1.40.0) is too old.
Found rustup. Will try to upgrade.
info: syncing channel updates for 'stable-x86_64-pc-windows-msvc'
info: latest update on 2020-01-30, rust version 1.41.0 (5e1a79984 2020-01-27)
info: downloading component 'rustc'
 35.5 MiB /  35.5 MiB (100 %)   1.0 MiB/s ETA:   0 s
info: downloading component 'rust-std'
 14.9 MiB /  14.9 MiB (100 %) 761.6 KiB/s ETA:   0 s
info: downloading component 'cargo'
  3.1 MiB /   3.1 MiB (100 %)   1.0 MiB/s ETA:   0 s
info: downloading component 'rust-docs'
 11.9 MiB /  11.9 MiB (100 %) 729.6 KiB/s ETA:   0 s
info: downloading component 'rust-std' for 'i686-pc-windows-msvc'
 14.5 MiB /  14.5 MiB (100 %)   1.1 MiB/s ETA:   0 s
info: removing component 'rustc'
info: removing component 'rust-std'
info: removing component 'cargo'
info: removing component 'rust-docs'
info: removing component 'rust-std' for 'i686-pc-windows-msvc'
info: installing component 'rustc'
info: installing component 'rust-std'
info: installing component 'cargo'
info: installing component 'rust-docs'
info: installing component 'rust-std' for 'i686-pc-windows-msvc'
info: checking for self-updates
info: downloading self-update

  stable-x86_64-pc-windows-msvc updated - rustc 1.41.0 (5e1a79984 2020-01-27)

error: could not remove 'rustup-bin' file: 'C:\Users\myuser\.cargo\bin\rustup.exe'
error: caused by: Zugriff verweigert (os error 5)
error: toolchain 'stable-x86_64-pc-windows-msvc' does not contain component 'rustfmt' for target 'x86_64-pc-windows-msvc'
Error running mach:

    ['bootstrap']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.
You can invoke |./mach busted| to check if this issue is already on file. If it
isn't, please use |./mach busted file| to report it. If |./mach busted| is
misbehaving, you can also inspect the dependencies of bug 1543241.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

subprocess.CalledProcessError: Command '['c:/Users/myuser\\.cargo\\bin\\rustup.exe', 'component', 'add', 'rustfmt']' returned non-zero exit status 1.

  File "d:\mozilla-source\mozilla-central\python/mozboot/mozboot/mach_commands.py", line 44, in bootstrap
    bootstrapper.bootstrap()
  File "d:\mozilla-source\mozilla-central\python/mozboot\mozboot\bootstrap.py", line 449, in bootstrap
    self.instance.ensure_rust_modern()
  File "d:\mozilla-source\mozilla-central\python/mozboot\mozboot\base.py", line 709, in ensure_rust_modern
    self.upgrade_rust(rustup)
  File "d:\mozilla-source\mozilla-central\python/mozboot\mozboot\base.py", line 757, in upgrade_rust
    subprocess.check_call([rustup, 'component', 'add', 'rustfmt'])
  File "d:\mozilla-build\python3\lib\subprocess.py", line 347, in check_call
    raise CalledProcessError(retcode, cmd)

Sebastian

Running mach bootstrap again after restarting the shell fixed the problem.

Sebastian

Status: NEW → RESOLVED
Closed: 4 months ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Resolution: --- → INVALID
Duplicate of this bug: 1617569

What version of rustup do you have? (rustup --version)

You need to log in before you can comment on or make changes to this bug.