Closed Bug 1618002 Opened 7 months ago Closed 7 months ago

Migrate performance-new browser chrome tests to only be mochitests

Categories

(DevTools :: Performance Tools (Profiler/Timeline), task, P2)

task

Tracking

(firefox76 fixed)

RESOLVED FIXED
Firefox 76
Tracking Status
firefox76 --- fixed

People

(Reporter: gregtatum, Assigned: gregtatum)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Currently we have a separate initializer that creates a fairly abstract performance-new client. I originally wanted to do this so that the browser tests would be unit tested, and not flaky. However, the new user-focused UI tests for the mochitests are proving pretty resilient, and fast. It would be easier in the migration to the new workflow to move all of these tests over to the browser mochitests, rather than browser chrome.

The browser mochitests are also testing more of the full stack of integration, and have been better at catching bugs compared to the chrome mochitests, which mostly just fail due to implementation detail changes.

The browser chrome tests previously only tested the performance-new client
from a unit testing perspective. I originally wrote them this way so that
they would be fast, and not flaky, as the client actually runs the profiler
and full browser infrastructure. However, these tests haven't been really
great at catching bugs, and the tests break pretty easy to due implementation
changes for the client.

The new browser tests have been proving fast, reliable, and great at catching
regressions. This patch moves all of the about:profiling related tests to be
exclusively mochitests.

Depends on D65148

Pushed by gtatum@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/723168776bd4
Migrate about:profiling chrome tests to only browser tests;r=julienw
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 76
You need to log in before you can comment on or make changes to this bug.