Closed Bug 1618179 Opened 8 months ago Closed 8 months ago

[about:logins] Hover effect for [Sort by] button triggered of wrong element

Categories

(Firefox :: about:logins, defect, P3)

defect

Tracking

()

VERIFIED FIXED
Firefox 75
Tracking Status
firefox-esr68 --- unaffected
firefox73 --- wontfix
firefox74 --- wontfix
firefox75 --- verified

People

(Reporter: cfogel, Assigned: itiel_yn8, NeedInfo)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image hoverBTN.gif

Affected versions

  • 74.0b8, 75.0a1 (2020-02-26);

Affected platforms

  • Windows 10/8.1, Ubuntu 18.04, macOS 10.13;

Steps to reproduce

  1. Launch Firefox, access about:logins
  2. Move the mouse towards the Sort By (Name) button;

Expected result

  • hover effect triggered when mouse reaches button;

Actual result

  • hover effect triggered before;

Regression range

  • will provide one asap;
  • might be linked with bug 1584162 at first glimpse;

Additional notes

  • attached recording with the issue;

Checking for the regression range:

This might still be linked with work on the list/button that was noticed while checking for the regression range for the reported issue.
On older versions the dropdown list was of the same width as the button; work on them appears to have changed the width of the list compared to the button when inspecting them.
In case this is relevant, for them the change appeared with this pushlog and bisecting it further pointed out to 1576029.

Has Regression Range: --- → yes
Has STR: --- → yes

@Jaws, could you check the above comment and confirm if it's accurate?
Thanks!

Flags: needinfo?(jaws)
Regressed by: 1584162
Priority: -- → P3
Flags: needinfo?(itiel_yn8)

Also add a 2px margin after the "Sort by" text to avoid having dropdown's focus ring being too close to the "Sort by" text.

Assignee: nobody → itiel_yn8
Status: NEW → ASSIGNED
Flags: needinfo?(itiel_yn8)
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9f81cd5d2a68
Fix the "Sort by" dropdown being actuated by clicking outside of its surrounding hover area r=jaws
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 75

Verified the fix with Nightly 75.0a1 (05-03-2020) on Windows 10 x64, Ubuntu 18.04 and macOS 10.13. The issue is no longer reproducible.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.