Closed Bug 1618243 Opened 5 months ago Closed 4 months ago

Checkboxes in the rule view get out of sync

Categories

(DevTools :: Inspector: Rules, defect, P2)

defect

Tracking

(firefox-esr68 unaffected, firefox73 wontfix, firefox74 wontfix, firefox75 wontfix, firefox76 verified, firefox77 verified)

VERIFIED FIXED
Firefox 77
Tracking Status
firefox-esr68 --- unaffected
firefox73 --- wontfix
firefox74 --- wontfix
firefox75 --- wontfix
firefox76 --- verified
firefox77 --- verified

People

(Reporter: mtigley, Assigned: ntim)

References

(Depends on 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(2 files)

STR

  1. Open Rules view
  2. Uncheck any declaration and edit its value
  3. Enable the declaration again to apply.

Expected Results
The declaration should appear to be enabled

Actual Results
The declaration is crossed out.

We may have regressed this when we started using <input type="checkbox"> elements (which have their own state) instead of a <div /> styled like a checkbox. When we programmatically change the state after editing a value, we probably don't change the input's checked attribute value.

Good hunch Florens, I just ran mozregression and it did confirm that this was a regression caused by bug 1491811.

Keywords: regression
Regressed by: 1491811
Priority: -- → P2
Duplicate of this bug: 1619088
Assignee: nobody → ntim.bugs
Status: NEW → ASSIGNED

:gl - did you want this to land in 76?

Flags: needinfo?(gl)

(In reply to Tim Spurway [:tspurway] from comment #7)

:gl - did you want this to land in 76?

I have pushed the changes.

Flags: needinfo?(gl)
Pushed by gluong@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/de1d34a37e59
Use checked property instead of attribute for rules view checkbox. r=devtools-inspector-reviewers,gl
Depends on: 1627695
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 77

The patch landed in nightly and beta is affected.
:ntim, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(ntim.bugs)

Comment on attachment 9133371 [details]
Bug 1618243 - Use checked property instead of attribute for rules view checkbox.

Beta/Release Uplift Approval Request

  • User impact if declined: annoying bug for web developers, see comment 0
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See comment 0
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small straightforward patch
  • String changes made/needed:
Flags: needinfo?(ntim.bugs)
Attachment #9133371 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9133371 [details]
Bug 1618243 - Use checked property instead of attribute for rules view checkbox.

Fixes a graphical glitch in rules view. Approved for 76.0b3.

Attachment #9133371 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

I have managed to reproduce this issue using Firefox 75.0a1 (BuildId:20200226213903) on Windows 10 64bit.

This issue is verified fixed using Firefox 77.0a1 (BuildId:20200409131623) and Firefox 76.0b3 (BuildId:20200409223136) on Windows 10 64bit, macOS 10.14 and Ubuntu 18.04 64bit.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.