When Mozilla is set to "offline," opening a previously downloaded message starts Remote Access.

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Backend
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Michael Graubart, Assigned: Bienvenu)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.1b) Gecko/20020808
BuildID:    2002080808

TalkBack crash report TB9126733W refers, but it contains an error. The
description below is more accurate.

I have Remote Access set to start automatically whenever an appropriate
application is started.

I downloaded a message (an online magazine, ‘Andante’, to which I subscribe). I
then set Mozilla to ‘Offline’ and disconnected Remote Access from the line. I
clicked on ‘Andante’ in the Inbox window so as to open it, and Remote Access
immediately started to connect to the line, even though the on/offline icon in
the bottom right corner of the mail window still showed ‘Offline’.

I did not wish to go online (I wanted my telephone line to remain accessible to
an expected telephone call), so I clicked ‘Cancel’ in the Remote Access window,
and then started to scroll in the window in which ‘Andante’ was partially
displayed. At this point Mozilla crashed and TalkBack opened. After filling in
(inaccurately, I am afraid) and sending the Talkback report, a ‘See Finder’
message appeared and that led to a message telling me that Mozilla had
unexpectedly quitted because an error of Type 3 had occurred.

I then tried the whole process again, with the same result (I did not, however,
send another TalkBack report), except that the final message said ‘error of Type 2’.

Reproducible: Always
Steps to Reproduce:
1. Set Remote Access to ‘Connect automatically when a TCP/IP application is
started’. 
2. Download a mail message.
3. Set Mozilla to ‘Offline’.
4. Click on the name of the message in the Inbox window.
5. When Remote Access starts to connect, click on ‘Cancel’.
6. Start to examine the message (try scrolling down).

Actual Results:  4. – 5.: Remote Access starts to connect.
6.: Mozilla crashes.

Expected Results:  4. – 5.: Remote Access should not be activated.
6: In any case, Mozilla should not crash when examining a downloaded message
while offline.

Mac G3 (old beige). OS 9.2.2. Classic theme.  Remote Access set to start
automatically.
(Reporter)

Comment 1

16 years ago
Created attachment 94612 [details]
Saved mail messagewhich caused the malfunctioning

This was the message that caused the sequence of events detailed in my report.
(Reporter)

Comment 2

16 years ago
I have now discovered that this misbehaviour (both the unwanted starting of
Remote Access and the crashing after scrolling) happens not only with the
downloaded ‘Andante’ message in the Inbox, but also with the saved .eml message
on my desktop. But I have also discovered that it is special to this particular
message, and does not happen with other e-mails. 

In the case of the ‘Andante’ message saved to my desktop, Remote Access started,
I clicked ‘Cancel’, I started to read the saved message, I then scrolled down a
little, but it was several seconds before Mozilla crashed. This time, though, it
made my computer crash also!
(Assignee)

Comment 3

16 years ago
um, wouldn't it be talkback that's making the network request and causing remote
access to get invoked? If you turn off talkback, I doubt remote access would get
invoked. Why you're crashing (the actual problem), I don't know. 

Comment 4

16 years ago
Using same 20020808 on mac 9.2.2, I couldn't bring
remote access up (no modem) but I did download
the mesg, went offline and tried reading it and I had
no problems. no crash.

Tried scrolling and no problems.

Updated

16 years ago
Summary: When Mozilla is set to ‘offline’, opening a previously downloaded message starts Remote Access. → When Mozilla is set to "offline," opening a previously downloaded message starts Remote Access.
(Reporter)

Comment 5

16 years ago
Dear Bienvenu,

No, I don't think so, because Remote Access gets started before there is any
question of TalkBack. The crash only occurs after Remote Access has been
cancelled and I have returned to the message. And TalkBack is the last link in
the chain, being triggered by the crash and not before.
(Reporter)

Comment 6

16 years ago
Dear Bienvenu,

No, I don't think so, because Remote Access gets started before there is any
question of TalkBack. The crash only occurs after Remote Access has been
cancelled and I have returned to the message. And TalkBack is the last-but-one
link in the chain, being triggered by the crash and not before, the last one
being Remote Access starting up for the second time.
(Reporter)

Comment 7

16 years ago
Dear Qchan,

That is a different situation. It is only the unwanted starting of Remote Access
and its cancellation that leads to the crashes.
(Assignee)

Comment 8

16 years ago
well, that message has html in it which might try to generate some network
protocol (though the Mozilla networking code should not do so when offline) -
what exactly do you mean, "Remote Access set to start automatically whenever an
appropriate application is started."? Usually, those things are dial on demand,
where whenever a network connection is attempted, the dialer gets invoked, and
really have nothing to do with applications per se.

Comment 9

16 years ago
Related to bug 161776?
(Assignee)

Comment 10

16 years ago
pretty darn good bet that it is the same bug.
(Reporter)

Comment 11

16 years ago
If you were to open Remote Access and click on Options, you would find 'Connect
automatically when starting TCP/IP applications'. When this is checked, as I
have done, Remote Access dials and begins to connect to the internet immediately
after a browser, or Sherlock, or many other applications, are started. In
Netscape 4.79, if it is set to start offline or is made to go offline, it does
not start Remote Access. In Mozilla – at least in the case of that particular
message – it did.
(Assignee)

Comment 12

16 years ago
Michael, I don't have a mac here, so I couldn't do that. thanks for the info -
my guess is that the text in that options dialog is misleading and remote access
is just invoked whenever a tcp connection is attempted, not when an application
that might require tcp is launched. Anyway, I think bug 161776 is what's causing
the connection to get attempted. I'm not sure about your crash - there's no
valid stack trace there. But, as you say, if the connection was not attempted,
i.e., bug 161776 was fixed, then you wouldn't have problem.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 13

16 years ago
Bienvenu (what a good name!), Thanks for both comments, and I shall try deleting
the 'Sent' file.
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".
(Assignee)

Comment 15

15 years ago
wfm
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.