GUI for for New List: drag & drop doesn't work

VERIFIED DUPLICATE of bug 143355

Status

VERIFIED DUPLICATE of bug 143355
16 years ago
14 years ago

People

(Reporter: twhall, Assigned: racham)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.0) Gecko/20020529
BuildID:    2002052918

The graphic interface for building a New List is crippled.  The instruction is
to "type names or drag addresses", but nothing outside of that dialog reacts
to mouse clicks.  Moreover, the dialog obscures the address book's content pane
and can't be moved.  It's impossible to drag anything into the list.


Reproducible: Always
Steps to Reproduce:
1. Pull down "Window / Address Book"
2. Click on an address book in the left pane to expose its contents
3. Click the "New List" button in the top tool bar.
4. Try to drag an address from the obscured pane into the new list.

Actual Results:  It's impossible to select anything outside of the "New List"
dialog.

Expected Results:  I expect to be able to move the "New List" dialog as
necessary to unobscure the main address pane, to be able to select addresses
in the main pane, and to drag them into the "New List" dialog.

Work around is to create an empty list, close the "New List" dialog, then drag
addresses from the main pane onto the list's small icon in the left pane
(assuming that the address-book's hierarchy is expanded).  This copies
addresses into the list.  The copy is confirmed in the status line at the
bottom of the window.  However, the list icon does not highlight.  It _looks_
insensitive, but it works.

Comment 1

16 years ago
Confirmed using FizzillaCFM/2002080508. Because New List is modal, and a sheet,
it isn't possible to drag anything to it.

See also bug 58485 on the OS 9 side, and see bug 58485, comment 32 for a
proposed solution.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 143355 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.