iframe layout error when loading directly to a hash

RESOLVED DUPLICATE of bug 137982

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 137982
16 years ago
16 years ago

People

(Reporter: Frankie, Assigned: Marc Attinasi)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
I've seen this problem for a few months. Finally ran a bug query today but
didn't find anything exactly comparable. Apologies if I missed one and this is a
dupe.

If you load a URL with a hash (#string) that requires the page to be scrolled
down, and the page has an iframe above the hash, then the iframe will often load
in the position as if the scroll were at the top of the page. In other words,
you get an iframe floating in the middle of the desired content, blocking your view.

Another example: http://www.macslash.org/comments.pl?sid=02/07/30/1013221&pid=3#5

Comment 1

16 years ago
WFM, 2002-08-06-14 (trunk) on Linux.

Frankie, which build were you using?
Please attach a screenshot. Thanks.

Comment 2

16 years ago
Confirming with the OS X 2002-08-07-05 NB. This is a known Mac only issue (OS X
- OS 9.1) and is a duplicate of http://bugzilla.mozilla.org/show_bug.cgi?id=137982

*** This bug has been marked as a duplicate of 137982 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.