Download (save/save as) does not work

RESOLVED WORKSFORME

Status

Core Graveyard
File Handling
--
major
RESOLVED WORKSFORME
16 years ago
2 years ago

People

(Reporter: Chris Winne, Assigned: Bill Law)

Tracking

({qawanted})

Trunk
Other
AIX
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: checkmac, checklinux, checkwin)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; AIX 0001B53F4C00; en-US; rv:1.1a) Gecko/20020612
BuildID:    2002072311

Save/Save As simply will not save any file.  This is version 1.1 beta for AIX. 
Version 1.1 alpha works.

Reproducible: Always
Steps to Reproduce:
1.Try to download a file, ftp or http
2.
3.

Actual Results:  When I click on a link to download (or use "save as"), the
dialogue box says "Downloading <tmpfile> ..." in the title bar. The dialogue
reads <tmpfile> could not be saved because the source file could not be read. 
Try again later, or contact the server administrator."  Note that <tmpfile>
varies and is the name of the tmpfile in my $TMP directory, not the actual name
of the file on the server.

Expected Results:  I expect the file to be saved.  Typically the title bar has
the name of the actual file on the server.

I do notice that there is no libnullplugin.so in the mozilla/plugins directory
in the 1.1 beta version.  The behaviour is the same whether I leave it as is, or
add the libnullplugin.so to that location from the 1.1 alpha build.  This is on
an RS6000.
any permission problems about the tmp-folder?
tried a fresh profile?
Summary: Download (save/save as) does not work → Download (save/save as) does not work
(Reporter)

Comment 2

16 years ago
I tried a fresh profile ... no change.

Also, I own the tmpdir and the tmpfile is created, however it has 0 bytes while
the dialogue box is still up (and deleted after the box is dismissed).  However,
one development.  If I click on the link to download again (in this case
immediately, which may or not matter), another tmpfile is downloaded, but no
dialogue box pops up asking where to save the file and the file is not copied,
but remains in the tmpfolder with its temporary name.

Comment 3

16 years ago
-> file handling, aix qawanted

I have not seen similar reports in Networking in the time frame of your build date.

Possibly AIX only?
Assignee: new-network-bugs → law
Component: Networking → File Handling
Keywords: qawanted
QA Contact: benc → sairuh
Whiteboard: checkmac, checklinux, checkwin
QA Contact: sairuh → petersen

Comment 4

15 years ago
Resembles bug 171441 / bug 162593
Reporter: does deleting compreg.dat help?

Comment 5

15 years ago
This problem exists on Windows as well, but I cannot reproduce it under Linux.
(Reporter)

Comment 6

15 years ago
As of the version 1.2 series (currently 1.2.1), the problem no longer exists on
AIX. I really could not say about Windows.  For me, it is resolved as FIXED.

Comment 7

15 years ago
resolving wfm per comment 6
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.